Jump to content

Ethernet STOPPED working on HackBook: Acer Extensa 5220, HELP!


7 posts in this topic

Recommended Posts

Hi all.


A few days ago I successfully installed Kalyway Mac OS 10.5.2 on my Acer Extensa 5220, after a full-on day of solid research.


Plenty of trial and error, and 100's of viewed forums (so it seemed) later I finally found how to get ethernet working! - And stoaked I was!


Anyway, a few days later, my ethernet connection STOPPED working properly - I'm not 100% sure why, -I have no idea why- and I hope someone here can help me out! Simply reinstalling the OS and re-applying all the fixes, is not a happy thought as I've already spent hours personalizing my new HackBook as my own!


Here are some details..



When the ethernet worked fine;

I plug in my ethernet and away we go, the correct IP address is assigned and the internet charges! The connection details are as follows...


IP ADDRESS: 192.168.1.xxx


SUBNET MASK: (I think it should be, but it auto-corrected itself, and this is the number that works, so hey)






--I'm sure all these numbers are correct because I copied them from my PlayStation (I'm not my network administrator) and they internet worked fine while using these numbers.




I plug in the ethernet and a bunch of random numbers that mean nothing to me are assigned for the IP. - hopefully these numbers mean something to someone out there.


*IP ADDRESS:* :confused:






DNS SERVER: (Ffor some reason had to fill this one out myself to get the ethernet to work, it didn't find the information itself. Also, please correct me if I'm wrong, I think the ROUTER is [bLANK] because the DNS I have here is from a different access point, not the one I'm currently trying to connect to. ??? :/) - you see I'm very new to this kind of thing.



Possible reason;

I noticed the change shortly after installing software to run my NZ Vodem (portable wireless) on my HackBook. I downloaded the installer from the official Vodafone site, that works fine and I can connect to Vodafone network effortlessly. However shortly after using the Vodem I noticed the ethernet connection would no longer work properly.

I've tried uninstalling the Vodem's software, but this didn't 'let' my computer find the right IP address.


I'm not 100% sure if the Vodem caused it - I used a lot of different programs (testing them) and played around a lot (not with any system files or anything like that) - This is my first "Mac" machine, ever, so a good ol' fashion toh-too was in order.

I've tried reapplying the ethernet fix for the Broadcom ethernet chip inside the machine, this didn't do the job.


In Network preferences, it says the ethernet is connected, *I'm convinced, the only problem has something to do with installing the Vodem software, but to be honest, at the end of the day, I have no idea what the problem is.


It is just my machine with the problem, I have tried many other computers running Mac OS, XP. I have also tried the ethernet in more than one home, at different access points. *just to knock out that possible reply.


I tried to leave as much detail as possible, please someone help me! I'm eager to learn how to fix these types of problems. As I'm a new Mac user, I really have no idea what's going on.


Oh if anyone missed it, I have a Broadcom chipset.


I thank you in advance,



Link to comment
Share on other sites

I'm blown away.


After using my VODEM again just now, I decided to try to access the internet again with an ethernet and the correct IP is shown, the internet works!


I'm very confused as to how this happened.. or why it happened.. and if anyone has any information I'm all ears.



Link to comment
Share on other sites

Ok.. Problem still exists.


The ethernet sometimes works... sometimes doesn't.

It's very fustrating.


I did some research, turns out these numbers are made up by your computer.

After trying to reach the modem for an IP, and failing, the computer will make up it's own IP, using these numbers.


This could be a result of a broken ethernet, as well as other things. (not in my case)


Can anyone help me?? As I am using Kalyway 5.5.2 build, I think the MAC address of my computer is not proper.. Can someone confirm? I remember reading somewhere during installation that if I wanted to change MAC address do this (...) but I have lost the document.

What I'm getting at - Is it possible my 'hackintosh' has the same MAC address as another Mac computer in my house? I cannot get to this computer to check. If it does have the same MAC address, reason for there being no IP could be 'cause there's already that computer on the network.. ????


- if the above isn't reason, then could it have something to do with the vodem? I'm more leaning towards this direction, the above guess was just that, a guess.


I'm really just throwing balls with my eyes shut here. Hoping for the swish.


Please help if you have any infomation!

Link to comment
Share on other sites

  • 2 weeks later...

I've performed a clean install, I still have the same problem.


It must be a damaged cable, perhaps the -female- part of the PCI card on my laptop. The ethernet works fine in Vista and XP on my machine, and my flatmates legit Mac Os, perhaps Mac OS 10.5.2 is a bit more serious than Windows when it comes to damaged hardware.


That's all I can make of it. It's a bit upsetting, but what can you do.


I've currently ditched the idea and started trying to get my Atheros AE5007EG working (wifi). I'm not having much luck following oldmaclover's guide.


If anyone comes across this thread and has some info please share :rolleyes:

Link to comment
Share on other sites

sudo killall mDNSResponder


Thanks for your reply. Within the corners of your knowledge, would this command still work even after a clean install?


This did not fix my problem.

If you answered no to the above question, I've already wiped the HDD and reinstall kaly 10.5.2.


If it doesn't matter whether you have performed a clean install or not, I would assume this command does some magic with the router itself? I would like to add I do not have administrative rights on my home network.


Perhaps you can help me further.



Link to comment
Share on other sites

Problem solved.


After weeks of stress and late nights of research I called my ISP for help. I wish I had done this in the first instance!


The problem was the DNS was wrong




I can't believe I could be so stupid.


The DNS was fetched automatically so it wasn't by wrong input on my part, my ISP told me the DNS that was not there was not the right one for my router.


So there! Problem solved!


If anyone has the same problem, which I know a lot using Leopard do (thanks to google) check DNS settings!


Thanks to those who helped!

Link to comment
Share on other sites


  • Create New...