Jump to content

Intel 82573L Gigabit Ethernet

11 posts in this topic

Recommended Posts

  • 4 months later...
  • 2 months later...

hi guys..... with the 82573L Gigabit Ethernet Controller everytime I reboot or I shut down and boot the next time, the system do not recognize the Lan....


to make it "run", I have to unplug and plug the ethernet cable, with the computer on....


any ideas?



Link to comment
Share on other sites

Hey there,


For me this ethernet controller doesn't work. In my case it could be connected with PCI Express bus not working properly. Still trying to figure out what's wrong with it. Any suggestions? BTW. Which kext's you're using?




Link to comment
Share on other sites

  • 3 months later...

Hello eveybody!


Same problem as misterd, my 82573L Gigabit Ethernet everytime when I shut down and boot the next time, the system do not recognize my network interface, I have to unplug and plug the ethernet cable, with the computer on. I put a little script in /etc/rc.local with ifconfig -i eth0 down; sleep 3; ifconfig -i eth0 up, but 1/2 this doesn't work correctly.


Any ideas?

Link to comment
Share on other sites

  • 2 months later...

I had the Intel 82573L network working fine in my Thinkpad T60 when I first installed the JaS 10.4.8 DVD. No problems at all.


Then I updated using the JaS 10.4.9 Updater. Still worked fine.


Then I updated using the 10.4.10 Intel updater. Now the network doesn't work at all.


I tried going back to the AppleIntel8254XEthernet.kext from the original 10.4.8 DVD but it still doesn't work.


My /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist still show it using that kext.


The other thing I did was check the AppleACPIPlatform.kext/Contents/Plugins/AppleACPILPC.kext/Contents/Info.plist to make sure my Intel PCI Bridge device IDs were present. They are.


My guess is that there is something that broke in the kext from the 10.4.10 update but the new kernel doesn't work with the kext from 10.4.8.


Any ideas with this info?

Link to comment
Share on other sites

  • 1 month later...

Hello all.

I've solved - at least for me - the problem with this Intel 82573L and OS X 10.10.

I do also tried 10.5 B uild 9A527 and keep working.


What I've done to make it works.


I have a Intel BadAxe II D975XBX2 board.


After upgrading to 10.4.10 (with koolkal 10.4.9 to 10.4.10 upgrader) the ethernet giga went out of business...


I was able only - and not always - to have working (without touching anything) using DHCP.


But no way to have a manual fixed IP.


What I have done.


Yes need to reinstall to thin g.


I could not find any other way: sorry for that...


I use XxX 10.4.10 image. You can (hardly?) find it on Torrent.


I've installed an almost plain distrib. No driver noi other stuff.


The sooner I've booted and configued the system again the ethernet was not working: red fdot on Network config.

What I have done (since I was almost desperate...) installed alone the following packages over the already installed not working one:



This can be found in the XxX 10.4.10 installation dir here:



After that I've done usually housekeeping stuff:

rebuild permission in diskutil

erase Kext caches



After booting the darn thing was workibg back...


I've halted an reooted the x86 box many times and always worked with DHCP and manual IP addresses.


It works for me.


Didn't check anything else since it was working.


Hope it helps.

Link to comment
Share on other sites

Yep IONetworking 10.4.3.

I've had mine working for a week now, no problems with automatically logging on with DHCP anymore, dont use manual address so can't say anything about that.

It didn't require a fresh install though, just installed with kexthelper.


I also use XXX 10.4.10 haven't tried with any other versions but I suspect it was simply the kext.


The Asus wireless still keeps disconnecting, but I guess that's a different issue.

Link to comment
Share on other sites

  • 2 months later...

hi i've the same intel but, leopard toh have a good installation only if ethernet is deactivate from bios.i've deactivated, installation it's ok, but if i try to able ethernet from bios, ihava a kernel panic in 3 language.there is a solution?please

Link to comment
Share on other sites

  • 11 months later...

  • Create New...