Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
lixuelai

rEFIt reinstall problem

4 posts in this topic

Recommended Posts

refit somehow stopped working on my 2.4GHz Unibody MBP. Tried reinstalling to no avail. It just goes straight into OSX and I have to hold down option to get the default Mac OS selector. Tried reinstalling everything and still no go. Here is my partition analyzer output:

 

*** Report for internal hard disk ***

 

Current GPT partition table:

# Start LBA End LBA Type

1 40 409639 EFI System (FAT)

2 409640 312623143 Mac OS X HFS+

3 312887296 625141759 Basic Data

 

Current MBR partition table:

# A Start LBA End LBA Type

1 1 409639 ee EFI Protective

2 409640 312623143 af Mac OS X HFS+

3 * 312887296 625141759 07 NTFS/HPFS

 

MBR contents:

Boot Code: Unknown, but bootable

 

Partition at LBA 40:

Boot Code: None (Non-system disk message)

File System: FAT32

Listed in GPT as partition 1, type EFI System (FAT)

 

Partition at LBA 409640:

Boot Code: None

File System: HFS Extended (HFS+)

Listed in GPT as partition 2, type Mac OS X HFS+

Listed in MBR as partition 2, type af Mac OS X HFS+

 

Partition at LBA 312887296:

Boot Code: Windows BOOTMGR (Vista)

File System: NTFS

Listed in GPT as partition 3, type Basic Data

Listed in MBR as partition 3, type 07 NTFS/HPFS, active

Share this post


Link to post
Share on other sites

this is most likely caused by using the bootcamp selector from inside windows to reboot into osx, or from inside osx using the utility that chooses your boot device.

simple solution:

Never use the 2 methods above to reboot your system into the other OS unless you want to break rEFIt.

Always use Start --> shutdown/restart/hibernate/sleep whichever you need or Apple menu --> shutdown/restart/sleep.

To fix your rEFIt just go to the drive you installed it to (most likely Macintosh HD) and open the EFI folder and open the REFIT folder and look for "enable-always.sh"

now open Terminal and drag and drop "enable-always.sh" into Terminal

Terminal will need your root password, enter it then reboot and you will see rEFIt.

Share this post


Link to post
Share on other sites

Hmm, thats strange. Can you boot into win7 by holding down the option key? rEFIt does some strange things sometimes. When I had it installed in a very similar situation it would always show two windows drives. I wonder if chameleons boot loader would work for you.

Share this post


Link to post
Share on other sites

NO! you never ever put a hackintosh bootloader such as chameleon on a real mac! it will screw up your boot up.

he should be able to boot to win7 by holding option key the win7 bootloader is installed to the efi style "reserved partition" that will be the one to boot from.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×