Jump to content
woody303

OSX 10.6 SL auf Platte mit MBR installieren ?

23 posts in this topic

Recommended Posts

Hallo,

 

ichversuche schon Tage ein OSX 10.6 SL Retail auf meinr Platte (MBR) zu installieren.

Jedoch immer noch ohne erfolg :pirate2:

 

Nun habe ich mir eine IMG der DVD gebaut in welcher ich die OSInstall.mpkg in /Volumes/OSX86/System/Installation/Packages geändert.

 

Jedoch findet der Installer immer noch keine Partion. (Gleiche Meldung wie bei nicht angepasster OSInstall.mpkg)

 

Muss ich da noch wo ne Datei anpassen?

 

Bitte im Hilfe :)

 

Gruß Woody

Share this post


Link to post
Share on other sites
Advertisement
Der mbr-patch besteht aus 2 Dateien; es wird noch nen Framework geändert und installiert wird von USB-Stick.

 

Hallo,

 

hab ich auch schon wo gelesen,

jedoch finde ich da im IMG nichts.

 

Hat einer nen link ?

Share this post


Link to post
Share on other sites

Man braucht keine 2. Platte, ich habe die SL DVD auf ein externes Laufwerk (mit CCC) geklont, anschließend die OSInstall.mpkg mit folgender Datei ersetzt:

 

OSInstall.mpkg.zip

 

Anschließend einfach das Setup mit dieser Datei starten, fertig

Share this post


Link to post
Share on other sites

Hallo,

 

so nun läuft die Installation auch mit MBR based Platten.

 

Mann muss 2 Dateien austauschen !!!

 

HowTo

 

Die orginal OSInstall.mpkg Datei mit der angepassten OSInstall.mpkg ersetzen!

Der Pfad: /System/Installation/Packages/

 

Die orginal OSInstall Datei mit der angepassten OSInstall ersetzen!

Der Pfad: /System/Library/PrivateFrameworks/Install.framework/Frameworks/OSInstall.framework/Versions/A/

 

So nun müsset OSX 10.6 SL auf MBR based Platten sich installieren lassen.

Und somit auch ein dualboot möglich sein.

 

Gruß Woody

Share this post


Link to post
Share on other sites

Hallo,

also das mit der Leistung will ich hier mal ned so stehen lassen.

 

Die Leistungsaufname eines Netzteiles ist abhängig von den angeschlossenen Geräten, wie z.B. HDD, GK, RAM,CPU, ....

Da sich die Leistung aus P=U*I wobei P die Leistung in Watt, U die Spannung in Volt und I die Stromstärke in Ampere ist

 

Also die Watt angabe auf einem Netzteil bezieht sich immer auf die max. Leistung die abgegeben werden kann.

 

 

Gruß Woody

Share this post


Link to post
Share on other sites

Hallo Pinarek,

 

also sparen wirst ned viel denk so max 20-30 Watt.

 

aber zu deinem MBR- Prob

 

Also du nimmst deine Retail DVD machst mit dem Festplattendiensprogramm ein dmg wobei du schreiben/und lesen auswählst.

 

Nun müsstest du das DMG der Retail im finder als VT Laufwerk öffnen können (doppel click)

 

Jetzt folgs du einfach dem Howto.

 

Die orginal OSInstall.mpkg Datei mit der angepassten OSInstall.mpkg ersetzen!

Der Pfad: /System/Installation/Packages/

 

Die orginal OSInstall Datei mit der angepassten OSInstall ersetzen!

Der Pfad: /System/Library/PrivateFrameworks/Install.framework/Frameworks/OSInstall.framework/Versions/A/

 

OSInstall_SLeo

 

Wenn du die Dateien getauscht hast, gehst du wieder in das Festplattendienstprogramm und brennst das DMG.

 

Nun kannst du ganz normal der Anleitung von NEXOS folgen.

 

P.S. Bei Windows 7 würde ich erst die OSX 10.6 booten, dann die 1 Partition als Fat formatieren, und die 2 Partition OSX Jornaled EX. So wenn du es soweit hast musst du die Windows 7 DVD booten und die 1 Prtition (Fat) wieder formatieren.

Widows 7 installieren und fertig.

 

Erst dann würde ich OSX nach der Anleitung von NEXOS installieren, da Windows 7 ein anderes NTSF Format als XP und OSX hat. (Wenn erst osx installiert ist zickt die Windows 7 installation)

 

 

So nun müssten all dein Fragen beantwortet sein ;)

 

Gruß Woody

Share this post


Link to post
Share on other sites
Habt Ihr vielleicht ne Idee wie ich das OHNE alles neu zu installieren, auch so

machen kann ? ich habe z.B. immer von meiner altuellen SL-Partition ein Image mit dem

festplatten-dienstprogramm erstellt, aber eben unter der GUID-Platte

 

Probiers einfach mit dem Tool CCC (Carbon Copy Cloner), sollte denke ich kein Problem sein. Den Bootloader wirst du in jedem Fall neuinstallieren müssen, aber der Rest sollte gehen.

 

Das Ersetzen meiner verlinkten Datei reicht aus, sonst würde ich jetzt nicht schreiben können :D

 

Ich hab Win7 noch drauf, allerdings nur noch für Games sobald ich alle Probleme mit SL beseitigt habe

Share this post


Link to post
Share on other sites

Ich hab am WE SL auf ne MBR-Platte (AHCI, Port0) mit XP installiert. Boot von EFI/USB-SL-MBR-patch

Install Stick.

 

1. Update der Leo iDeneb 10.5.5 auf der HD ging nicht -> Fehler, beim zweiten Mal

war die Partition verschwunden. Partition dann mit dem FDP gelöscht.

2. Clon von USB-Platte einer SL Installation auf intern MBR mit FDP 2x fehlgeschlagen

3. Clean-Install von SL über USB-Stick 2x auf MBR fehlgeschlagen lt Apple, aber boot- und updatebar.

Installierter Bootloader: Cham RC3/ PC-EFI 10.4 DSDT

 

System läuft, aber verschiedene Ungereimtheiten, die ich noch verfolgen muss:

 

- Pacifist meldet Fehler und startet nicht, ist aber 2.52.

- Ralink.kexte lassen sich nicht instaliieren, obwohl für 10.6. Fehler: SE nicht verwendbar, aber Rechte ok.

 

Keine BSD-Fehler.

 

btw: Merkwürdigkeiten2 ASUS-WLAN PCI geht jetzt auch mit DSDT, aber neue MAC??? Hat ne Weile gedauert, bis ich die MAC mit der im Router gespeicherten, verglichen habe. Kam nämlich nicht ins Netz, obwohl die Karte schon Monate im MAC-restringierten Netz benutzt wurden ist.

 

wbc...

Share this post


Link to post
Share on other sites

1. Pacifist: bei der Installation wurde offenbar das prebindung nicht abgeschlossen, und der link update_prebinding in usr/bin auch nicht angelegt. Nachdem der link gesetzt war und die prebindings erneuert wurden, geht auch Pacifist.

 

2. Ralink-Treiber werden nur geladen beim Booten mit -f??? Wieso das???

Share this post


Link to post
Share on other sites

Hallo zusammen,

 

ich brauche Eure Hilfe bei meiner Snow Leopard MBR Installation. Vorab meine Systemdaten:

 

- CPU: Intel Core2Duo E8400

- RAM: 2 GB GEIL Black Dragon

- MoBo: GA-E7AUM-DS2H

- HDD: Samsung F1 HD103UJ SATA

- DVD LW: LG GSA-H62N SATA

 

Für die Installation selbst, habe ich mich an diese Anleitung hier gehalten *Klick*

 

Mein erstes Problem ist der bootfähige USB Stick. Versuche ich die ISO aus dem Guide auf dem USB Stick wiederherzustellen, erhalte ich die Info es würde nicht gehen, da ich sie vorab "überprüfen lassen" muß. Sobald ich das versuche, erhalte ich allerdings einen Fehler (ungültiges Atribut).

 

Darauf hin habe ich also die ISO Datei in eine .dmg Datei konvertiert. Diese lässt sich auch wiederherstellen, bootet allerdings nicht. :D Bei der Formatierung habe ich darauf geachtet daß "MBR" aktiv ist und im Bios ist der Start von USB auch aktiv. Mache ich was falsch, oder liegt es an der ISO Datei?

 

Dieses Problem konnte ich "umgehen", indem ich mir den Rebel EFI Bootloader zum Starten besorgt habe. Die Installlation selbst habe ich dann auch erfolgreich ausführen können. Problematisch wird es dann wieder mit dem Terminal. Davon habe ich überhaupt keine Ahnung. Mit etwas Hilfe der englischsprachigen "Kollegen" bin ich etwas weiter gekommen. Um genau zu sein bis zu dem Punkt an dem ich die "com.apple.boot.plist" bearbeiten muß. Versuche ich mit "Nano" über das Terminal meine Änderungen zu speichern (CMD+W) erhalte ich immer ein .save File (z.B. com.apple.boot.plist.save). Gleiches gilt für die "Info.plist" (/Extra/Extensions/PlatformUUID.kext/Contents/Info.plist -> Info.plist.save). Was mache ich falsch? Gibt es evtl. eine andere Möglichkeit die Dateien zu editieren, z.B. mit dem BBEditor oder so?

 

Als Letztes habe ich noch Probleme mit dem Dualboot SL + Windows 7. Nachdem ich Windows 7 installiert und Chameleon 2 RC3 unter SL erneut ausgeführt habe, startet sofort Windows 7. Ich habe keine Auswahlmöglichkeiten. Liegt das an der Chameleon Konfiguration, oder habe ich was falsch gemacht?

 

Ich bin Euch für jede Hilfe dankbar, da mein Englisch leider nicht das beste ist.

Share this post


Link to post
Share on other sites

Pinarek, besten Dank für den FDISK Tipp!!! Das werd ich auf alle Fälle ausprobieren sobald ich Zuhause bin. Sollte ich mit der USB Variante wieder Probleme bekommen, werd ich definitiv von CD installieren. Wobei, heißt es nicht daß die MBR USB Installation für den Dualboot notwenig ist?

 

Das "Nano" Problem konnte ich in der Zwischenzeit auch lösen. In dem englischen Guide habe ich einen falschen Befehl zum Datei speichern bekommen. Es sollte CMD+O anstatt CMD+W heißen. :(

Share this post


Link to post
Share on other sites

So, nachdem ich über FDISK meine nicht DOS Partition auf aktiv gesetzt habe, war dies das Ergebnis...

 

chameleon2rc3dg6n.jpg

 

An dieser Stelle lässt sich auch nichts weiter auswählen. ;) Irgendwie ist das alles zum Mäusemelken. Hat evtl. irgendwer noch die zündende Idee?

Share this post


Link to post
Share on other sites

Also ich möchte Dir jetzt echt nicht zu nahe treten pinarek, aber manchmal tut es ganz gut erst zu denken und dann zu schreiben. :D

 

Was heist, "war dies das Ergebnis" ? na ist doch ok !!!

Bist du denn mal auf die Idee gekommen auf das umrandete Apfelsymbol zu drücken ?

indem du mit den Pfeiltasten Links und Rechts auf der Tastatur auswählst und dann Enter drückst.

 

Siehst doch das mein Tipp richtig war ! du bist undankbar !!! Jetzt bootet doch die Platte von

der Mac-Partition, das ist doch schon sehr gut.

 

Es wird Dich vielleicht wundern, aber ja, das bin ich! :D Wie Dir als IT-Fachmann allerdings sofort aufgefallen ist, hat der Chameleon scheinbar Probleme und es lässt sich rein GARNICHTS auswählen.

 

 

Wie ich aber sehe hast du beim Partitionieren schon wieder Mist gebaut.

Da ist also eine NTFS (Windows) dann sehe ich die Mac in der Mitte (also HFS) und dann noch eine

NTFS, was soll das denn ? Mensch mir scheint Ihr (Du bzw.) habt nicht mal bischen Erfahrung mit

DOS-Grundkenntnissen und dem Thema, wie erstelle ich Partitionen usw.

 

Das sehe ich einwenig anders. :) Wie ich meine Festplatte partitioniere solle bekanntlich mir überlassen sein.

 

Wenn ich jetzt mal Klartext spreche, würde ich es so formulieren: keine Ahnung von PC aber Mac auf

Intel-PC laufen lasen wollen. Ich bin 56 und kenne mich seit ca. 18 Jahren mit PC aus. Möchte gerne mal

wissen wie Jung und unerfahren du noch bist ???

 

Ich finde Du solltest einwenig auf Deinen Schreibstiel achten! Nicht jeder reagiert NOCH so freundlich wie ich auf eine solche "Niveaulosigkeit". Von einem 56 jährigen hätte ich mir dann doch einwenig mehr erwartet! Zudem finde ich es extrem anmaßend und unverschämt mich als unerfahrenen Jüngling der nichts auf die Kette bekommt zu betitteln.

 

 

Zu dem Rest enthalte ich mich mal, da der Thread jetzt schon zu genüge vollgespamt wurde. Falls jemand noch konstruktive Ansätze hat, wäre ich dankbar wenn er / sie diese hier posten würde.

 

 

PS.: Dein Supertipp mit FDISK hat lediglich zur Folge daß mein Mac OS warum auch immer extreme Probleme nach dem Booten hat. Vielen Dank dafür!!! Möchte ja nicht undankbar sein :) Achja, bitte verkneife Dir eine Antwort auf meinen Beitrag!

Share this post


Link to post
Share on other sites
So, nachdem ich über FDISK meine nicht DOS Partition auf aktiv gesetzt habe, war dies das Ergebnis...

An dieser Stelle lässt sich auch nichts weiter auswählen. ;) Irgendwie ist das alles zum Mäusemelken. Hat evtl. irgendwer noch die zündende Idee?

 

?? Die Mac-Partition ist doch ausgewählt??? Was passiert denn, wenn du enter drückst??

Share this post


Link to post
Share on other sites

@idsynk

Danke der Nachfrage. Chameleon macht an dieser Stelle nichts! Ich kann garnichts auswählen. Der Rechner hängt sich einfach an dieser Stelle vollständig auf. Ich vermute mal daß FDISK irgendwas verändert was es nicht soll. Wie bereits beschrieben, habe ich seit der FDISK Anwendung extreme Probleme unter SL (Finder reagiert nicht usw.). Es gibt ja scheinbar auf der Windows 7 DVD das Tool Diskpart. Das könnte mich der Lösung evtl. etwas näher bingen. Die Funktionen sind vergleichbar mit FDISK. Ansonsten bin ich für jeden Tipp bzw. konstruktive Kritik dankbar!

Share this post


Link to post
Share on other sites

Ich benutze Cham nicht so lange, aber das hatte ich noch nie.

 

Diskpart gibt es mindestens seit XP. Versuch mal DOS und Testdisk (Freeware -> Google) zu starten und dir

die Partitionstabelle reparieren zu lassen. Du kannst damit auch die aktive Partition setzen.

 

 

Oder alternativ bzw wenn das nicht ausreicht:

Nicht schaden würde es auch Cham noch mal zu installieren und im Zweifel händisch

die Bootloader nochmal zu kopieren und die Mac-Part mit fdisk aktiv zu machen

Share this post


Link to post
Share on other sites
Diskpart gibt es mindestens seit XP

 

Echt? Oh man, soviel zu dem "immer auf dem aktuellsten Stand sein" :D Ich habe mir Diskpart gerade mal angeschaut und es gefällt mir echt gut. Da mein SL warum auch immer nicht mehr funktioniert, werde ich erstmal alles neu installieren und dann mal schauen was Sache ist.

Share this post


Link to post
Share on other sites
Man braucht keine 2. Platte, ich habe die SL DVD auf ein externes Laufwerk (mit CCC) geklont, anschließend die OSInstall.mpkg mit folgender Datei ersetzt:

 

OSInstall.mpkg.zip

 

Anschließend einfach das Setup mit dieser Datei starten, fertig

 

Hallo,

 

irgendwie schaffe ich es nicht, die Datei auszutauschen:

 

ich habe ein dmg-File mit CCC von der SL DVD gemacht. Immer wenn ich es im Finder doppelklicke, öffnet sich der Startdialog zur Installation oder ich kann nur auf die Installation-App sowie die pdf-Handbücher zugreifen.

Wie komme ich an die Dateien im Systemfolder des DMG?

Unter Windows habe ich mit dem HFS-Explorer dieses Verzeichnis zwar anzeigen können, aber ich kann es dort nicht schreibend öffnen ...

 

Irgendeine Idee? Wäre klasse.

Share this post


Link to post
Share on other sites
Hallo,

 

irgendwie schaffe ich es nicht, die Datei auszutauschen:

 

ich habe ein dmg-File mit CCC von der SL DVD gemacht. Immer wenn ich es im Finder doppelklicke, öffnet sich der Startdialog zur Installation oder ich kann nur auf die Installation-App sowie die pdf-Handbücher zugreifen.

Wie komme ich an die Dateien im Systemfolder des DMG?

Unter Windows habe ich mit dem HFS-Explorer dieses Verzeichnis zwar anzeigen können, aber ich kann es dort nicht schreibend öffnen ...

 

Irgendeine Idee? Wäre klasse.

Öffne das Image mit dem Progr. pacifist dann die Dateien extrhieren welche man möchte

Share this post


Link to post
Share on other sites
Öffne das Image mit dem Progr. pacifist dann die Dateien extrhieren welche man möchte

Danke Dir, bin gerade beim Extrahieren - danach will ich eine Datei austauschen & packe das ganze irgendwie wieder zu einem Image auf einen Stick ...

 

So, mit Pathfinder scheint das mit dem Anzeigen & Ersetzen nun geklappt zu haben, nachdem ich dort die unsichtbaren Dateien anzeigen lassen konnte.

Share this post


Link to post
Share on other sites
Man braucht keine 2. Platte, ich habe die SL DVD auf ein externes Laufwerk (mit CCC) geklont, anschließend die OSInstall.mpkg mit folgender Datei ersetzt:

 

OSInstall.mpkg.zip

 

Anschließend einfach das Setup mit dieser Datei starten, fertig

 

Irgendwie klappt es nicht: ich boote jetzt mit dem myHack-Installer aber wenn ich nur die OSInstall.mpkg austausche, kann ich immer noch nicht auf die MBR-Partition installieren, da er GUID möchte. Wenn ich auch die Framework-Datei austausche, bleibt er bei "preparing Installation" hängen ...

 

Muss ich doch die ganze Festplatte GUID partitionieren?

 

Wäre super, wenn jemand von Euch noch eine Idee/Lösung hätte. Danke im Voraus!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×