Jump to content

dell 9300 working install dvd dual boot and sound


ZX81
 Share

2 posts in this topic

Recommended Posts

I am well happy with this, thks everyone. Some of the text here is copied and pasted from notebook forums, which is where I heard about this work and forum in the first place.

 

I got the DVD patched image installed on my Dell 9300 1.73Mhz 2GB ram 256mb nvidia

Once up and running I did the delete AppleFPMemdriver workaround to get USB to work. Its a logitech Mx518 with gaming sensitivity hardware changes and scroll wheel, sensitivity and scroll wheel works. I have blue teeth, but no devices so can't chek that (never use it).

It took me a while to get the dual boot thing working with chain0 workaround (I am mac newbie), details below

 

Dual booting tips:

 

what worked for me, clean drive, empty. Load dvd image, no problems, use apple disk utiility to partition disk, (piror to loading tiger) tiger in 1st primary partition 30GB, partition for XP 20 gb msdos(ntfs), 3rd partition (this one gets to be logical) for data 30GB

 

once tiger is installed, use xp disk to install on the 2nd partition, install xp as normally. Then you'll find the laptop will only boot into xp, and the first partition is listed as unknown in xp computer management. But you can get back into tiger by using the Tiger DVD to boot up the laptop.

 

To get a dual boot machine, copy the chain0 file from the tiger dvd into your xp drive, whatever letter the laptop has given it, it was E: in my case (C was tiger, d was dvd drive FYI) Then add a line to boot.ini in to reference Tiger E:\chain0="Mac OS X X86"

 

When I rebooted the first time, i got a hal.dll error. Found from the osx forum, boot once more from the tiger dvd, then shutdown, startup again and tiger is up first, option to start tiger only on boot, if you want windows, hit F8 key and get a choice of which partition to run from. You dont need the dvd to boot into tiger from there.

 

This is excellent stuff, the OSx forum is superb.

 

The only caveat I would have is if your going to do it, the apple disk utility which formats the tiger partition has for some people, wiped out the complete disk to apple format type. i got around this by using another backup drive I had. If you only have one drive, make sure all your xp stuff critical data is backed up - this is all in the read me notes from the DVD

 

I got another tip from this forum conerning audio...

 

I downloaded the darwin cd from apple to get the files necessary to get the sound to work.

Followed this procedure, taken from a poster there:

 

 

"......Directions taken from deep in the above thread:

 

Once you've copied that, you have to set the correct permissions, otherwise you'll get the "not properly installed" error. What I did (after browsing through the forums to find a semi-answer) was this:

 

Slap in the Darwin 8.01 cdrom

Go to terminal

 

$ cd /System/Library/Extensions

$ sudo cp -R /Volumes/Darwin8_i386/System/Library/Extensions/AppleAC97Audio.kext .

 

**** (I didnt do these 2 lines I dragged and dropped the file into my extensions, followed the rest below)

 

 

$ sudo chmod -R 755 AppleAC97Audio.kext

$ sudo chown -R root:wheel AppleAC97Audio.kext

 

This set the correct ownership and privileges, after which I was able to:

 

sudo kextload AppleAC97Audio.kext

sudo kextload /System/Library/Extensions/AppleAC97Audio.kext/Contents/Plugins/AppleAC97AudioVIA.kext

 

Reboot "

 

Sound is working now. Havent checked quality against xp yet.

 

I downloaded and ran Xbench to compare the performance (this is with the dual xp boot in situ on the other partition)

 

these are the results:

 

Bench results below

 

Dell 9300 1.73MHz 2GB 5400rpm seagate momentus

30gb Tiger / 20gb XP / 20gb data

 

 

Results 48.15

System Info

Xbench Version 1.2

System Version 10.4.1 (8B1025)

Physical RAM 2048 MB

Model ADP2,1

Drive Type ST9808211A

CPU Test 25.56

GCD Loop 224.68 11.84 Mops/sec

Floating Point Basic 44.79 1.06 Gflop/sec

vecLib FFT 8.87 292.66 Mflop/sec

Floating Point Library 58.91 10.26 Mops/sec

Thread Test 80.60

Computation 69.93 1.42 Mops/sec, 4 threads

Lock Contention 95.12 4.09 Mlocks/sec, 4 threads

Memory Test 76.54

System 79.71

Allocate 146.92 539.52 Kalloc/sec

Fill 62.95 3060.96 MB/sec

Copy 66.90 1381.88 MB/sec

Stream 73.61

Copy 66.77 1379.19 MB/sec

Scale 67.52 1394.93 MB/sec

Add 81.73 1741.08 MB/sec

Triad 81.18 1736.74 MB/sec

Quartz Graphics Test 74.42

Line 62.79 4.18 Klines/sec [50% alpha]

Rectangle 67.85 20.26 Krects/sec [50% alpha]

Circle 76.00 6.19 Kcircles/sec [50% alpha]

Bezier 86.21 2.17 Kbeziers/sec [50% alpha]

Text 85.02 5.32 Kchars/sec

OpenGL Graphics Test 33.36

Spinning Squares 33.36 42.32 frames/sec

User Interface Test 95.79

Elements 95.79 439.63 refresh/sec

Disk Test 37.12

Sequential 62.07

Uncached Write 47.15 28.95 MB/sec [4K blocks]

Uncached Write 66.47 37.61 MB/sec [256K blocks]

Uncached Read 67.88 19.87 MB/sec [4K blocks]

Uncached Read 74.29 37.34 MB/sec [256K blocks]

Random 26.48

Uncached Write 8.91 0.94 MB/sec [4K blocks]

Uncached Write 70.03 22.42 MB/sec [256K blocks]

Uncached Read 70.05 0.50 MB/sec [4K blocks]

Uncached Read 97.36 18.07 MB/sec [256K blocks]

 

Is this a good benchmark? If not suggestions on any possible tweaks?

 

__________________

9300 1.73 2GB Dual-Crucial WXGA+ Sammy SEC5857 Driver 77.7 380/780 3dmark5 4436K OC in XP Dual booting Tiger OSx & XP

 

 

So, if you have an 9300/XPS2 then you'll be able to get the DVD image up and running with no problem. I mentioned before it took longer to read through the forum and also to get the actual torrent dvd than to load it up. Thanks for the help from the many posters whom got the workarounds sorted out.

 

And as a comment on piracy. Well I will be a consumer when this gets released, I'll buy. I think apple are savvy enough to either have engineered this situation, or to grasp the nettle and take advantage of it. Witness microsoft with their new authentication for windows updates - that would be an effective way to ensure purchases. I am very happy to be able to dual boot and have the best of both worlds, plus the geek in me wants to learn tiger

 

cheers all

Link to comment
Share on other sites

Just an update.

 

I erased the image and redid it for the new release, which has all of the workarounds included.

There were no problems loading, I used disk utility to simply erase the partition, then loaded the new patched DVD. Sound and USB worked, ethernet still working. Basically the same end state as before but without the hassle of applying the workarounds myself. Cheers.

Link to comment
Share on other sites

 Share

×
×
  • Create New...