Jump to content

10.6 on Tyan 5397


5 posts in this topic

Recommended Posts

So I have been using a Tyan 5397 (Seaburg chipset) very happily under 10.5.x with only Disabler.kext and dsmos.kext installed and EFI strings for my ethernet card and 8800GTX. I use a 3ware 9650 RAID card for hardware RAID 6 as the main boot device.


Having decided to upgrade to 10.6 I tried a OSInstall.mpkg install onto a backup/test drive only to have an immediate kernel panic on reboot:


Darwin Kernel Version 10.0.0: Fri Jul 31 22:48:25
vm_page_bootstrap: 1977999 free pages and 119148 wired pages
kext submap [0xffffff7f80600000 - 0xffffff0000000000], kernel text [0xffffff0000200000 - 0xffffff0000600000]
standard timeslicing quantum is 10000 us
mig_table_max_displ = 73
panic(cpu 0 caller 0xffffff80002cbf74): Kernel trap at 0xffffff00004f65c3, type 14=page fault, registers:
CR0: 0x……….


I used the EFI partition on this drive to install netkas' fakesmc.kext with a DSDT.aml and Chameleon RC2. I monkeyed around in the BIOS and finally figured out the Multimedia Timer==HPET.


I finally got this configuration working after completely reformatting the drive (it was already GUID before) using fakesmc.kext, a smbios.plist and a DSDT.aml (all on the EFI partition as well.) In the process I also moved to Chameleon RC3, but I doubt this made a difference. With Multimedia Timer enabled AppleUSBEHCI did not start up with a "unable to get filterInterruptEventSource" which I finally tracked down to a IRQ problem thanks to a post from Slice. The fix so far has been disabling the Multimedia Timer/HPET and loading NullCPUPowerManagement.kext from the EFI partition.


Through all of the reboots I noticed an occasional kernel panic in 10.6 with: "Should have 2 Cores, but only found 1 for Die 0".


I would really like to keep my install as vanilla as possible (the board is pretty darn close to a MacPro board so that should help.) Given that a few questions:


Has anyone figured out a better solution to the initial kernel panics than a re-format? The main "drive" on my system is 2.7TB with a good chunk full making a re-format a major PITA.


Other than Slice's IOPCIFamily.kext is there another way to get around my IRQ conflicts or should I just give up in HPET/Multimedia Timer/AppleIntelCPUPowerManagement.kext?


My BIOS also offers Machine Checking, but that seems to KP Snow Leopard pretty darn fast. I assume I do not need this?


WTF is with the "Should have 2 Cores, but only found 1 for Die 0" KP? It happens maybe once every 10 reboots so it is not a major problem, but if anyone has a tip I would love to hear it.


Thanks especially to Slice, munky, netkas, Kabyl for posts, suggestions, etc.


FWIW the Tyan 5397 is freakin' awesome. LSI SAS works, SATA works, PATA works, NICs work, Firewire works, USB works. Only thing I have not bothered to poke at is the Realtek ALC262 HD audio onboard as I just plugged in a USB audio device.

Link to comment
Share on other sites

  • 3 weeks later...

So I took the plunge and tried installing on the RAID array by copying over the identical EFI partition information from the single drive that 10.6 was working on perfectly and doing the same .mpkg install. BOOM! KP out of the gate. Re-formatted the HFS partition (ouch!) and now am stuck with "Still waiting for root device" fun. I know why I get this prompt as it is preceded by:


kxld[com.amcc.3ware.AMCC3ware9000]: The Mach-O file is malformed: Invalid magic number: 0xcefaedfe.
Can't load kext com.amcc.3ware.AMCC3ware9000 - link failed.
Failed to load executable for kext com.amcc.3ware.AMCC3ware9000.
Kext com.amcc.3ware.AMCC3ware9000 failed to load (0xdc000016).
Couldn't alloc class "com_amcc_3ware_AMCC3ware9000Controller"


The kext loads just fine on the single drive... I did a chmod -R 0:0 on the kext and even tried copying the entire Extensions directory from the single drive to the RAID array and still get stuck at the same bit.


Anyone have any suggestions? Any help would be greatly appreciated.


EDIT: Used kextlibs to figure out I had somehow installed a PPC kext :)

Link to comment
Share on other sites

  • 2 weeks later...

Hi justroach!

I need help too with my Tyan in sig!

I have the same panic: panic(cpu 0 caller 0xffffff80002cbf74) (Don't know if the rest is important...)

I don't solve the issue with fakesmc.kext, smbios.plist and a DSDT.aml! :P And I have not in bios HPTE voice!

BTW, in Leopard 10.5.6 I don't use dsdt patch an Leo see all my cores!

Any idea?

Thak you!!!

Link to comment
Share on other sites

  • 2 months later...
  • 2 months later...

  • Create New...