Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[How To] Manual Update to 10.4.6 from working10.4.4/10.4.5 Installation, Intel Chipset

5 posts in this topic

Recommended Posts

Instructions on Manually Updating to 10.4.6 from a working 10.4.4/10.4.5 Installation, Intel Chipset

GMA900, modded ATI QE CI friendly, mounting shares, Personal File Sharing, autologin, widget flipping etc, :thumbsdown_anim:



----------------GUIDE BEGINS HERE-----------------------


obtain MacOSXUpdCombo10.4.6Intel.dmg, Maxxuss Patch Solution v1.0 for 10.4.5, and Pacifist 2.0, from Charlessoft.com




install Pacifist 2.0 to your Applications folder




extract Maxxuss Patch Solution, then copy the Decrypted_Files folder, to the root "/" of your OS X installation.


navigate to the copied folder and open /Decrypted_Files/replace.sh with TextEdit.app




function platformCheck



IS8G1454=`grep 8G1454 $VERSFILE | wc -l`

if [ $IS8G1454 == 0 ]; then

echo "Your Mac OS X installation is not a 10.4.5 8G1454 build."





backspace to delete the highlighted text, then Save and quit TextEdit.




open Terminal.app, located in Applications/Utilities


type in the following...


mkdir /backups

mkdir /backups4.6

cd /System/Library

cp -R Extensions SystemProfiler /backups

cd Frameworks

cp -R Kernel.framework OpenGL.framework /backups

cp /sbin/mount* /backups




mount MacOSXUpdCombo10.4.6Intel.dmg

right click on the MacOSXUpdCombo10.4.6Intel.pkg and "Open with" >> "Other", navigate to Pacifist 2.0 you've installed

in your Applications Folder.


Pacifist will open and a 15 second timer will run as it is unregistered. click on "Not Yet"


use Ctrl, to select EVERYTHING, ONE AT A TIME, EXCEPT---- mach_kernel ----

do not select them all at once using shift.

do not deselect anything.

if mach_kernel is accidently selected, shut down and restart Pacifist, and reselect


right click on selected blue highlighted files and "Install to Default Location"


click "Install" on the popup, leave the Administrative Priviliges box checked


type in your password to authenticate when required


two popups will come up, "Bundle Already Exists" and "File Already Exists",

check "Don't Ask Again..." for both,

click on "Update" for Bundles,

click on "Replace" for Files


after installation of files completes, Reboot.




at boot, hit F8 to access the prompt and type in the options, -x -s

hit enter


type in the following...


mount -uw /

cd /System/Library

mv Extensions /backups4.6

cd Frameworks

mv OpenGL.framework /backups4.6

cd /backups

mv mount* /sbin

cp -R Extensions /System/Library

cp -R SystemProfiler /System/Library

cp -R OpenGL.framework /System/Library/Frameworks

cd Kernel.framework/Versions/A/Resources

cp *.plist /System/Library/Frameworks/Kernel.framework/Versions/A/Resources

rm /usr/sbin/AppleFileServer

ln -s /System/Library/CoreServices/AppleFileServer.app/Contents/MacOS/AppleFileServer /usr/sbin/AppleFileServer

cd /Decrypted_Files



shutdown -r now




as soon as you get into OS X, open Disk Utility from your Applications/Utilities folder and repair permissions on

your OS X installation, then open terminal and type...


sudo update_prebinding -root / -force


(after prebinding ends, which might take a while, you will have access to the prompt again)

close terminal. :angry:





-------------------GUIDE ENDS HERE------------------------------





Attn: 10.4.6 supported, ATA, Nvidia, GMA950 users, 10.4.6 Extensions & OpenGL.framework backed up

to "/backups4.6" for your updating and/or tweaking convenience. remember, most 10.4.6 extensions are

useless for most people, and will only cause heartache. :blink:


Share this post

Link to post
Share on other sites



..so you went straight from 10.4.5 to 10.4.7?. wich file you used?


I mean: the original apple file?


I have 10.4.5 and Jas 10.4.7 update (intel)... will it work?



sorry for the novice Q ;)

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.