Jump to content
ryuu123

Snow Leopard on VAIO P(VGN-P90HS) working!

530 posts in this topic

Recommended Posts

Hi, now it works!!

 

********** snow **********

VAIO P(VGN-P90HS)

o CPU: Intel ATOM Z540

o US15W:

o ATA(+SATA SSD)

o USB(EHCI,UHCI)

x GMA500(1600x768/no QE/QI)

o ALC262(VoodooHDA)

x LAN:Yukon2( AppleYukon2.kext but Ultra2 revision is not supported)

o WLAN:Atheros AR928X/AR5B91

o Memory Stick :-p

o SD card

o Bluetooth

o WebCAM

o 3G modem/WWAN/GPS <- need install drivers below

o suspend/resume(?: deep sleep/hibernate)

o 10.6.1/2 update

o vanilla speedstep

 

o:working/x:have problem/?:not yet tested

 

- kext and patch tool sets

--US keyboard: ( not tested )

http://www.mediafire.com/file/hli2j12mi0n/...p20100327us.zip

--JP keyboard:

http://www.mediafire.com/file/ndm5ygmw32j/...p20100327jp.zip

 

- WWAN driver

http://www.option.com/en/support/software-...modems/icon225/

# thx, maccosmo

 

o 10.6.2 update see->

http://www.insanelymac.com/forum/index.php...t&p=1331304

 

o suspend/resume see->

http://www.insanelymac.com/forum/index.php...t&p=1430885

 

For non-vaiop GMA500 based netbook users, GMA500Enabler is here

o 10.6 http://www.insanelymac.com/forum/index.php...t&p=1310737

o 10.5 http://www.insanelymac.com/forum/index.php...t&p=1311449

 

********** 10.5 leopard **********

 

VAIO P(VGN-P90HS)

o CPU: Z540

o US15W:

o ATA(+SATA SSD)

o USB(EHCI,UHCI)

x GMA500(1600x768/no QE/QI)

x ALC262(noisy sound with VoodooHDA)

? LAN:Yukon2?

x WLAN:Atheros AR928X/AR5B91 <- I gave up binary patching to AirPortAtheros... and will buy Dell 1510

o Memory Stick :-p

o SD card

o Bluetooth

o WebCAM

o 3G modem <- see post #28( maccosmo )

? Suspend/resume

 

o:working/x:have problem/?:not yet tested

 

Files you need: http://www.mediafire.com/file/mhjmzjgznz3/vaiop-alpha-0.zip

ioreg: http://www.mediafire.com/file/4ulmnziadyy/ioreg-vaiop.txt

 

*** update ***

For 10.5.7

http://www.mediafire.com/file/gyeqmmxzy2q/vaiop-alpha-1.zip

- this "boot" also work with 10.5.6 and can read /DSDT.aml and /Extra kexts.

(but needs kernel option "Graphics Mode")

- Improve USBEHCI stablity( based on 10.5.7 IOUSBFamily )

- brightness can adjustable through PCIFix.kext's Info.plist

***

 

post-74571-1243599997_thumb.jpg

 

[boot options]

- need "cpus=1"

(with 10.5.7 boot also need "Graphics Mode" )

Share this post


Link to post
Share on other sites
Advertisement

Hi,

 

it's amazing that it works!

 

Can you tell me how fast it is?

I know its not like a new mac book pro - but textmate should work without problems, right?

 

I haven't managed to boot os 10.5.6 from a usb thumbdrive with your kext and boot file(s) on my p.

 

Do you have the time to help me out, please?

I installed Mac OS 10.5.6 on a thumbdrive with my macbook and moved "PCIFix.kext", "IOATAFamily.kext" and "IOUSBFamily.kext" from your zip file to "/System/Library/Extensions/".

I also copied the "boot" file to the root of my disk.

Where do I get the "AppleIntelPIIXATA" kext file?

 

I tried booting with -v -cpus=1 but I get "still waiting on root device" - when I search for the message I get a lot of results - but I can't pass the message with the tips i get.

 

 

My vaio p is an european p11z/q with 60gb hdd.

 

 

 

sorry for my english and being a noob.

Share this post


Link to post
Share on other sites

What about 3G modem? is it working?

 

How's the speed of the system, is it better than with `vista or Windows7 ?

Share this post


Link to post
Share on other sites

@maccosmo

AppleIntelPIIXATA is in IOATAFamily.kext/Contents/Plugins directory.

so what you doing is right.

 

I install leopard without USB drive.

so not sure, try below boot options.

 

-v cpus=1 -f rd=disk0s1 or

-v cpus=1 -f rd=disk1s1 or

-v cpus=1 -f rd=disk2s1 or

-v cpus=1 -f rd=disk3s1

 

diskXsY .. X Y is depend on BIOS setting and thumbdrive partitioning.

 

If you see some USBEHCI error, post the message here.

 

I didn't mention but also need some OSX86 standard kexts.

- dsmos, IntelCPUPMDisabler, PS2Nub, PS2Controller

- Voodoopower, SMIOS, etc ..

 

@rnglad

My model didn't have 3G modem. so I cannot try. :-P

but USB 3G modem is working.

 

I feel faster than Vista, I don't know win7 so can't compare.

but for me, leopard on p is enough fast :-P (safari,mail and text edit)

 

I feel ...

faster <------------> Slowwww

Linux >> Leopard >>>>>>> Vista

Share this post


Link to post
Share on other sites

ok - now it works - more or less (more less) ^^.

 

i've installed chameleon 2 rc1 and a few kexts into the extra folder and now it boots to my desktop with the "-v cpus=1 -f rd=disk1s2" parameters.

the finder and other apps are pretty fast even from a sdhc card.

 

with chameleon 1 and your boot file i get a usbehci error like you mentioned - i will post the messages later this day.

 

my current resolution is 1024x768 (with chameleon 2 rc1).

i hope for an easy solution for the usbehci problem so i can enjoy your boot file :D.

 

 

could you do me a favour? it would be really nice if you could post the content of your extensions folder(s) with the kexts you are using.

fastest way: cmd + a, cmd + c and cmd + v into this topic ^^

 

like this:

...

AppleIntelCPUPowerManagement.kext

AppleK2SATA.kext

AppleIntelGMAX3100VADriver.bundle

AppleIntelIntegratedFramebuffer.kext

AppleIRController.kext

AppleK2.kext

AppleK2Driver.kext

AppleK2Fan.kext

...

 

thanks!

Share this post


Link to post
Share on other sites

Hi ryuu123 i have an American version sony p and I have been trying to install leopard since I bought it. I am kind of a noob so, could you please post or PM instructions on how to install it ?

 

Thanks in Advanced... :thumbsup_anim:

Share this post


Link to post
Share on other sites

@maccosmo

Currently,

To get 1600x768, there is no way without using my chameleon 1 based "boot".

so /Extra doesn't work.

 

I sent my patch to "Chamelon Team" and got reply "accept your patch and wait next release..."

so, I'm waiting next Chamelon release too.

 

My /System/Library/Extentions modification is ..

 

add ->

AppleACPIPS2Nub.kext

ApplePS2Controller.kext

AppleSMBIOS.kext <- netkas's one

IOATAFamily.kext <- overwrite IOATAFamily.kext/Contents/PlugIns/AppleIntelPIIXATA.kext

IOUSBFamily.kext <- overwrite IOUSBFamily.kex/Contents/PlugIns/AppleUSBEHCI.kext

IntelCPUPMDisabler.kext

OpenHaltRestart.kext

PCIFix.kext

UUID.kext

VoodooBattery.kext

VoodooHDA.kext

VoodooPower.kext

dsmos.kext

 

delete ->

AppleTyMCEDriver.kext <- 10.5.7 :-p

 

I'll post USBEHCI messages helper to next.

 

 

 

AppleUSBEHCI messsage and trouble shooter. :-p

 

"AppleUSBEHCI[xxx]::UIMInitialize - unable to get device memory"

 

<- faild overwrite kext.

-> re-overwrite AppleUSBEHCI whit attached one.

 

"AppleUSBEHCI[xxx]: unable to get filterInterruptEventSource"

 

<- this is my noob. 10 tims 1 or 2 this message appear and out of work.

-> try shutdown and restart.

 

"AppleUSBEHCI[xxx]::UIMInitialize - could not get chip to halt within 100 ms"

 

<- someting wrong. model specific difference or some thing wrong

-> no way.(or boot linux and send me lspci -vvnn)

 

"EHCI controller unable to take control from BIOS"

 

-> normal message with version alpha-0 :-p

-> nothing to do.

 

I continue work to stabilize EHCI.

wait for update.

Share this post


Link to post
Share on other sites

i love you ;)

 

yesterday (a few hours ago) i installed leopard on an another usb flash drive, installed your kexts, chameleon 1 and your boot file .. - and surprize, surprize - this time it worked - dont know what was wrong.

 

thanks for your kexts list by the way - i was missing my trackpoint. the kexts i tried didn't work.

 

os x on this machine and 1600x768 looks amazing.

 

EDIT: trackpoint + battery indicator work now - thanks.

Share this post


Link to post
Share on other sites

@maccosmo

:yoji:

 

enjoy vaio P

 

 

 

Hi ryuu123 i have an American version sony p and I have been trying to install leopard since I bought it. I am kind of a noob so, could you please post or PM instructions on how to install it ?

 

Thanks in Advanced... :)

 

@ccarrieta

 

My Install Procedure is ...

 

(0. make vaio recovery DVD disks.)

1. shurink VISTA partition from VISTA with diskpart.

2. boot from gparted live cd.

3. create two hfs partitions on empty area(#3:16G,#4:10G)

4. format partition #4 hfs.

5. copy entire retail dvd to partition #4(be careful copied files uid/gid)

6. copy osx86 standard kexts( dsmons, ps2 and etc...)

7. copy vaio p specific kexts( download topic link)

8. replace OSInstall.mpkg to enable MBR partition install.

9. append boot options to com.apple.Boot.plist, "cpus=1 rd=disk0s4")

10. install bootloader( mbr and pbr and /boot )

11. boot leopard installer from partition #4

12. install leopard to partiton #3

13. before reboot, install and overwrite kexts on pattions #3(installed #4 step 6. 7.)

14. append boot options to com.apple.Boot.plist, "cpus=1 rd=disk0s3")

 

this method saves VISTA and Instant mode.

but so complex.

 

I hope someone find more easy way and post here :D

Share this post


Link to post
Share on other sites

this is how to install mac os on an usb flash drive - this method will not alter your internal harddisk:

 

what you need:

1. an usb flash drive - 8 gb minimum

2. an intel mac

3. a retail mac os dvd (tried with mac os 10.5.6 retail)

4. a sony vaio p ;)

5. the chameleon 1 installer

6. ryuu123's kexts and boot file + the kexts you need to get additional components running (see ryuu123's list).

 

1. boot your intel mac with the retail leopard setup dvd, format your usb drive (mac os extended (journaled)) and start the installation

2. when done, boot from usb drive and install chameleon 1 with the installer

3. install the kexts you need

4. copy ryuu123's boot to the root of your flash drive

5. edit the com.apple.Boot.plist, set the kernel flag to "-v cpus=1 rd=disk1s2 -f" and repair permissions (-v and -f is not necessary - but if something went wrong for the first boot, its good to know what the problem is)

6. unplug your usb flashdrive from your mac, plug it into your vaio p

7. boot and enjoy

Share this post


Link to post
Share on other sites

HY

I tried to use your pcifix into my packard bell DOTM

it has gma500.. the id is:

ven_8086 DEV_8108 SUBSYS_02561025

 

what are the values to change into your plist?

it's the pci match?

 

I see the light quite lower at boot due to the 80% brightness value.. but no video shell!!

 

can you help me?

 

ugo

Share this post


Link to post
Share on other sites

wow

we use the same pen!! is very quickly.. yes?

then.. now i gave up the laptop.. but in italy there are many people which are very happy to continue my job

the pcifix.kext seems to load the video card.. the log report a lot of good data.. but the video didn't start.. it remain in text mode

 

then I'm sure that the problem is the pcimatching in the plist

 

this is the job

 

http://www.insanelymac.com/forum/index.php...t&p=1170437

Share this post


Link to post
Share on other sites

Hi,

 

what are the values to change into your plist?

it's the pci match?

 

It's using pci class match, so no need to add vendor id or device id.

 

PCIFix does VAIO P specific memory address fix.

 

this is VAIO's message ->

 

kernel[0]: bootDisplay: 1600 x 768 x 32 addr:0x7f800000 offs:00000000

kernel[0]: PCIFix: BAR0: 94200000

kernel[0]: PCIFix: BAR1: 00006071

kernel[0]: PCIFix: BAR2: 80000000

kernel[0]: PCIFix: BAR3: 94280000

kernel[0]: PCIFix: prop 0: 94200000

kernel[0]: PCIFix: prop 1: 00006070

kernel[0]: PCIFix: prop 2: 7f800000

kernel[0]: PCIFix: prop 3: 94280000

kernel[0]: PCIFix: setting memory

 

OSX's VESA driver can't mep memory, because

bootDisplay(VESA) frame buffer address(addr:0x7f800000) is

out of device memory address(80000000)

 

so PCIFix do replace 80000000 with VESA's address.

 

I guess 80000000 is for VAIO P and ur laptop have different value.

 

can u post PCIFix's message?

Share this post


Link to post
Share on other sites
Hi,

 

 

 

It's using pci class match, so no need to add vendor id or device id.

 

PCIFix does VAIO P specific memory address fix.

 

this is VAIO's message ->

 

kernel[0]: bootDisplay: 1600 x 768 x 32 addr:0x7f800000 offs:00000000

kernel[0]: PCIFix: BAR0: 94200000

kernel[0]: PCIFix: BAR1: 00006071

kernel[0]: PCIFix: BAR2: 80000000

kernel[0]: PCIFix: BAR3: 94280000

kernel[0]: PCIFix: prop 0: 94200000

kernel[0]: PCIFix: prop 1: 00006070

kernel[0]: PCIFix: prop 2: 7f800000

kernel[0]: PCIFix: prop 3: 94280000

kernel[0]: PCIFix: setting memory

 

OSX's VESA driver can't mep memory, because

bootDisplay(VESA) frame buffer address(addr:0x7f800000) is

out of device memory address(80000000)

 

so PCIFix do replace 80000000 with VESA's address.

 

I guess 80000000 is for VAIO P and ur laptop have different value.

 

can u post PCIFix's message?

 

 

here you are.. repeat.. I gave up the lappie.. but I have my usb pen.

 

 

Jun 6 19:59:27 ugos-imac kernel[0]: GFX0: family specific matching fails

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: 8086:8108

Jun 6 19:59:27 ugos-imac kernel[0]: bootDisplay: 1024 x 768 x 32 addr:0x3f800000 offs:00000000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: BAR0: b0080000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: BAR1: 00001801

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: BAR2: c0000000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: BAR3: b0000000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: prop 0: b0080000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: prop 1: 00001800

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: prop 2: c0000000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: prop 3: b0000000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: setting memory

this is written 2 times.. one after the .. got boot device

the second at the end.. after the

 

Login Window Application Started --

Share this post


Link to post
Share on other sites
Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: BAR2: c0000000

Jun 6 19:59:27 ugos-imac kernel[0]: PCIFix: prop 2: c0000000

 

@ugokind

try this

 

pcifix.zip

 

if u don't give up. :)

Share this post


Link to post
Share on other sites
@ugokind

try this

 

pcifix.zip

 

if u don't give up. :(

 

thanks!!

i can't reply.. I must wait 2 weeks.. before having another one.

but. thanks!

but.. you're a developer!

Share this post


Link to post
Share on other sites
*** update ***

For 10.5.7

http://www.mediafire.com/file/gyeqmmxzy2q/vaiop-alpha-1.zip

- this "boot" also work with 10.5.6 and can read /DSDT.aml and /Extra kexts.

- Improve USBEHCI stablity( based on 10.5.7 IOUSBFamili )

- brightness can adjustable in PCIFix.kext's Info.plist

***

 

post-74571-1243599997_thumb.jpg

 

hi ryuu123,

 

i tried your updated boot file but the resolution changed back to 1024x768 - do you know what's wrong?

 

thanks!

Share this post


Link to post
Share on other sites
hi ryuu123,

 

i tried your updated boot file but the resolution changed back to 1024x768 - do you know what's wrong?

 

thanks!

 

Ahh...I forgot mention.

 

I made "boot" more *GENERIC*,so changed default to 1024x768 from 1600x768.

 

New boot needs an option "Graphics Mode"="1600x768x32" as below.

 

in /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

 

<key>Kernel Flags</key>

<string>cpus=1 "Graphics Mode"="1600x768x32"</string>

 

or

 

<key>Graphics Mode</key>

<string>1600x768x32</string>

.

 

thx :hysterical:

Share this post


Link to post
Share on other sites
Ahh...I forgot mention.

 

I made "boot" more *GENERIC*,so changed default to 1024x768 from 1600x768.

 

New boot needs an option "Graphics Mode"="1600x768x32" as below.

 

in /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

 

<key>Kernel Flags</key>

<string>cpus=1 "Graphics Mode"="1600x768x32"</string>

 

or

 

<key>Graphics Mode</key>

<string>1600x768x32</string>

.

 

thx :hysterical:

 

hy

question is .. due!

if I use chamel 2.0 .. then is right to put graphics mode.. or is enough to put the size in the Extra/themes folder?

bye

Share this post


Link to post
Share on other sites
Ahh...I forgot mention.

 

I made "boot" more *GENERIC*,so changed default to 1024x768 from 1600x768.

 

New boot needs an option "Graphics Mode"="1600x768x32" as below.

 

in /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

 

<key>Kernel Flags</key>

<string>cpus=1 "Graphics Mode"="1600x768x32"</string>

 

or

 

<key>Graphics Mode</key>

<string>1600x768x32</string>

.

 

thx ;)

 

 

thanks - i dont know why i didn't tried that before :D

 

 

i love you :D

Share this post


Link to post
Share on other sites

How do I use 1280x800?

 

Hi, I am testing my Fujitsu U820 with pcifix, so cool it works! (same GMA500 like Viao P has)

But only at 1024x768

 

The native is 1280x800, I have tried specify it in the plist file/command line, no luck. Is there a way to get around? Thanks.

Share this post


Link to post
Share on other sites
anyone manage to get the in-built 3G modem to work as well?

 

@saiyan-jin

My P does't have WWAN module,so consult google :-p

google says it's "GlobeTrotter MO40x" "Option Wireless Technology GTM382"

Consult google "GTM382 OSX86"

 

 

 

How do I use 1280x800?

 

Hi, I am testing my Fujitsu U820 with pcifix, so cool it works! (same GMA500 like Viao P has)

But only at 1024x768

 

The native is 1280x800, I have tried specify it in the plist file/command line, no luck. Is there a way to get around? Thanks.

 

@lilyl

What bootloader you use?

In VESA compatible mode framebuffer init is part of bootloader's work.

Try my boot and specify "Graphics Mode".

 

if still not work, type on boot prompt "?video".

the list shown is the mode you can use.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×