Jump to content

FireWire Problem - SOLVED!

4 posts in this topic

Recommended Posts

Hi OSX86´s,


Soooo, I´ve allways used Vista to Capture Video in .avi format and after that import it

into HacMAC for editing.

Till Yesterday! I wonted to Capture some homemade Video from Panasonic miniDV

Camcorder NV-GS24 via FireWire on my Mac, but ques what? Didn´t worked!

Not with IMovie, nor with Premiere or FinalCut saying: capture device not connected!

But System Profiler on Mac shows it correct under FireWire up to 400MB!



First step was to check all the FireWire Kext´s under system/library/extensions, and

compare it with "Aktive" kext´s in System Profiler.

Very important kext for Audio-Video Capture was not loaded: IOFireWireAVC.kext !!!

I can remember that i used LioNEXT Way to solve the USB Mount Problem with small

App called "Lingon".




With Lingon we create applescript that loads this kext on start up. It will be placed

Under Library/LaunchDaemons.


Start Lingon. Choose: New – USERS DAEMONS

1. Call it wherever you wont. ( FireWire Starter)

2. Under „What“ type: kextload -b com.apple.iokit.IOFireWireAVC

3. Under „When“ choose second one: Run it when it is loaded by the system…

4. VERY IMPORTANT! Don´t forget to ACTIVATE „Enabled“ on upper right corner!

Save and Reboot!


And VOILA!!! It WORKS! I can now capture with all App: Premiere, FinalCut and IMovie!

As soon as you connect your Camcorder on Mac, IMovie starts automaticly saying: Capture Device



Unfortenately I can not confirm if this works with ext. FirewireHD, because i don´t have one!

If not, use this Procedure to create second script for this kext: IOFireWireSBP2.kext

Please, post it here if you have success with it!!!


Credits to: LioNEXT, McKack and BoNeS!!!


Good Luck!




Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

  • Create New...