Jump to content

Can't install Xcode from apple dev tools


marionez
 Share

7 posts in this topic

Recommended Posts

Hi guys, I'm trying to install latest Xcode downloaded after the registration here: http://developer.apple.com/TOOLS/xcode/

 

It's xcode312_2621_developerdvd.dmg so version is 3.1.2

 

I tried installing an old version (I think it was something like 2.5) and it installed but I can't create executable binary. I need the latest.

 

I get the error at the end of the installation, quite everything seems to be installed the message is:

"Install Failed

The installer could not install some files in "/".

Contact the software manufacter for assistance."

 

So the installation end, I've got quite everything in /Developer directory, there's even the gcc compiler I need as gcc-4.2 binary name from terminal, but at all xcode is not installed. If I try to run a configure there's no gcc:

./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... autotools/install-sh -c -d
checking for gawk... no
checking for mawk... no
checking for nawk... no
checking for awk... awk
checking whether make sets $(MAKE)... no
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... i386-apple-darwin9.6.0
checking host system type... i386-apple-darwin9.6.0
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

 

 

from /var/log/system.log

Mar 17 22:04:35 mypcname login[1400]: USER_PROCESS: 1400 ttys000
Mar 17 22:04:35 mypcname ReportCrash[1398]: Formulating crash report for process installdb[1076]
Mar 17 22:04:36 mypcname Installer[1068]: The Installer could not install some files in “/”. Contact the software manufacturer for assistance.
Mar 17 22:04:36 mypcname com.apple.launchd[1] (com.apple.installdb.system[1076]): Exited abnormally: Bus error
Mar 17 22:04:36 mypcname ReportCrash[1398]: Saved crashreport to /Library/Logs/CrashReporter/installdb_2009-03-17-220433_mypcname.crash using uid: 0 gid: 0, euid: 0 egid: 0

 

 

cat /Library/Logs/CrashReporter/installdb_2009-03-17-220433_mypcname.crash
Process:		 installdb [1076]
Path:			/System/Library/PrivateFrameworks/Install.framework/Resources/installdb
Identifier:	  installdb
Version:		 ??? (???)
Code Type:	   X86 (Native)
Parent Process:  launchd [1]

Date/Time:	   2009-03-17 22:04:33.354 +0000
OS Version:	  Mac OS X 10.5.6 (9G55)
Report Version:  6

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  0

Thread 0 Crashed:
0   libSystem.B.dylib				 0xffff07fc __memcpy + 92 (cpu_capabilities.h:246)
1   libsqlite3.0.dylib				0x913f9ec0 fillInCell + 384
2   libsqlite3.0.dylib				0x913fbef7 balance_nonroot + 7351
3   libsqlite3.0.dylib				0x914026ab sqlite3BtreeInsert + 763
4   libsqlite3.0.dylib				0x91447f23 sqlite3VdbeExec + 8835
5   libsqlite3.0.dylib				0x91451ea2 sqlite3Step + 386
6   libsqlite3.0.dylib				0x9145255d sqlite3_step + 29
7   installdb						 0x0000c47c -[IFDBD_SchemaA(Utilities) pathkeyForPath:insert:] + 463
8   installdb						 0x0000a783 -[IFDBD_SchemaA closeNewReceipt] + 1059
9   installdb						 0x0000b612 -[IFDBD_SchemaA closeReceipt] + 35
10  installdb						 0x00007c27 IFDBD_NewReceiptClose + 103
11  installdb						 0x00002de4 _XNewReceiptClose + 172
12  installdb						 0x00002a02 installdb_server + 109
13  installdb						 0x00002552 my_mach_msg_server_timeout_runflag + 390
14  installdb						 0x000028ff main + 316
15  installdb						 0x00002342 start + 54

Thread 0 crashed with X86 Thread State (32-bit):
  eax: 0xffff07a0  ebx: 0x913fa260  ecx: 0x00000228  edx: 0x00000001
  edi: 0x0002b44f  esi: 0x00000000  ebp: 0xbfffeda8  esp: 0xbfffeda0
ss: 0x0000001f  efl: 0x00010206  eip: 0xffff07fc   cs: 0x00000017
ds: 0x0000001f   es: 0x0000001f   fs: 0x00000000   gs: 0x00000037
  cr2: 0x00000000

Binary Images:
 0x1000 -	 0xffff  installdb ??? (???) <6b056db4d139abcc814c1edf8704dbc8> /System/Library/PrivateFrameworks/Install.framework/Resources/installdb
0x8fe00000 - 0x8fe2db43  dyld 97.1 (???) <100d362e03410f181a34e04e94189ae5> /usr/lib/dyld
0x90003000 - 0x900e4ff7  libxml2.2.dylib ??? (???) <306036e0070330e35045650e6d9f0d05> /usr/lib/libxml2.2.dylib
0x906df000 - 0x90728fef  com.apple.Metadata 10.5.2 (398.25) <e0572f20350523116f23000676122a8d> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/Metadata.framework/Versions/A/Metadata
0x908b8000 - 0x908bffe9  libgcc_s.1.dylib ??? (???) <f53c808e87d1184c0f9df63aef53ce0b> /usr/lib/libgcc_s.1.dylib
0x91211000 - 0x91290ff5  com.apple.SearchKit 1.2.1 (1.2.1) <3140a605db2abf56b237fa156a08b28b> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/SearchKit.framework/Versions/A/SearchKit
0x912d1000 - 0x913b1fff  libobjc.A.dylib ??? (???) <7b92613fdf804fd9a0a3733a0674c30b> /usr/lib/libobjc.A.dylib
0x913d2000 - 0x91459ff7  libsqlite3.0.dylib ??? (???) <6978bbcca4277d6ae9f042beff643f7d> /usr/lib/libsqlite3.0.dylib
0x91460000 - 0x915c7ff3  libSystem.B.dylib ??? (???) <d68880dfb1f8becdbdac6928db1510fb> /usr/lib/libSystem.B.dylib
0x935e9000 - 0x935f1fff  com.apple.DiskArbitration 2.2.1 (2.2.1) <75b0c8d8940a8a27816961dddcac8e0f> /System/Library/Frameworks/DiskArbitration.framework/Versions/A/DiskArbitration
0x936b2000 - 0x9373eff7  com.apple.LaunchServices 290.3 (290.3) <6f9629f4ed1ba3bb313548e6838b2888> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/LaunchServices
0x93826000 - 0x9395eff7  libicucore.A.dylib ??? (???) <18098dcf431603fe47ee027a60006c85> /usr/lib/libicucore.A.dylib
0x9395f000 - 0x9395fffa  com.apple.CoreServices 32 (32) <2fcc8f3bd5bbfc000b476cad8e6a3dd2> /System/Library/Frameworks/CoreServices.framework/Versions/A/CoreServices
0x93960000 - 0x93bdbfe7  com.apple.Foundation 6.5.7 (677.22) <8fe77b5d15ecdae1240b4cb604fc6d0b> /System/Library/Frameworks/Foundation.framework/Versions/C/Foundation
0x93bdc000 - 0x93c39ffb  libstdc++.6.dylib ??? (???) <04b812dcec670daa8b7d2852ab14be60> /usr/lib/libstdc++.6.dylib
0x93c3a000 - 0x93c69fe3  com.apple.AE 402.3 (402.3) <4cb9ef65cf116d6dd424f0ce98c2d015> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/AE.framework/Versions/A/AE
0x93caa000 - 0x93dddfff  com.apple.CoreFoundation 6.5.5 (476.17) <4a70c8dbb582118e31412c53dc1f407f> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x93dde000 - 0x940b8ff3  com.apple.CoreServices.CarbonCore 786.11 (786.11) <f06fe5d92d56ac5aa52d1ba182745924> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CarbonCore.framework/Versions/A/CarbonCore
0x940b9000 - 0x940bdfff  libmathCommon.A.dylib ??? (???) /usr/lib/system/libmathCommon.A.dylib
0x9436b000 - 0x9438ffff  libxslt.1.dylib ??? (???) <0a9778d6368ae668826f446878deb99b> /usr/lib/libxslt.1.dylib
0x9452e000 - 0x94535ffe  libbsm.dylib ??? (???) <d25c63378a5029648ffd4b4669be31bf> /usr/lib/libbsm.dylib
0x947dd000 - 0x9487afe4  com.apple.CFNetwork 422.15.2 (422.15.2) <80851410a5592b7c3b149b2ff849bcc1> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/CFNetwork
0x94f2c000 - 0x94f3affd  libz.1.dylib ??? (???) <5ddd8539ae2ebfd8e7cc1c57525385c7> /usr/lib/libz.1.dylib
0x94fe3000 - 0x9500efe7  libauto.dylib ??? (???) <42d8422dc23a18071869fdf7b5d8fab5> /usr/lib/libauto.dylib
0x9511a000 - 0x951d4fe3  com.apple.CoreServices.OSServices 226.5 (226.5) <2a135d4fb16f4954290f7b72b4111aa3> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/OSServices.framework/Versions/A/OSServices
0x95577000 - 0x95745ff3  com.apple.security 5.0.4 (34102) <55dda7486df4e8e1d61505be16f83a1c> /System/Library/Frameworks/Security.framework/Versions/A/Security
0x95ff0000 - 0x96027fff  com.apple.SystemConfiguration 1.9.2 (1.9.2) <8b26ebf26a009a098484f1ed01ec499c> /System/Library/Frameworks/SystemConfiguration.framework/Versions/A/SystemConfiguration
0x96028000 - 0x9603efff  com.apple.DictionaryServices 1.0.0 (1.0.0) <ad0aa0252e3323d182e17f50defe56fc> /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/DictionaryServices.framework/Versions/A/DictionaryServices
0x96088000 - 0x96113fff  com.apple.framework.IOKit 1.5.1 (???) <f9f5f0d070e197a832d86751e1d44545> /System/Library/Frameworks/IOKit.framework/Versions/A/IOKit
0xfffe8000 - 0xfffebfff  libobjc.A.dylib ??? (???) /usr/lib/libobjc.A.dylib
0xffff0000 - 0xffff1780  libSystem.B.dylib ??? (???) /usr/lib/libSystem.B.dylib

 

 

At the end I launch /Developer/Library/uninstall-devtools to uninstall everything and I still not have any gcc compiler correctely installed.

Any help? Why am I getting this error?

post-303759-1237324747_thumb.png

Link to comment
Share on other sites

Already tried that, even tried enabling journaling, repairing in -s mode with fsck (there was no error).

I definetely don't know which is the problem :(

It's something with these latest 3.x versions, because an older install correctely, don't know...

Link to comment
Share on other sites

whereis gcc didn't reply anything. There was gcc-4.2 binary not gcc, I think the installation was just not complete and not working.

I tried everything, but mac log doesn't help so much.

So the only solution I found was a complete OSX re-install. I did and now it works with any installation error and I can even compile. :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...