Jump to content
Sign in to follow this  

OSX86 on a Shuttle SB51G

12 posts in this topic

Recommended Posts

Oddly enough, the only installation I've been able to boot (after installing) on this system is the XxX PPF3 distro. Needless to say, 10.5.5 runs VERY SLOWLY.


I've tried installing 10.4.6 and 10.4.8, as well as 10.5.X (kalyway, leo4all, ideneb & iaktos); nothing will boot all the way into the OS (usually gets stuck at the first grey screen after installation, with loading circle still moving, but no more activity after a hour or two). I'm guessing PPF3 was successful at runing because of the updated kexts included. Installing with the Voodoo kernel (first one on the list) didn't seem to improve performance.


Anyway, I'm very interested on getting ANY OSX running on this machine that will not take 10 seconds to register a simple scroll bar moving, or delay when clicking on menus (let alone trying to run a program).


Any help diagnosing and fixing this problem will be most appreciated :D


Here's my system's specs:

Chipset: i845GZ/ICH4

FSB: 533

Processor: Intel Pentium 4 Northwood (133 with a 20x multiplier; oc'd @ 150x20=3GHz)

RAM: 2 GB DDR1 (337)

IDE: 2 160GB 7200 RPM drives

Video: GeForce FX-5200 (128MB DDR, AGP 8x

Sound: Onboard - ALC650 (Not working), PCI - SB Audigy 2 ZS (partially working with kx)

Share this post

Link to post
Share on other sites


I took out the eGeForce card and put in a GeForce MX 440; instantly recognized, but if I have it hooked up via s-video, init display fails (though in other installations, it still worked). UPDATE: replaced with FX 5200


I also tried a different hard drive, and it seems everything runs fine (other than the no svideo prob), though. SSE3 emulation seems to work very well.


I would like to get this s-video thing sorted out, but I guess I'll just have to buy another monitor (looks like {censored} on the TV anyway).

Share this post

Link to post
Share on other sites

Ok, after much learning and questioning, I've narrowed it down to what *may* be the problem. I've got a dead (well, last person who owned it says it's dead, and I can't get it to work in windows) ethernet port, which is still detected (just no cable detection). Anyway, the part that it will hang at is inbetween the gfx strings and when you're logged in. realityiswhere told me that it's hanging because of some ethernet related thing, and I can't seem to disable the ethernet port in the BIOS (only enable/disable network boot, which doesn't seem to affect this).


Anybody know how to go about fixing this? It seems to be the only thing holding me back from having a perfectly working Leopard install on this box. As long as I can start, everything else works fine (except sleep seems to work when it wants to; possibly due to the same problem).

Share this post

Link to post
Share on other sites

Ok, so I've decided to resurrect this box as my semi-mobile audio workstation, as it's only slightly taller than a mac mini and I do a lot more music work.


I've decided to ditch the FX5200; not because it was at all a PITA to get working (note: I seem to have a rare version of this card - 2 VGA outputs, which may be why most other people's gfx solutions for FX5200 wouldn't work properly for me. I also dumped the ROM of this videocard with NVFlash for Windows, but I couldn't make a proper NVCAP with it :/ ), but because I put it in another "lost soul" I've decided to waste hours on :). I still have a Radeon 9550 which looks nice with callisto008, but osx without qe/ci is pointless (and borderline sacrilege), so I'll probably just scrap up $40 for a 6200 or better.


Until I get a new card, however, I figured I'd start working on.... everything else. So here's current specs:


Motherboard: FB51G (BIOS 0.37)

Chipset: ICH4

LAN: Realtek 8139 (dead)

Firewire: VIA

Processor: P4 Northwood (SSE2) 478-pin @ 2.7 GHz

Audio: Intel AC '97 Audio (rev. 02)

Video: 845G Brookdale (Of course, no qe/ci, but I'll use it until I get a decent agp card)


So far I've got 10.5.5, with occasional boot hangs after it "started". I'm working on the DSDT at the moment and once I have some fixes working how I like, then I'll post them.


The goal here is to have a fully working install that would be the mac equivalent of the same spec. I will eventually make a boot-132 disc with as few kexts as possible. I will be trying to do as much DSDT fixing as possible to also make all the existing ACPI work as it should, if not better, and of course, the voodoo kernel. Perhaps my project here can benefit some others who have the same PC (museums, perhaps).

Share this post

Link to post
Share on other sites

Ok, a bit of progress... I've done some more DSDT editing and I have managed to spoof my UHCI/EHCI as "built-in" by following apocolipse's guide. Instead of using the same devid's, however, I checked the info.plist of IOUSBFamily.kext (and within the plugins folder, too) and found an ID that was semi-close to my chipset, and supported in 10.5 retail disc, and 10.5.8 Update. Not entirely sure it's done anything, as I still have a few things to do before sleep will work properly, but it looks fine.


Also, using the same idea (and nearly the same method in dsdt) I also spoofed my ATA from ICH-4 to ICH-8 (also supported in all Leo). I was using Dune's kext prior to this, and replaced with IOATAFamily.kext from 10.5.8 update and everything loads up (before dsdt spoof would get "waiting for root device" without Dune's IOATAFamily).


I also did the ISA and SMBus fixes/spoofs, but they don't seem to be working anymore (AppleLPC not loaded in 10.5.8, but it was in 10.5.5.....)


More to come....

Share this post

Link to post
Share on other sites

Attempting to make a boot disc for retail install. Current specs are as follows:


  • ICH4 spoofed as ICH8 (USB/LPC/ATA in DSDT)
  • Pentium 4 Northwood (SSE2)
  • FX5200 AGP (NVResolver for my card)
  • ALC650 (AppleAC97Audio.kext)
  • RTL8139 Ethernet (doesn't work - IONetworkingFamily bocked w/ disabler kext)
  • Brookdale 845-G onboard VGA (disabled)


Here's the kexts I'm using for my /Extra

  • AppleAC97Audio
  • FakeSMC
  • NVResolver
  • NVDAResman
  • NVDANV30Hal
  • VoodooPS2Controller
  • IONetworkingDisabler
  • IntelCPUPMDisabler
  • System (for voodoo 9.5 kernel)
  • blacklist=0 (for fakesmc/voodoo compatibility)
  • MacMini1,1 smbios.plist


The IONetworkingDisabler kext I made seems to get me past the mDNSResponder messages, which is where the install disc would previously hang. I now make it to the leopard background (right before you would select your language), and the color wheel spins infinitely.


I see 3 'FakeSMC' messages during startup - all three messages seem to just give credit to various contributors, but nothing to suggest that FakeSMC is not loading correctly.


I do get one yellow message on startup, saying that AppleHPET did not load correctly - this should not prevent the loader window from launching (to my understanding), though.


If anyone can help me sort this out, I'd greatly appreciate it. I'm using BootCDMaker to make my install disc (with cdboot from ChameleonRC5v699), on a machine running 64-bit snow leopard (vanilla). When I built my mkext I am using the 'i386' option.


Here's my 'extra' folder I'm using to create the boot disc.


Share this post

Link to post
Share on other sites

Ok, I figured out that I needed to use blacklist=0 in my kernel flags so fakesmc could load. Much much progress. I now have a boot disc with gfx support for my fx5200 (listed as pci still, however), working ac97 audio (system profile doesn't reflect this), etc. Couple more tweaks and this will be a complete build ;)

Share this post

Link to post
Share on other sites

I've resurrected this project once again! Quite a bit of change to the system, most notably swapping the 5200 for a 6200. I also added a pci airport card. I'm thinking of deleting this thread and making a new post about it, but I kinda like having it as a log of when I started...


So as of right now, the box is working rather flawlessly in most aspects. S-video isn't working, which is one of the more important aspects for this particular box. Considering DVD playback is skipping a bit too, I'm considering getting a better video card (although the 5200 played DVDs flawlessly in 10.5.5). Perhaps I just need to tweak the DSDT a bit more in this area.


So, recap of this project:



  • Pentium 4 Northwood (SSE2 only)
  • nVidia GeForce 6200 LE 128MB AGP
  • ICH4/865G
  • Realtek ALC650 AC97 Audio


/Extra/Extensions - With the current versions of chameleon, it seems I can't load my AC97 kext unless it's in /S/L/E - on version 748 it would load if I made an Extra/Extensions.mkext that included IOAudioFamily.kext

  • FakeSMC (modified with version 1.30f4)
  • AppleAC97Audio
  • IntelCPUPMDisabler


DSDT modifications:

  • USB spoofed as ICH8
  • ATA spoofed as ICH8
  • SBus spoofed to ICH8
  • Graphics Injection entry
  • Listing for Airport PCI card
  • Darwin entry
  • HDEF added (though it doesn't show much in profiler)
  • some cleanup


The system is as vanilla as it can get (short of apple suddenly writing a SSE2 kernel for leopard or a way to get my AC97 working without this non-stock kext), unless we find a way to achieve fakesmc's job within DSDT. There are still a few things I need to fix, mostly cosmetic:


  • Get S-Video port to work
  • Get System Profiler to report Graphics card as AGP
  • Get System Profiler to gather memory information
  • 'About This Mac' always crashes Finder - I'd like to find a way to fix that...
  • Add audio lines in/out for 'Audio' section of System Profiler
  • Fix/Customize what System Profiler reports for 'Bus' and 'Slot' for devices


I'll update with any progress - and if anyone can lend a hand in figuring out my 'To Do' list, I'd sure appreciate any help :)


Here's my current dsdt / plists / info / etc:







Share this post

Link to post
Share on other sites

I have the same system Shuttle SB51G but paired with an ATI Radeon 7500 graphics card with 64 MB of memory.


Which version is most suitable for me and if you can point me in a direction on how to start installing, it would be great. Please send me a private message.


It just feels so good to find a fellow user of SB51G, seriously :-)

Share this post

Link to post
Share on other sites



I'm currently tring to get 10.6.6 installed on this machine. Only difference in mine is I have a geforece 7600 APG 4x/8x card with 512mb DDR2. I can not get it to boot but want SL over Leo if I can get it on there. SO far no luck booting Hazard 10.6.6i yet...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.