Jump to content

Broadcom 4311 on Compaq v5000 Plz Help!


7 posts in this topic

Recommended Posts



First of all i want to thank the iATKOS team for the distro. It worked very well then any other i have tried. This is the first time i could be successful in installing MAC on my PC. As said every thing worked out of the box except my Broadcom 802.11 wireless card. I have tried every thing i could find online about it without any success. Please Help.



Compaq Presario v5000 series

Intel Celeron M 1.46 GHz


From XP device manager my Wireless card shows these details:

Broadcom 802.11b/g WLAN







Link to comment
Share on other sites

Thanks for Replying Guys...


@kennyp I selected Broadcom under Network. What can i do now to fix this?



@Nick14 Can you give me some details about Chan Nun Fix.



Thanks Again.


Link to comment
Share on other sites

Hey neo, Chun-Nan changed his user name to ~Eureka. Here's the relevant post from my Compaq BCM4311 thread:

Hi guys,


Here are the new revsions of IOPCIFamily. You can use tools (like OSXTool or kexthelper) to install the kexts or you can try these steps:


1. Make sure "IOPCIFamily" is inside "System/Library/Extensions"

2. Open "Terminal"

3. Type "sudo -s"

4. Type "chown -R 0:0 /System/Library/Extensions/IOPCIFamily*"

5. Type "chmod -R 755 /System/Library/Extensions/IOPCIFamily*"

6. Type "touch /System/Library/Extensions"

7. Exit "Terminal"

8. Reboot the OSX





IOPCIFamily.Leopard.zip ( 51.92K ) Number of downloads: 181




IOPCIFamily.Tiger.zip ( 224.86K ) Number of downloads: 11



QUOTE(CyberTron88 @ Sep 23 2008, 10:33 PM)

Hi! Is the one attached on post #10 the latest beta 3?


I tried it on my Toshiba Satellite L310 and got some partial success. Sometimes I would get kernel panic halfway during booting up, or freeze after awhile, sometimes just hangs while booting halfway.


Ever managed to boot up and configured the wireless and run safari to get online 2 or 3 times, and that's about it.


I'm using iATKOS 4i installation.


Hi CyberTron88,


This one is not the same as the beta3. Beta3 didn't double check to see if the ethernet/wireless device really get the correct memorry resource. Beta3 mainly foucus on pccard issues. Maybe in the future, I will try to combine those two together.




QUOTE(celioregolik @ Sep 24 2008, 06:34 AM)

Lately I have tried 2 versions of macosx leo4all 10.5.2 and kalyway 10.5.1.

With Kalyway is somewhat slow and the on-off button of the wireless light on but does not work

instead the button turning on your PC works.

with Leo4all the on-off button of the wireless work fine and the button up-shutdown pc does not work.

I would like to have both operating buttons.



Hi celioregolik,


I don't have leo4all and kalyway so I am not sure what version of IO80211Family and IONetworkingFamily they have in DVD.



Link to comment
Share on other sites



Thanks a Million! It Worked...


I first tried it but it didn't work.. maybe because i had already screwed up so many configuration files and kexts etc.


Then i quickly installed iATKOS 4i all over again and this time following kennyp's instructions and did not selecting any thing under Network in the Custom Install.


It didn't work OOB but then I applied your fix download the IOPCIFamily.kext and replaced it with the existing one ran the "Repair Disk Permissions" from the Disk Utility.


AND now I'm writing this message over my wireless connections.



Thank you all of you iATKOS, Chun-Nan and the entire InsanelyMac community.


Now I'm going to write a detailed post about my experiences from more then a month to get these shiny things working on my laptop.




Link to comment
Share on other sites

  • 6 months later...

Hey folks, firstly THANK YOU! for the info I've almost got the Wireless working correctly in my Presario V5000 (Intel chipset). After fiddling I can get the wireless to work but ...


Firstlt on boot it doesn't auto connect to the preferred networks, though if you open the Air Port pref its in the drop down list and when you select it it connects and everything works. (I'm looking at scripting this selection as a temporary fix).


Secondly even once manually connected the "AirPort" logo on the task bar never shows as connected, when you click it it always says "AirPort: Not Configured", even when in Network Prefs it shows as connected and I can surf the web (Like I am doing now!).


Like I say it works but its a bit finiky, any help resolving the issues would be appreciated. Also used the AppleUSB Kext and that got my USB ports working!


Many Thanks



Link to comment
Share on other sites


  • Create New...