Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Zero0000

Diamond Xtreme 16-Bit 5.1 PCI Audio Device Fix

7 posts in this topic

Recommended Posts

Well here is the Diamond Xtreme 16-Bit 5.1 PCI Audio Device Drivers for OS-X.

It may work on other C-Media Devices as well.

 

I am currently using this now and I can confirm it does work properly.

 

Use Kext Helper b7 to install the driver.CMI8738PCIAudioDriver.kext.zip

Share this post


Link to post
Share on other sites

Well i have integrated C-Media 6501, it's recognized as USB Audio and everything works well, but i miss my 6 Channels audio, so, i'm thinking about connecting my X-Sound 5.1 PCI card (CMI8738), will this driver enable 6 channels output?

Share this post


Link to post
Share on other sites
Well here is the Diamond Xtreme 16-Bit 5.1 PCI Audio Device Drivers for OS-X.

It may work on other C-Media Devices as well.

 

I am currently using this now and I can confirm it does work properly.

 

Use Kext Helper b7 to install the driver.CMI8738PCIAudioDriver.kext.zip

 

 

Dude all I can say is THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU THANK YOU!!!!!!!!!!!!

 

I spent a few frustrating days screwing around with my built in sigmatel HD Audio. I finally gave up today. While I was at Staples I bought this Diamond Xtreme for 20 bucks. I checked this forum on my blackberry before I left the store and this driver works!!!!

 

 

Ahhhh...sweet sound!

Share this post


Link to post
Share on other sites
Well here is the Diamond Xtreme 16-Bit 5.1 PCI Audio Device Drivers for OS-X.

It may work on other C-Media Devices as well.

 

I am currently using this now and I can confirm it does work properly.

 

Use Kext Helper b7 to install the driver.CMI8738PCIAudioDriver.kext.zip

 

I just resurrected my rig, after months of neglect due to new Macbook purchase.

 

Asus p5k

q6600

7300gt

 

Before when I installed kalyway 10.5.1 the diamond card worked out of box even though it did not show up in system profile. After updating a fresh 10.5.1 to 10.5.6 card stopped working but this kext worked with 10.5.6. Thanks

Share this post


Link to post
Share on other sites

I also wanted to thank you. I installed it on Lion once and it worked great. I just happened to reinstall it and now it's not working right. I don't know what's different. The sound is crackly. Do I need to have another next that I may be missing?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×