Jump to content

adi1986a Finally with AppleHDA kext


9 posts in this topic

Recommended Posts

Although no SPDIF Out,Mic,Line in now but atleast Line Out...i will investigate other thing later...


The main reason for some 1986as didnot work is there is a problem with linux codec dump

i used madtux and the king guide for finding "pinconfig"(using vista) and what i found out was linux codec dump was completely wrong...this may work only for Subsystem Id: 0x104381b3 now ...

1.15 hdapatcher only recognised but no sound,so used 1.13 it worked like charm....

but 1.13 alone worked without 1.15 already existing but anyway i got success..


1)use the text file attached in 1.15 hdapatcher first

2)after installation restart

3)install with patcher 1.13 and restart



Link to comment
Share on other sites

  • 2 weeks later...

I have the Same Sound Card, i Installed only Azalia Audio Package and its work fine because i dont have Microphone Support, it´s this the Solution? I doesnt Understand it, my English is Bad. Sry

Link to comment
Share on other sites

How to PinConfig

U can obtain this PinConfig thru Vista registry explorer.

Click on:



and write: regedit (this will start registry explorer)

Search for PinConfig, and U will get something like this:


Then as user idoc said: "strip out the junk!"

f01c2701 111d2701 111e2701 411f2701 f01c3701 111d3701 111e3701 411f3701 1f1c4701 101d4701 211e4701 021f4701 101c5701 011d5701 131e5701 991f5701 f01c6701111d6701 111e6701411f6701 401c8701981d8701 a11e8701021f8701 411c9701091d9701 a31e9701991f9701 4e1ca701301da701 811ea701021fa701 f01cc701111dc701 111ec701411fc701 2d1cd701951dd701 171ed701401fd701 301ce701111de701 451ee701021fe701


then you have to byte flip each double word;

<01271CF0 01271D11 01271E11 01271F41 01371CF0 01371D11 01371E11 01371F41 01471C1F 01471D10 01471E21 01471F02 01571C10 01571D01 01571E13 01571F99 01671D11 01671CF0 01671F41 01671E11 01871D98 01871C40 01871F02 01871EA1 01971D09 01971C41 01971F99 01971EA3 01A71D30 01A71C4E 01A71F02 01A71E81 01C71D11 01C71CF0 01C71F41 01C71E11 01D71D95 01D71C2D 01D71F40 01D71E17 01E71D11 01E71C30 01E71F02 01E71E45>



this is the way to get pinconfig....but you should not have installed the sound driver from motherboard vendor(it changed registry in my sys)....

Link to comment
Share on other sites

  • 3 months later...

Hey!I use iPc osx 10.5.6, and installed the Ad1986 driver included in the installer, audio works, bt no microphone!I tried this method, patch with 1.15, restart,(no sound at all, no device) then with 1.13, now i have sound but no input device..i shouldn't have installed the driver of the install disc, or what could be wrong?Any other ways to get sound+microphone work:S?

Link to comment
Share on other sites


  • Create New...