Jump to content

Success: Motherboard Works Except Gig-e, Raid


2 posts in this topic

Recommended Posts

Method: Disk image written to partition using dd in gentoo linux (installed natively, not a cdrom). Reverted to original coregraphics since I have an SSE3 CPU (Intel Pentium 4 540, otherwise known as 3.2ghz prescott core P4, LGA775).




Asus P5GDC Motherboard, Intel 915P nothbridge, ICH6R southbridge:

Onboard C-Media 9880 "Azalia" HD Audio - worked immediately on booting, green output jack. Kextstat revealed an AppleAzaliaAudio kext at work, not an AC97 kext.

Onboard Marvell Gigabit Ethernet - not working

Onboard Firewire 400 - worked immediately on booting

Onboard USB 2.0 Provided by Intel ICH6 Southbridge - worked immediately on boot.

Onboard SATA (ICH6R southbridge)- Works in when not in AHCI or RAID mode, but I have it set to RAID.

Onboard IDE RAID (ITE Tech. 8212F chipset) - NOT working in any mode.

Onboard IDE (ICH6R southbridge) - Works with no tweaking needed or any issues.


Audigy 2 ZS Sound card :

Its firewire is detected and works, the sound does not.


Tv tuner (BT878 chipset):

not working


NVIDIA Geforce 6600GT (PCI Express):

-Booted and ran without any issues or tweaking needed

-Running in VESA 3.0 mode


-Resolution change successful through boot parameter AND/OR plist editing HOWEVER specifying refresh rate at 1280x1024x32 causes reboot loop. Since I have an LCD, refresh rate does not matter, so I set it to "1280x1024x32", and it runs great. I tried @60, 70, and 75 and they all caused teh reboot loop issue. My advice it to run it at whatever apple's 1280x1024x32 default is. I do NOT need to specify platform x86 or any {censored} like that for the resolution to work


USB 1.1 card reader, USB 2.0 memory stick:

-Automounts fine on insertion, both devices run at their proper speeds.


D-Link DWL-G122 USB Wireless Adapter (A2 revision with PRISM GT USB chipset):

-Does not work.

-Tried apple PrismGT USB driver from their site, would give architecture error (expected PPC, found i386).

-Seems I am one of the few unlucky bastards with teh A revision <_< . The B sports a RT2500USB chipset which seems to work with a special driver in osx86, and also in linux, where as mine has no osx86 hope, and kernel panics after a few minutes in linux with ndiswrapper. :)


NTFS Volumes on supported controllers:

-Automounts fine, no tweaking needed




- So far the only software I have used which requires rosetta is itunes. It did NOT work until I reverted to the original SSE3 coregraphics from teh dev DVD. Works GREAT now.


- System boots very fast, shuts down and turns machine off fine (no ACPI issues)

Link to comment
Share on other sites

  • 4 weeks later...

  • Create New...