Jump to content

Apple 10.5.4 : Will it work out of box in Intel


stirucherai
 Share

8 posts in this topic

Recommended Posts

Dear All,

 

I loaded Kalyway 10.5.2 and then upgraded to 10.5.3 (applied the patch as well). Now I have good working 10.5.3 -- Can just download 10.5.4 upgrade from Apple and install with out any patch. Will it work

 

Please let me know

 

( I tried using the Upgrade 10.5.4 guide and tried -- but Mouse and Keyboard hangs)

 

Thanks and Regards

Link to comment
Share on other sites

Thanks a lot for reply

 

10.5.2 -- From Kalyway

10.5.3 -- I download kalyway. upgraded and patched.

 

10.5.4 -- I downloaded from Apple site directly.

 

After applying 10.5.4 -- When I boot it failes with "out range" error. When I applied the patches as communited in this forum (v4.2) -- I could boot but the Mouse and Keyboard are in-active.

 

Please help

 

My Machine

CPU : Pentium 4, 3066Mz

CPU Alias : Prescott

CPU Setting : G1

Instruction Set : X86, x86-64, mmx, SSE, SSE2, SSE3

Display Chip : ATI Radeon Xpress 200

RAM : 512MB

 

Motherboard ID : GC11020M.86A.1058.2006.0330.1109

 

Motherboard Name : Unknown

 

Harddisk : Driver Description ST380211AS (Configure SATA as IDE)

ATA/IDE Mode : Enhanced

Link to comment
Share on other sites

during boot try hitting F8 or whatever key it tells you to input data prior to boot

 

then type:

 

"Graphics Mode"="1024x768x32"

 

that should get you in

 

if not try:

 

"Graphics Mode"="1024x768x32@60"

 

(using the @refresh rate on mine causes restarts due to my drivers but otherwise it works correctly)

 

I suggest setting it low because the update might have *screwed* up your drivers

Link to comment
Share on other sites

No.

 

Pentium 4 is old type, and not work with vanilla kernel. Period.

 

1. copy Your old kernel with the new name.

 

cp mach_kernel mach_kernel_bak

 

2. keep terminal open

 

3. drive update, BUT DO NOT RESTART

 

4. copy Your old kernel with the new name back to name: " mach_kernel "

(because: there is now new not working vanilla type kernel in Your root level.)

 

ls -la

cp -f mach_kernel_bak mach_kernel

 

5. fix rightness and userlevel to right.

 

chown -R root:wheel mach_kernel*

chmod -R 755 mach_kernel* (hmmm... 644 ?)

 

6. in the end in terminal write: diskutil repairPermissions /

 

7. wait

 

8. NOW reboot.

 

====

 

This is step by step my system:

 

1. Kalyway 10.5.1

2. Restore factory settings

3. Finnish.pkg

4. Kalyway combo update DO NOT RESTART

5. Kalyway 10.5.3 kernel.pkg

reboot and type: update -v <- very important to remember!

6. Then I fix my framebuffer to old version. (=more resolution)

7. 10.5.4 build 9e6 delta update

8. Update Modbin 9.4 with osx86 tools (kernel+system kext)

9. THEN Mac osx update "10.5.4 update" like I wrote early.

10. QuickTime, iTunes, FrontRow, Airport, iLife and yes:

Sec update 2008-005 and Java and Safari 4 update.

11. Kernel ToH & StageXNU 1228.5.20 with osx86 tools.

 

=> Fullworking AND sleeping 9.4 kernel with the most last system.

 

 

Hope this help a little.

 

Tuure

 

-.-

Link to comment
Share on other sites

THANKS A LOT. It worked

 

Now I am little more greedy. Is there any way to increase the partition size of "/"

 

I have 2 partition of 10GB -- One is Called MacOS in which I have installed 10.5.4 and another one MacDATA. I want to merge MacData to MacOS partition. Is ther any way with out killing my existing MacInstallation

Link to comment
Share on other sites

 Share

×
×
  • Create New...