Jump to content

Can OSX 10.5.2 (Kalyway or Leo4all) Be installed on an Intel Centrino HP laptop?

Will V

15 posts in this topic

Recommended Posts

What's cooking guys?


I'm trying to get OSX 10.5.2 installed in my HP laptop. I have a spare HD and i'm trying to install it as my primary OS. I've tried both DVDs but apparently both DVDs get during the loading page. I dont even get to the blue screen with the color cursor... So i was wondering if any of these 2 OS can be installed in my laptop? perhaps someone else has tried it and can confirm this for me or even recommend another version that i should try.


Thank you,


Will V.

Link to comment
Share on other sites

Thanks for the info, i was hoping someone could tell me whether it works or not.


When i try the Leo4All 10.5.2 it gets stuck on a blue screen after the booting off the DVD (where i'm supposed to get the color cursor which never comes on)


When i try Kalyway it gets stuck on the loading screen when booting off the DVD (the darwin loading screen)...

Link to comment
Share on other sites

Use the Leo4all disk to install. The blue screen with no cursor means it has switched to external monitor and treating your laptop screen as secondary. You need to connect an external monitor during the install and your laptop screen can be enabled once you have completed the install by using natit for GMA 950 or X3100


PS: And someone can tell if it works on your laptop if you tell us what laptop it is! HP Intel Centrino laptop just doesnt make any sense

Link to comment
Share on other sites

Thanks for the reply Gujal!


I'm currently doing exactly what you said and i able to see the setup screen now. (currently going thru the settings)


The laptop where i'm installing OSX in is an HP NC6220 and here are the specs (I should've had been more specific from the beginning)



At A Glance

Genuine Windows XP Professional,

Genuine Windows XP Home Edition (select countries only), or


Certified for Novell Linux Desktop 9

Intel® Pentium® M processors 740 to 780*

Sleek industrial design starting at 4.69 lb/2.13 kg and 1.04-inch/26.5-mm thin

14.1-inch display

Mobile Intel 915PM Express Chipset on nc6230 model

Mobile Intel 915GM Express Chipset on nc6220 model

256-MB DDR2 SDRAM, upgradeable to 2048-MB maximum

Up to 80-GB 5400 rpm, user-removable hard drive

ATI MOBILITY RADEON X300 graphics controller with 32 or 64 MB of video memory (on nc6230)

Intel Graphics Media Accelerator 915 (on nc6220 model)

Optional integrated 802.11 a/b/g or 802.11 b/g wireless LAN module

Support for optional Intel Centrino™ mobile technology

Optional integrated Bluetooth®

Integrated Secure Digital (SD) flash media slot

Security features including integrated Smart Card Reader and optional Trusted Platform Module (TPM) Embedded Security Chip

NetXtreme Gigabit PCI Express Ethernet Controller

Dual pointing devices

Support for ultra-slim MultiBay II devices

Processors Intel Pentium M processor 780* (2.26-GHz, 533-MHz FSB, 2-MB L2 cache)

Chipset nc6220 model: Mobile Intel 915GM Express Chipset

Link to comment
Share on other sites

Thanks for helping me out with this.

I'm actually still working on the laptop LOL I'm going for a second install cause the first time the installation finished successfully; however, after clicking on restart, the darwin loading screen keeps on coming up and it just goes on a loop. It appears to be loading, then it restarts the machine again and so on. Dont know if it makes any difference but I first picked Vanilla Kernel 9.2.2 and now i'm trying with vanilla kernel 9.2.0. If that doesnt work then I'll have to look more into it.

Link to comment
Share on other sites

You cant run Vanilla kernel on your laptop. chose SSE2 patched kernel

Vanilla kernel can run only or Core2 Cpus and the very latest Pentium D and Celeron D (i dont have the model numbers off hand)

Link to comment
Share on other sites

LOL another installation gone LOL I'm sure I'm not the only rookie going thru this or that have gone thru this LOL... I was actually folllowing the instructions from the wiki site http://osx86leo4all.wikidot.com/installation-support which recommended Vanilla kernel for intel processors but didnt specify that it applies to Core 2s.


But then again, thankfully you've been able to guide me.


Booting from DVD again now... going for my 3rd try since like you already expected it didnt work LOL... i'll My other choices are Kernel 9.2.0 and Kernel 9.2.2 which supposely are for AMDs. I dont see any other kernel stating that is patched but they do say SSE2 & SSE3


Okay so i'm at the customize screen right now. Besides the Vanilla kernels my other 3 choices are Kernel-9.2.0 (Speedstep 9.2.0 kernel SSE3/SSE2 from Netkas), Kernel-9.2.0-Sleep (Sleep 9.2.0 kernel from Netkas SSE2/SSE3) and finally Kernel-9.2.2 (New modified 9.2.2 kernel SSE3 only from Modbin)


So i'm going with Kernel 9.2.0 (SSE2/SSE3). As for the drivers i picked Intel-ICHx for chipset, AC97 for Audio and for GMA950 eventhough you said ti wont work but i just put it so it can load a driver. (installing right now)

Link to comment
Share on other sites

Hey Gujal!


I got the OS running (pretty good i may add). I got sound, Ethernet, Video (using the drivers from the link you gave me) and everything else seems to be working just fine. The only one thing that is missing drivers is my wifi card (Intel PRO/Wireless 2200). I'm currently reading the instructions to install the IWI200 drivers from iwidarwin as those are the only drivers i've found. the only drawback is that i ready it cannot be use thru the apple's wifi manager or connect to WEP networks :tomato: but I guess some sort of wifi is better than nothing right?


Thanks again for all the help you provided!

Link to comment
Share on other sites

  • 1 month later...

Hi! I´m trying to get OSX 10.5.2 installed in my HP laptop too, It's the same hp compac nc6220, and I have the same problem, the blue screen without any cursor, I read what Gujal said and I conected my lamptop to an external monitor (I tried 3 different monitors) but I can´t connect to any monitor because I have the same message: signal imput out of range, I tried t o change the BIOS configurations of the vga port or something but it doesen't works.

I'm lost and I need some help, thanks.

Link to comment
Share on other sites

well, Now I see the choose lenguaje screen but only the first 1/2 of the screen, now my problem is to change the resolution because I cant click on the continue, It's on the other half of the screen that don't apperas in my monitor, I need a good resolution.

Link to comment
Share on other sites


  • Create New...