Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Paween

How to disable Mirror Displays!

12 posts in this topic

Recommended Posts

Please tell me how to disable mirror displays via UNIX command or edit preference files.

I can't setup on connected external display because it fail screen. I think I have to change configuration on preference files.

Share this post


Link to post
Share on other sites

System Preferences -> Display -> Arrangement -> uncheck Mirror Displays checkbox. The setting should be saved just fine. If you've set Mirror Displays but the dialog now opens on a second screen that for some reason doesn't show picture, disconnect the external monitor, then check the checkbox "Show display menu" option in Displays and you'll have a display icon in the top toolbar that you can click and turn mirroring off. Don't know if that'll help.

Share this post


Link to post
Share on other sites

Actually 'System Preferences -> Display -> Arrangement' appears only after you connect the second screen, and if you selected mirror display setting (and didnt work; so basically you dont see a thing) it will load up right after you connect the 2nd monitor, and again you wont see a thing to be able to change the settings....

 

You could try pluggin another screen and see if that resets the dual screen settings,

Another option is try playing around with switchResX. With this app you can choose the screensets in forehand... then load them with a keyboard shorcut or expose

Share this post


Link to post
Share on other sites

Infact, when I connect the second screen, both of screen are flick. And then I can't setting anything.

It's bug of my GMX3100 driver.

 

Thank you very much everybody. SwitchResX can help me!.

Share this post


Link to post
Share on other sites

I have the same issue here and I found another solution. Actually, use SwitchResX seams to be the simplest way, but I've just forgot it...

I use an AppleScript that open system pref. > displays > and uncheck "mirror display" (dono why I check this early...)

 

Here is the link source [link]http://forums.msiwind.net/mac/how-you-turn-mirror-off-t6266.html[/link]

and here is the code source:

 

tell application "System Preferences"
  activate
  reveal anchor "displaysArrangementTab" of pane id "com.apple.preference.displays"
  tell application "System Events"
  tell application process "System Preferences"
	 tell window 1
		tell group 1 of tab group 1
		   click checkbox "Mirror Displays"

		end tell
	 end tell
  end tell
  end tell
end tell

 

Thanx for remind me about SwitchResX is so cool!

Share this post


Link to post
Share on other sites
I have the same issue here and I found another solution. Actually, use SwitchResX seams to be the simplest way, but I've just forgot it...

I use an AppleScript that open system pref. > displays > and uncheck "mirror display" (dono why I check this early...)

 

Here is the link source [link]http://forums.msiwind.net/mac/how-you-turn-mirror-off-t6266.html[/link]

and here is the code source:

 

tell application "System Preferences"
  activate
  reveal anchor "displaysArrangementTab" of pane id "com.apple.preference.displays"
  tell application "System Events"
  tell application process "System Preferences"
	 tell window 1
		tell group 1 of tab group 1
		   click checkbox "Mirror Displays"

		end tell
	 end tell
  end tell
  end tell
end tell

 

Thanx for remind me about SwitchResX is so cool!

 

An excellent script that worked for me on 10.5! Thank you!

Share this post


Link to post
Share on other sites

another method would be connecting from another computer with remote desktop/ssh

Share this post


Link to post
Share on other sites

Is there any way to leave the Mirror Displays box unchecked permanently? Every time I connect to a projector, it messes with my screen resolution and I have to uncheck the box again.

 

Thanks,

 

Patrick

Share this post


Link to post
Share on other sites

Yeah, this is my question too, I am looking through the web for quite a while for the permanent disablement...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×