Jump to content

VGA: family specific matching fails ...then crash!

12 posts in this topic

Recommended Posts

Hey everyone,


booting works until then following message appears:

"VGA: family specific matching fails"


then it just stops and nothing happens. (I tried -x too...)




My System:


Pentium M 725

ATI 9700 Mobile

512 MB RAM

80GB Harddrive

Synoptics Touchpad v4.6


Link to comment
Share on other sites

Try booting into single user mode... (-s at boot prompt).


Then once you get to the prompt, do the steps that will be displayed to mount the root filesystem. Then type 'su', and enter your root password.


Next, cd /System/Library/Extensions. In there delete every ATI file, but I don't recall their exact names off-hand. Worth a try, at least it let my HP Compaq NC6000 get past that message when I did this.

Link to comment
Share on other sites

Got the identical problem, even in safe mode, and got the same hardware....please UP...anyway i tried to:


1- delete ATI9700gldrive.bundle (actually renaming it, i have only win, no mac, so i don't want to DD again if i lose some files)


2- edit /System/Library/Extensions/AppleI386PCI.kext/Contents/Info.plist with my cpu->agp bridge (actually the same from davidred, pci8086,3341)


I noted that darwin at its boot, before specify the boot options, says that i have a 9600 128megs, but i actually have a 9700 128 megs..so it could be the same problem with 9600 friends (let me crosspost for this, it could be useful for both topics)


starting both in safe or not mode hangs at the same point....actually not the same, but i think for the same problem...when in safe mode it hangs with this "VGA: family specific matching fails" for 3 times, and in normal hangs at synaptic mouse recognizing, but after displaying 2 times "VGA: family specific matching fails"


so now i'm going to add at /etc/rc the ATIRadeon9700 kext, and let see if it starts or it hangs again...the bad thing is that in /Library/Log/CrashReporter/ there's no crash report except two old ones from the image that i DDed (tiger-x86-flat.img), so they don't care...this is gorgeus B)

Link to comment
Share on other sites

  • 2 weeks later...

hi all,

for fix vga problem at boot follow this istruction:


- reboot system in single mode

exec in shell:

mount -uw /

- go to /System/Library/Extensions

- make a directory in your home (root home is /var/root, for others users is /Users/"shortname")

- move all video extension to this new folder, except your Video Extension

( my video card is Intel830, my extension is IONDRVSupport.kext, AppleIntelIntegratedGraphics.kext and AppleIntel830* )


now exec:


sh /etc/rc


if view blue screen and login windows... work! :)

else see into every video extension (.kext) and find the dependencies

(another method for find dependencies is manual load extension with:

kextload -t file.kext

if extension not load you can view every error )

enjoy man ;)

Link to comment
Share on other sites


  • Create New...