Jump to content

Leo4Allv3 Geforce 6800 NVInject No QE


16 posts in this topic

Recommended Posts

Hey guys, I've used Leo4All V1-2 and as soon as I've booted into the OS, I've ALWAYS had QE enabled on my 128MB AGP Geforce 6800.


But, as soon as I've installed Leo4AllV3, I no longer have QE supported. I've tried every version of NVInject from the disk, I've added my deviceid I believe the correct way, and I still have no QE support.


Everything else works fine, but for some strange reason this release makes QE disabled and I'm not allowed to change my resolution.


Can someone PLEASE help me, as I have no idea what to do now, as I've tried to install every version I could, and it's just not working for me.


My card is a Geforce 6800 OC, 128MB AGP. It worked on NVInject 0.1.3 when I used iATKOS, and it worked with 0.1.3 when I used Leo4All Versions 1 and 2, but it won't work with 3 no matter what I do and it's the only thing I'm having trouble with.


Please help.

Link to comment
Share on other sites

have an asus a8js with go7700 and had no problems with 10.5.1 and nvinjectGO 0.2 512


I installed fresh leo4all v3 and had no problems with install and can boot to standard 1024x768 without choosing any video options.

However, any video option install gives me a lockup and black screen after near complete boot.

I can get into safe mode and see a complete 1440x900 display (which I think is odd) but normal boot nothing.

I've tried nvinstaller 0.33 and 0.41 and tried different mem settings and anything other than simpe vga I get a lockup.

Any help would be appreciated

Link to comment
Share on other sites

didn't work for me...it says the extensions weren't installed correctlydidn't work for me...it says the extensions weren't installed correctly



¨repair permissions... how to´s all around here

Link to comment
Share on other sites

  • 3 weeks later...

i took these files and got a kernel panic. i use Leo4all V3 Final with modbin's kernel 9.2.2

i tried all kernels and drivers available on dvd and best what i've got is ability to change screen resolution and refresh rate. i've tried Natit also. there are still no QE/CI. i've tried NVinstaller 0.41 and got kernel panic. in tubgirl osx 10.4.8 amd sse3 with Titan my video works great. it works in JaS 10.4.8 intel/amd. it does not work in Leo4allv3final. help please.

Link to comment
Share on other sites

I've been having similar (non-Russian) problemos with Leo4allv3 on my 128MB AGP GeForce 6600 GT. I've tried two of the three NVinject versions, and will try version 0.2.1 next. With the first two attempts, I had video but only 1024 x 768 resolution and QE unsupported.


I got all the resolutions and QE working with a Kalyway 10.5.2 install using Kalyway's NVinject-128, but FW and USB and iCal not working discouraged me there. All 3 work in the two Leo4all installs I've done (if iCal is run under Rosetta). Now if I could only get the dang video to work better, I'd have QE and VLC would run, and I'd be set.


I tried Macshiba's download, but got similar kernel panics as reported, even though I did the 3 holy steps of:


sudo chmod -R 755 /System/Library/Extensions/*.kext

sudo chown -R root:wheel /Sytem/Library/Extensions/*.kext

sudo rm -R /System/Library/Extensions.mkext


I can't use iATKOS, because I'm on an AMD machine. And the Zephyroth 2.5.2 ver 2 install DVD won't do an install or even give me any sort of Darwin bootloader. Way faster than something could boot, it just shows a grey curtained screen saying to restart the computer in 3 different languages. And that comes up every time I try to boot from the Zephyroth DVD.


I could go on and on with such travails, as I'm sure everyone here could. This is my fifth day.


The best one that happened today was when, during an install, I for some stupid reason partitioned my IDE 120GB 3.5" internal drive as GUID ("Gee, that sure seems like a nifty idear!"). Later that install failed, so on restart I could neither boot nor get into BIOS to change things to boot from my internal SATA drive that has Tiger running on it (the disk I'm aiming to update to Leopard once I get all the kinks worked out on the IDE drive).


At that point, I was totally stuck. WTF to do? Sphenopalatine ganglioneuralgia. Then venting hysterically at heinous computer and devilish digital daemongods. Gnashing of teeth. Swinging of oxgoad.


Suddenly a bright green LED lit somewhere in my melting grey matter: I remembered I just happened to have an external USB IDE disk laying around somewhere. A few boxes to sort through, a few screws to unloosen to open the enclosure, and I found that not only was the drive inside also 3.5", but it was in fact the same brand as the one in my computer and 45GB LARGER.


I exchanged drives and popped the now GUID-partitioned 120GB piece of whaledreck into the external enclosure and the 165GB drive into the computer. My BIOS easily recognized the new drive, I changed startup disks, and I was able to banish all GUID evil with Disk Utility. My little then problem was solved, with some extra disk space on the side for my histrionics.


Happy daze were here again!


But that was 3 or 4 installs ago, and now just this one little iddy bitty NVIDIA problem to overcome...

Link to comment
Share on other sites

I finally got different resolutions to work on my display, but am still trying to get QE to work. How I got the resolutions enabled:


I installed with Leo4allv3 using NVinject 128 ver 0.2.0 and then replaced the resulting NVinject.kext with one I got from a Kalyway 10.5.2 install where I'd selected NVinject-128. I also copied over from that same Kalyway install these two kexts that weren't already in the Leo4allv3 install: NVDANV40Hal.kext and NVDAResman.kext.


I then did the following to all 3 kexts:


sudo chmod -R 755

sudo chown -R root:wheel


and then:


sudo rm -R /System/Library/Extensions.mkext


I'll update if I can get QE to work.

Link to comment
Share on other sites

I think I have a very easy solution :


tested on my Dell i9300 with 6800Go 256MB


first install Leo4allV3 without any video driver selected (select other drivers, and good applications too)

Leo4allV3 has almost everything working on the i9300, including network and sound

the system boots with a basic resolution no QE/CI

after that use this Zephyroth NVidia Universal Installer

from : Zephyroth Utilities


you must select customize in zephyrot installer, then check the appropriate NVinject (go , go 512, or destktop versions of NVInject, according to the amount of VGA RAM) ; in the case of my 6800Go 256MB, it's NVinjectGo


before rebooting you need to edit the NV40 plist : right after




"0x00C010de&0xfff0ffff " (one space at the end)


also, in NVDAresman plist, right after




"0x00C810de&0xfff8ffff " (one space at the end)


in both cases the original list follows and must stay untouched

Once the plist are saved, just use extensions-repair utility and reboot (no need for terminal etc)


You should then have full support for your 6800 including all resolutions, color assistant, QE /CI, rotation and mirroring enabled <_<

Also, Zephyroth NVidia is the only one that allows working dual screen with a DVI monitor (VGA connector is not enabled)

(natit works but no dual screen support, NVinject has no DVI and no QE CI etc)


I think this combination is suitable for any computer, with any 6800 VGA, if you don't have a 6800go,

you only have to insert the correct ID of your card (for example, the 6800Go Ultra is 0x00c910de not c8)

insert the correct code when using & mask ("& 0xfff0ffff) means the ID fourth digit will be forced to zero)


Please let me know if this method works for you....

Link to comment
Share on other sites

Thank you, Red Leader, I had to do a little tweaking, but that worked for me! Now I have QE!


My tweaks were:


1. I used my device's ID of 0x00f110de


2. I couldn't reboot after using Zephyroth NVidia Universal Installer until I copied NVinject.kext that I saved from my previous install into the Extensions folder. For some reason Zephyroth NVidia Universal Installer didn't install NVinject.kext. But after I manually installed it, everything works.


And thanks for the tip on the extensions-repair utility. I hadn't even known that existed.

Link to comment
Share on other sites


  • Create New...