Jump to content

Kalyway 10.5.2 and USB


Mixed
 Share

12 posts in this topic

Recommended Posts

Hi there,I've installed Kalyway 10.5.2 on my P4 box. It works great. The net card gave be a headache but I've solved it by using PCGenRTL8139Ethernet driver.So now my big problem is that I can't see USB devices. When I insert my stick... nothing happens. What can I do?

 

A quick solution I found is to remove the extensions cache.

rm -rf /System/Library/Extensions/Caches
But I don't like that... What else can I do?
Link to comment
Share on other sites

I had the same issue, asked in IRC. Seems Kaly used a dvd from a new mac to make this latest one. The issue is if you use a 9.2.0 kernel the system.kext is still from 9.2.2.

 

To solve the issue, get the real Mac 10.5.2 update.

Use Pacifist and Kext Helper to get the new system.kext file out of the .pkg and installed.

 

Then reboot and enjoy :(

Link to comment
Share on other sites

I had the same issue, asked in IRC. Seems Kaly used a dvd from a new mac to make this latest one. The issue is if you use a 9.2.0 kernel the system.kext is still from 9.2.2.

 

To solve the issue, get the real Mac 10.5.2 update.

Use Pacifist and Kext Helper to get the new system.kext file out of the .pkg and installed.

 

Then reboot and enjoy :lol:

 

Worked perfectly for me ! Thanks !

Link to comment
Share on other sites

To solve the issue, get the real Mac 10.5.2 update.

Use Pacifist and Kext Helper to get the new system.kext file out of the .pkg and installed.

 

Then reboot and enjoy ;)

Thanks man, I did this and now it works! :)

Link to comment
Share on other sites

guys usb not seen, not mounting issue is not caused by caches. it is caused by the system.kext and kernel versions do not match...

 

what does it mean? if you installed kaly 10.5.2 with default settings, it will install 9.2.0 kernel and 9.2.2 system.kext... which means their versions will not match... you have two options;

 

1 get system.kext from your previous 9.2.0 install, or kalyway's 10.5.2 update package's original files folder

2 change the kernel to 9.2.2

 

That is the reason for USB NOT MOUNTING issue...

 

Cheers...

Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...