Jump to content

Sata Problem

7 posts in this topic

Recommended Posts

Try this. When the installing srceen comes up, you should have a menu bar at the very top of the screen. Select disk utility (?) Make one (or how many you want) partions in the mac format. Close the disk utility and now you should see a HD on the install screen.

Link to comment
Share on other sites

What's your PC specification?

Probably you got a motherboard with nForce chipset. Those ones are terrible because the installation will never find your SATA disk.

You have 2 solutions:


1- Get an IDE Hard-disk

2- Try a pre-patched installation DVD that comes with nforce support. Try looking at: http://forum.insanelymac.com/index.php?showtopic=87901

Link to comment
Share on other sites

This is interesting to me. I am trying an install of 10.5.2 kalyway and cant see any of my my hdd's. Motherboard is a ECS661gx, intel p4-sse3 3gig, 1 gig ram, nvidia128m video card.


1) i have 2 sata 200gig drives on the sata mb connector 1 and 2 that previously was a mb raid in windows xp. I have set one as fat32 and the other as just an unallocated partition. (however when the leopard is booting, the bsd dmesg type of display looks like it has a sata Via driver installed. Then it says BSD Root:disk1s2 major 14 minor 2


2) i had a spare 80gig hdd from work that is out of an video hdd recorder. Looks like a normal hdd hitachi deskstar. However I cant even see this in windows xp or the leopard disk utility. I have tied the jumpers to master and slave options, tried mbrhh program that seems to point that it has an ata password that i cant get rid of.


Leopard cant see either in the disk utility! It only sees the dvd drive in there.

I know nothing about how to use different kernels on boot time either.

I have tried all utilities on the Hiren disk 9.5 and there are a lot of disk partition programs, mbr programs, and format programs, to no avail!


Can anyone offer any cure or reasonable suggestion to help please?


(allready its a frustrating project!


1)I accidently deleted the mbr/partition info to the raided pair of sata drives, however with the Hiren disk "getmyfilesback" i recovered 99% back to a usb plugin drive unit ok.

2)Lost the boot ability to my remaining ide ata hdd 80gig windows xp bootable, and now i have to leave the Hiren disk in the dvd drive, it then gives me a boot from hdd or cd option, and so this way i can still boot windows again. Not sure if this just needs a fdisk /mbr command t fix it? Thats my best guess att the moment.


yes very frustrating)


Also the Kalyway dvd would not boot with the usb enabled on the motherboard. If i disable the usb on the motherboard bios it boots and i can get to the install screen diskutility. Where there are no drives at all to install to!


Its just been a great weekend!


I have searched all over and while there are many problems maybe its just the hardware thats my downfall and perhaps i should not go any further. Has anyone got a 661gx motherboard type pc operating on leopard.


Never having being in contact with any apple OS i am so peeved with xp that i wish to try Leopard with the view i will buy hardware and os later on, if its as good as those apple users say it is. However many people who use XP says its all a con!


However i was so impressed with seeing a brief glimpse of the the speed of a mac laptop with leopard on it i would like to test some more. It was a tech who came and sis some stuff to our windows servers. It seemed like the os was far faster and smoother at what it did.



Minsik thanks all who take pity on this very old and frustrated soul.

Link to comment
Share on other sites

Well at least some progress.

must make sure usb is disabled in the mb bios or it wont boot.


ata disk 9 gig found in old computer so tried that. Yes as it was fat32 it appeared in the hdd section of disk utility. so it loaded ok in about 40 minutes.


Of course i have no idea about leopard so its all new to me. However i have no network at all, no sata drives. Interestigly the dvd and ata drive do appear in the sata section of the system information utility.

had to slow the mouse down it was way too fast as well.


so no external usb drive as cant leave on usb. must be a patch somewhere for that, also no idea how to add hardware ethernet for the network or make the usb work. apart from that it works. Seems to be very speedy and the spaces with different screens is nice.


Oh well its all interesting but nowhere as easy as i thought it would be.

Link to comment
Share on other sites


  • Create New...