Jump to content

1 Screenshot

About This File

Files Package For Xiaomi Mi Notebook Air 13” 2.1

Bios vers A05 — CPU i5 6200U (confirmed working even on A06 bios)

 

2.1 PACK FOR HIGH SIERRA ONLY, FOR SIERRA USE 2.0

 

Discussion's thread.

 

Not working:

Wi-fi / Bluetooth. (Bluetooth works if using a VM to inject the FW)

Nvidia Optimus 940MX GPU. (Optimus does not work on macOS at all)

 

Issues:

Excessive battery draining while on sleep.

 

For 2.0 Steps check the discussion thread

Steps:

 

 

Create the installation flash drive with create install media or with your preferred tool.

Install Clover and copy all the files from the package to the EFI partition of your flash drive.

Install using a fakeid as shown in the picture below.

To boot with fake id select the Gear icon - Graphics Injector - FakeID and insert: 0x123456789

 

equqn6.jpg

After the installation install clover and copy all the files to the EFI of the local disk and all other files from the pack.

Reboot

Have Fun!

 

 

 

When updating to new versions of the filepack:

Remove all old files and install the new ones following the ReadMIs.

Just remember to use the same serials you used before.

 

Don't use bios mods, other files with different patches or you'll get no help.

Special thanks to:

Jolly, gengik84, and RehabMan.

 

By Jahstories on InsanelyMac a.k.a. EliJah on macos86.com

 

HELP NEEDED?

Please don't post a comment, use

this thread !

Thanks!


What's New in Version 2.1   See changelog

Released

  • Various changes for 10.13 support.

User Feedback

Recommended Comments



That's what I just found out :) . Please write that on the front page.

 

Is there any other way to fix the cache issue? For me personally it's a non issue,  but it's not as straight forward anymore.

Link to comment
Share on other sites

Just wanted to thank you again for all your help. Now I've got a working dual boot solution on one SSD :) It's great.

If only the intel wifi project hadn't died... :/

 

 

EDIT: Just found another issue :( The headphone jack emits terrible audio. It's echoing and sound like a cheap lowpass filter lol..

 

EDIT2: Regarding the lid sleep issue, have you taken a look at this? GitHub

Link to comment
Share on other sites

I was tired I suppose. I didn't check if the Kext tool had moved done its job right..

 

Could you please take a look at the lid issue? It should be quite easy to fix within the DSDT (by searching for LID or LID0). Could you also please upload the uncompiled DSDT with all applied patches (if possible, separately) ?

 

Also, your guide is missing this command:

sudo chown root:wheel /usr/bin/hwpenabler

And brew can't be installed on Sierra with that command only. You've got to alter the permissions for /usr/bin first. (For the guide as well I mean)

Link to comment
Share on other sites

New problem... Sleep Mode seemed to be working but after a few times it suddenly didn't want to wake up anymore. So I rebooted it - the thing is that it's always shutting down at boot now. It's also impossible to take a picture of the verbose because it goes to fast. I've tried to use clover's cancel hiberation and debug 100 for making the log stay, but since it isn't a panic it doesn't stay on.

Link to comment
Share on other sites

Proper sleep is not an easy thing on sierra hackintosh, I don't know if this is your first hack, but some issues are normal!

I had problems of sleep getting the notebook stuck, but a reset always worked, don't know whats causing that instant reboot, sorry.

Link to comment
Share on other sites

Found the issue :( 

Sleep mode corrupted the macOS partition.. "Invalid record count. The volume could not be verified completely."

It worked for at least 20 tries, but the last time made it stay in an unresponsive state. And now it's toast. The windows partition and so on is unharmed though, so it shouldn't have anything to do with the NVMe hack.

Link to comment
Share on other sites

That's surely caused by the nvme! Thats why I don't add support to it on the file pack!

Get a sata m2 drive and use the expansion slot.

Btw I'm uploading a new version.

Link to comment
Share on other sites

EDiT: Maybe you're right (almost definitely so) but there aren't many people complaining with rehab man's new method of patching. Maybe I misread, but in theory you should get any corrupted drives if you use that patch since it uses a patched kext and not an injection (which could load badly and therefore screw the entire drive). I may be wrong though.

 

 —--

 

Before it died I also managed to get HDPI scaling for 125% res. It's easies on the eyes while traveling. If you'd like to include it in your filepack, all you gotta do is to a plist using this (link) awesome website and voila' :)

 

It works for notebooks too of course.

Link to comment
Share on other sites

I always used 1280x720 using RDM

 

 

But it isn't highDPI right? It's a bit blurry I suppose, that's why making this plist in conjunction with RDM is amazing. So everything keeps being crisp and sharp :) 

Link to comment
Share on other sites

The lid issue can't really be fixed then right? The problem is that, at least on my install, it's not ok to just press sleep and close it: that will make it unresponsive, you'd have to press sleep and wait like 40 seconds or more before it turns off the fans and the light starts blinking. It is just on my system like this or is it the intended behaviour?

Link to comment
Share on other sites

The last config.plist of yours doesn't load the DSDT, is this deliberately done?

 

If it isn't defined in the loading order it will get ignored or am I wrong?

Link to comment
Share on other sites

I've done a reinstall now and tested the sleep mode extensively (more than 30 tries) 

It works 9/10 times if you keep the lid open until the light blinks (after like 30-50 seconds), but I've found that if you close the lid within that period, it will almost always either cause it to freeze, wake-up again (without USB as mentioned) or to reboot. Even when letting it go to sleep with the lid open, it can, although rarely, still cause it to reboot instantly :/

This is my first hackbook, I've two other hackintoshes though, and I've fortunately never had these issues before. I'm really grateful for your amazing work though! Thanks

 

---

 

I'm also quite certain that booting on the NVMe isn't a bad idea. I haven't got a corrupted drive since my re-installation; which doesn't mean that it's safe of course. I've bought another SSD now as well. But I'll keep it on this one for now to see if it works. It's not a big problem if it dies since I'm mainly using it for taking notes at university and coding (which get's instantly saved in the cloud).

Link to comment
Share on other sites

Today, in the library, I discovered another problem :(

I can't use an external bluetooth dongle since the internal bluetooth is still active. Is there any way to trick the HCIcontroller to disable the internal bluetooth? 

 

Thanks again :)

Link to comment
Share on other sites

Don't know, if you really want you could modify the xiaominjectXHC to disable bluetooth's USB.

Please use the thread linked on the main page don't post comments here, thanks.

Link to comment
Share on other sites

×
×
  • Create New...