Jump to content

10.10.5 Mach_Kernel Patched (After mach_kernel for Security Update 2016-001) For Intel Z87 Haswell Motherboards w/ Reboot Loop


About This File

This is a patched version of an official vanilla kernel from Yosemite 10.10.5 after Security Update 2016-001, allowing Z87 Haswell motherboards with reboot loops or kernel panics capable of booting.

The following perl scripts have been applied to the vanilla kernel for 10.9.5 after Security Update 2016-001:

 

#1

perl -pi -e 's|\xe2\x00\x00\x00\x02\x00\x00\x00|\x00\x00\x00\x00\x02\x00\x00\x00|g' kernel

#2

perl -pi -e 's|\xe2\x00\x00\x00\x4c\x00\x00\x00|\x00\x00\x00\x00\x4c\x00\x00\x00|g' kernel

#3

perl -pi -e 's|\xe2\x00\x00\x00\x90\x01\x00\x00|\x00\x00\x00\x00\x90\x01\x00\x00|g' kernel

 

Patches #1 & #2 have been documented on this blog by the original owner here. Shout outs to Pike R. Alpha whose code the patches are based on, he lives here.

 

Tested on EVGA Z87 FTW

 

Please let me know if it works well for you so I can confirm the amount of success users are having. Thanks


User Feedback

Recommended Comments

Installed Niresh's Yosemite Distro on a C2Q Q9550s. But the mach_kernel was missing. I could only boot using the USB key. Also after installing the Combo Update (10.10.5) it was not there. Copying /System/Library/Kernels/kernel to the system root (and renaming as "mach_kernel") did also not lead to an improvement though being suggested all over the web. Now I found your kernel file (took the unpatched one) and tried ... but the system reboots everytime instead of getting up. Now I tried your file and renamed it accordingly to mach_kernel. But it is still rebooting. What am I doing wrong? Do I need to replace /System/Library/Kernels/kernel as well?

 

Cheers,

Daniel.

Link to comment
Share on other sites
×
×
  • Create New...