Jump to content

About This File

ElNono's dump tool to determine variables used to activate iMessage. Run on real mac or validated hackintosh to get working Serial Number, HardwareID, MLB & ROM values for Clover config.plist.


Background Info

  1. MLB & ROM explained
  2. Mac cloning if you own a Mac - procedure in the AIO guides

Note: Runs on OSX Mountain Lion or later.


Update 8 Sep 2014: V2 Addition of system-id to dump and improved formatting of text.

Credits to @pokenguyen and @sugarface.

What's New in Version 09/11/2014 05:27 AM   See changelog


No changelog available for this version.


User Feedback

Recommended Comments

imessage_debug v1 was Great

but iMessageDebug (v2) is even better :)

(clearer) :thumbsup_anim:

thanks to : ElNono, mdmwii,flux84, sugarface, pokenguyen


my little advice to reach perfection : adding the 2 keys used in clover configurator (custom UUID and SmUUID)

so its ok for clover and for Chameleon

Great job guys!!!




this post             #99             is great too :thumbsup_anim: thanks to fusion71au

this post should be used in clover wiki ;)

  • Like 1
Link to comment
Share on other sites

Fabio it's meant to be used on a Real mac to obtain it's ROM/MLB/Serial values...

How did it fail for you??

iMessageDebug tried OS X Maverick System-ID: found

No OS X Yosemite




Link to comment
Share on other sites

Hi! I'm having a problem trying to execute this file on two real macbooks. I've tried the file on my hackintosh and it works fine, but if I try to use it on either one of the two macbooks, it just opens up the Terminal app and shows nothing. Then, if I drag and drop the file over the Terminal window and press intro, I receive a message saying permission denied, process completed, or someting like that. If I wirte "sudo " and drag and drop the file it asks for my password, but after I put the password I receive the same error. I don't know what am I doing wrong, because it's supposed to work by only double clicking on it, like on my hackintosh. Does any of you know what is happening? The two macbooks are running Mavericks.


EDIT: Solved. I just needed to type in Terminal chmod 755 and drag and drop the file, press intro, then double click on it.

Link to comment
Share on other sites

  • Create New...