Jump to content

10.5 Originale installato....


  • Please log in to reply
53 replies to this topic

#21
Xanny

Xanny

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Ciao ragazzi, scusate se non vi rispondo nell'immediato ma mi accupo di sicurezza e nel mio lavoro si fanno turni che mi lasciano libero a volte negli orari piu' strani...........

Xanny sto cercando di capire dove possa essere l'errore poiche' sul mio sistema tutto va come dovrebbe....

Una cosa solo hai sul desktop tutti i files ?


Tranquillo ci mancherebbe il lavoro prima di tutto...

si ho tutti i file sul desk e ho provato anche lo script originale di Satan stesso errore... ora provo con un altro computer e vedo che succede.
ciao
Xanny

p.s. leggero O.T. qualcuno sa perche' su una installazione di toh su un altra partizione mi va lentissimo il leo... dipendesse dal chipset ich8r serve qualche kext?

#22
shortfilm

shortfilm

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
ciao Alessandro grazie per questa bella notizia. io non sono un esperto come te ti chiedo dove potrei trovare una immagine del tuo leopard osx86????
grazie



Vorrei aggiungere che ho testato al volo le due suite software che vanno per la maggiore su mac :( :( (quelle per le quali ci vogliono i vari fix).
Scoperta interessante : nessun fix e tutto si installa e funziona come dovrebbe. :unsure: :o :o



#23
alessandro_D

alessandro_D

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Shorfilm mi dispiace ma non ho nessuna immagine da laciare in giro, ho solo realizzato degli script con il contributo di altri per mettere a punto qualcosa di utile per me e che ho voluto condividere con voi.

Non voglio essere moralista o fare la paternale, uso uno connessione che sfrutta l'umts perdpiu' con un segnale che e' indecente, anche se volessi sarebbe quindi impossibile......

A presto.....

#24
Xanny

Xanny

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Ale non so perche' ma non va proprio provato su varie macchine e vari leopard uno originalissimo, ma un dubbio size=7680come lo hai determinato? sto cercando di capire, ho gia' leopard installato su un'altra partizione, ma vorrei installarlo su GPT....

#25
alessandro_D

alessandro_D

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Allora Xanny ho provato e riprovato ma qui funziona come dovrebbe, per sicurezza ho formattato e reinstallato da capo.
Cercando in internet ho scoperto che anche altre persone sono incappate in quel problema sotto Linux, pare che possa anche essere una cattiva interpretazione di un carattere finale della riga dello script da parte della shell..... prova ad editare lo script e a salvarlo nuovamente,io di solito use TexMate su Mac.

Sto mettendo a punto gli script, nella prossima versione finalmente si dovrebbe anche rigenerare la mkext del sistema sul dvd cosi' che all'avvio dello stesso il processo di boot dovrebbe migliorare....(ora al boot il sistema deve rileggere l'intero contenuto della cartella Extensions)...


Grazie......

#26
tony23

tony23

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts
io ho provato e questa iso non mi va....mi da subito il panic non mi fa neanche andare in opzioni di f8...

#27
alessandro_D

alessandro_D

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
anthony qual'e' la configurazione che hai ?

#28
tony23

tony23

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts
una mobo ga-p35-ds4 un core 2 duo 6750 2 gb ram e geforce 7900 256mb

#29
stationapollo

stationapollo

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 616 posts
  • Gender:Male
non avevi una asus? anke tu hai abbandonato questo trend (ke skifo di trend) per gigabyte?

#30
alessandro_D

alessandro_D

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
anthony sei partito da una immagine originale non patchata ?Hai applicato le patch con esito positivo ?Hai inserito nella cartella files/Extensions sul desktop le kext per la tua mainboard ?Ti faccio queste domande poiche' se hai applicato le patch cosi' come sono queste generano una iso che molto probabilmente funziona solamente con chi ha la mainboard Intel col p35 o 975.......Lo scopo degli script e' prevalentemente di generare una immagine iso che contenga tutto il necessario per installare il sistema senza troppi sbattimenti ma questo nono vuol dire che se non si mettono o tolgono estensioni questo funzioni. Nel mio caso ho potuto sostituire solo due o tre estensioni perche' si avviasse correttamente....Una cosa non capisco : cosa vuol dire kernel panic ancor prima di caricare ??? Se l'iso e' fatta correttamente compare automaticamente l'opzione f8 per opzioni del bootloader altrimenti carica il kernel.............stationapollo hai avuto modo di provare gli script ?

#31
tony23

tony23

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts
si apollo o abbandonato asus.....cmq la iso lo fatta con successo senza errori provato a rifarla 2 volte ho fatto tutto da toh,ma cmq sara un problema mio anche perche ho difficolta a mettere efi....secondo me ho problemi di smbios dovrei provare a tenere quello della toh

#32
thefamous

thefamous

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

una mobo ga-p35-ds4 un core 2 duo 6750 2 gb ram e geforce 7900 256mb


ho la tua stessa identica (cambia solo la GeForce che ho la 7600 GT) e a me funziona tutto alla grande con la brazil liscia (senza psotpatch) + efi 8.0. Se ti da kernel panic dopo l'applicazione dell'efi perch devi togliere AppleEFIRuntime.kext, AppleCPUPowermanagement.kext e inserire dsmos (l'ultimo delle v.8.0) e SMBIOS.kext.

comunque sto provando a usare queste patch postate da alessandro, un po' modificate d ame per il resizing a 4,3 gb, tutto funziona a 7.6 giga mentre non va se resize a 4481M il problema nella verifica del size al momento del boot-patch.sh

per il nostro sistema usa ICH9R patch (non quella di satinpollo che non va per noi, prendi quella del sito inglese, unpost sulla DS6 non trovo il link ora).

se serve aiuto fai un fischio.

#33
alessandro_D

alessandro_D

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Il problema del resize a 4481 e' dato dal fatto che lo script usa il comando asr per ricreare l'immagine, questo comando non tiene conto dello spazio libero che e' presente dopo l'applicazione della prima patch, infatti se verifichi la dimensione del file leopard.iso.cdr ti dara' sempre 7 e rotti GB mentre se monti l'immagine e verifichi lo spazio dell'immagine osx86dvd vedrai che se hai eliminato il superflo prima questa ti dara' 4GB e piu'.

Sto pensado di sostituire il comando asr con lo schema della brazil che genera l'iso.........

#34
tony23

tony23

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts

ho la tua stessa identica (cambia solo la GeForce che ho la 7600 GT) e a me funziona tutto alla grande con la brazil liscia (senza psotpatch) + efi 8.0. Se ti da kernel panic dopo l'applicazione dell'efi perch devi togliere AppleEFIRuntime.kext, AppleCPUPowermanagement.kext e inserire dsmos (l'ultimo delle v.8.0) e SMBIOS.kext.

comunque sto provando a usare queste patch postate da alessandro, un po' modificate d ame per il resizing a 4,3 gb, tutto funziona a 7.6 giga mentre non va se resize a 4481M il problema nella verifica del size al momento del boot-patch.sh

per il nostro sistema usa ICH9R patch (non quella di satinpollo che non va per noi, prendi quella del sito inglese, unpost sulla DS6 non trovo il link ora).

se serve aiuto fai un fischio.





io sto usando la toh e mi da problemi,non riesco a mettere sta benedetta efi....se hai usato la brazil la post patch dopo l'installazione devi metterla se no poi non ti va...o pure cancellato efiruntime ma nulla....-il dsmos della efi 8 non la trovo o solo quella della 5.1

#35
thefamous

thefamous

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Antony: formatta tutto in GUID, e segui alla lettera questa guida:
http://forum.insanel...showtopic=73952
(metti tutti i file dell'EFI nella pennina USB), boota da qualsoiasi DVD leopard, formatta l'hd in GUID e poi metti l'EFI, poi segui questa guida :
http://forum.insanel...showtopic=72493 installa tutto e poi installa le kext che hai nella pennina usb (metti le kext per la tua scheda, se ti servono te le invio via mail)

quindi hai un Leopardo puro puro (perch NON va applicata nessuna postpatch specialmente kernel ecc...)

altrimenti attendiamo Alessandro_D che prepara lo script per il resizing (visto che lui sa dove mettere mano... a me venuto in mente di fare la prima parte del resize-patch.sh con lo stesso script della brazil, tolto ovviamente il replicing kernel, bless, miniball e install.pkg... poi continuare con gli altri script del boot e del file patch, potrebbe funzionare?)

#36
tony23

tony23

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts
ma tu che kernel hai usato?

#37
nikfol

nikfol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Interests:osx leopard 10.5.5 efi boot_v8 <br />acer 5633<br />core 2 duo work<br /...
ciao a tutti allora alessandro o sfruttato la tua guida solo che i problemi non sono pochi o preparato il dvd doppio strato si avvia nel mio notebok ma solo se digito f8 seguito da -f e cosi carica i kext da una serie di errori pero va avanti partiziono il disco in 2 parti con la guid lo script e prosegue con l'istallazione poi mi da quel famoso errore do il comando da terminale per cambiare i kext ed e ok quindi riavvio e tastiera e mous del notebok continuano a non funzionare vabe per il momento sto usando gli esterni comincia la configurazione dell'account e nell'arrivare su cosa vuoi fare trasferire da un altro mac ecc.. ecc. si blocca e riparte la videata di benvenuto. ora ho installato sull'altra partizione tigre cosi o creato li l'acount riavviato leo e trasferico da li infatti ora sto scrivendo da leo ora chiedo aiuto se e possibile a risolvere sto problema di tastiera e mouse con la thoc andavano sia senza efi che con efi e kernel originale mi chiedo come mai con la tua procedura ma creato sto problema forse qualche kext da togliere ? o cambiato gia un sacco di appleps2controller ma il risultato e sempre negativo

#38
nikfol

nikfol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 123 posts
  • Interests:osx leopard 10.5.5 efi boot_v8 <br />acer 5633<br />core 2 duo work<br /...
ciao a tutti allora alessandro o sfruttato la tua guida solo che i problemi non sono pochi o preparato il dvd doppio strato si avvia nel mio notebok ma solo se digito f8 seguito da -f e cosi carica i kext da una serie di errori pero va avanti partiziono il disco in 2 parti con la guid lo script e prosegue con l'istallazione poi mi da quel famoso errore do il comando da terminale per cambiare i kext ed e ok quindi riavvio e tastiera e mous del notebok continuano a non funzionare vabe per il momento sto usando gli esterni comincia la configurazione dell'account e nell'arrivare su cosa vuoi fare trasferire da un altro mac ecc.. ecc. si blocca e riparte la videata di benvenuto. ora ho installato sull'altra partizione tigre cosi o creato li l'acount riavviato leo e trasferico da li infatti ora sto scrivendo da leo ora chiedo aiuto se e possibile a risolvere sto problema di tastiera e mouse con la thoc andavano sia senza efi che con efi e kernel originale mi chiedo come mai con la tua procedura ma creato sto problema forse qualche kext da togliere ? o cambiato gia un sacco di appleps2controller ma il risultato e sempre negativo

#39
alessandro_D

alessandro_D

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts
Ragazzi ho modificato lo script files-patch.sh ora rigenera correttamente anche il file Extensions.mkext con tutte le kext che si trovano in /System/Library/Extensions del sistema su dvd.Grazie a questo la velocita' di boot e' migliorata poiche' non deve rileggere le kext in avvio, diciamo che sul mio sistema ho guadagnato quasi 2 minuti.....Come sull'originale.......Sto ancora cercando il modo di poter fare il resize a 4GB ma per ora nada....... Ho provato ad utilizzare parte dello script della Brazil ma sinceramente fa confusione, ha un approccio diverso da quanto pensavo.......Valuto anche un'altra possibilita' cioe' quella di effettuare il resize dopo tutto il processo di patching visto che il file osx86final.sparseimage quando montato contiene all'interno due partizioni, una di boot e l'altra osx86dvd : partendo dal presupposto che se elimino quello che voglio nella prima parte del patching avro' alla fine sempre un file da circa 7,5GB ma questo perche' la partizione osx86dvd anche se contenente i 4GB e rotti di dati risulta grande 7 con 2GB di spazio vuoto, ed e' qui che l'asr non puo' far altro che generare l'immagine da 7,5GB.Ora se non ricordo male hdiutil consente di fare il resize sia dell'immagine che del singolo volume o partizione....... Vi faro' sapere........ Nikfol inanzi tutto bisogna che nella cartella files/Extensions che hai sul desktop devi inserire quelle kext che servono al tuo sistema per funzionare correttamente, poiche' cosi' come sono gli script tolgono e aggiungono veramente poco all'installazione originale (vedi problema mouse tastiera).Io sono stato fortunato poiche' il mio hardware e' compatibile quasi al 100% con quanto fatto da Apple........

#40
tony23

tony23

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 301 posts

Antony: formatta tutto in GUID, e segui alla lettera questa guida:
http://forum.insanel...showtopic=73952
(metti tutti i file dell'EFI nella pennina USB), boota da qualsoiasi DVD leopard, formatta l'hd in GUID e poi metti l'EFI, poi segui questa guida :
http://forum.insanel...showtopic=72493 installa tutto e poi installa le kext che hai nella pennina usb (metti le kext per la tua scheda, se ti servono te le invio via mail)

quindi hai un Leopardo puro puro (perch NON va applicata nessuna postpatch specialmente kernel ecc...)

altrimenti attendiamo Alessandro_D che prepara lo script per il resizing (visto che lui sa dove mettere mano... a me venuto in mente di fare la prima parte del resize-patch.sh con lo stesso script della brazil, tolto ovviamente il replicing kernel, bless, miniball e install.pkg... poi continuare con gli altri script del boot e del file patch, potrebbe funzionare?)










no provato a mettere leo con brazil,ma non va ancora ho provato in qualsisi modo non c'e nulla da fare....sta efi del cavolo non ne vuole sapere di andare





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy