Jump to content

ATi Mobility Radeon x1700


  • Please log in to reply
808 replies to this topic

#141
torpie13

torpie13

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Great !!!

@righteye : your drivers working flawlessly on 10.5.2, no crash or instability till now. Thanx alot.

@python1564 : Try to change the EDID, I got the same behaviour like you with the righteye drivers (I got a 1680x1050 resolution), then I changed the EDID with mine and all went perfectly OK.

Makes my day :censored2:

#142
python1564

python1564

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:chicago

OK, managed to get the resolution to 1680x1050 !! This is a real relief for me, because now it least it looks good.

Because I believe there are many people still trying to get their x1700 up and running at a decent resolution, here's a step by step guide of what I did:

(-3. Install Tiger 10.4.5 to a clean HFS+ Partition)
(-2. Don't boot into Tiger after install, but boot from ToH's Leopard DVD and install Leopard over Tiger)

Now for the driver stuff:
I attached all the files I used.
-1. Use Phoenix under Windows to extract your monitor's EDID. Save it as a .dat file, open it with Notepad, remove the stuff around the data and group the data into bits of 8 characters. For me, this was:

00FFFFFF FFFFFF00 244D8728 00000000 000F0103 80211578 0ABCA598 58558B28 24505400 00000101 01010101 01010101 01010101 0101A82F 90E0601A 10402040 13004BCF 10000019 B72790E0 601A1040 20401300 4BCF1000 00190000 000F00B3 0A32B30A 28140100 320C0000 000000FE 004C5031 35345730 322D544C 3036007F<BR>
Save it to a place you can load it in OSX and name it EDID.txt or something like that.

0. Download the files and install Property List Editor and Kexthelper.
1. In Leopard, I used Finder to extract the zip of the files, then go to downloads (stack from the dock) and open the x1700 folder.
2. Right-click the ATIinject.kext file > show package contents
3. Click Contents, then Right-click Info.plist > open with > Propery List Editor (default).
4. Click the arrows for "Root", "IOKitPersonalities", "ATIinject", "entriesToAdd".
5. Scroll down to the propery CRT2,EDID, click it, and click Delete to remove it.
6. in the property "device-id", change the Value to your device ID, for me I filled in <71d51002>
7. in the LVDS,EDID property, paste your EDID info which you retreived in step (-1). for me the new value was thus:
<00FFFFFF FFFFFF00 244D8728 00000000 000F0103 80211578 0ABCA598 58558B28 24505400 00000101 01010101 01010101 01010101 0101A82F 90E0601A 10402040 13004BCF 10000019 B72790E0 601A1040 20401300 4BCF1000 00190000 000F00B3 0A32B30A 28140100 320C0000 000000FE 004C5031 35345730 322D544C 3036007F>
8. DO NOT EDIT ANYTHING ELSE IN THE INFO.PLIST, NO IOPCIMATCH OR WHATEVER!
9. Save the Info.plist and exit Property List Editor.
10. Now, start Kexthelper, drag the two files ATIinject.kext (in which you just edited Info.plist) and ATINDRV.kext into it.
*For me, EASY INSTALL didn't work so I did the following:*
- Click Advanced and Make Script.
- Start Terminal from Finder>Applications>Utilities
- type sudo -s
- hit enter
- type your password
- hit enter
- now paste the Kexthelper's script line by line into the Terminal en hit enter between the lines (pretty obvious)
11. close terminal and kexthelper.
12. reboot and press F8 to interrupt the boot, then type:
"Graphics Mode"="1680x1050x32"
(including the quotes and the capitals)

13. Now you boot into a great 1680x1050x32 Leopard Desktop (wow everything's tall!!), awesome!

(14. Now start Terminal from Leopard and type
sudo nano /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
and add the following lines in the right place (directly below a <string></string> thing):
<key>Graphics Mode</key>
<string>1280x1024x32@85</string>
This boots into 1680x1050x32 every time you boot, so you don't have to enter the lines from step 12 each time)

Hope this was helpful.

My system specs are in the signature.
QE/CI is not working on my machine, so I still have to figure that out, but having never worked with Unix or OSX before I started installing all this stuff, it could take a while ;-)).


Ok I got my Mobility Radeon X1700 working flawlessly on my F3JP! 1680x1050 resolution, Qe/Ci enabled with no mouse tearing or artifacts!
Thanks to everyone who helped!
I followed the instructions above and everything is fine. I skipped step 14 because my EDID already provided me with the resolution

I am including the files i used: ATIinject.kext, ATIRadeonX1000.kext (to enable QE/CI), and ATINDRV.kext
Also included are teh tools that finetuned provided: phoenix editor, kexthelper, and property list editor.

Attached File  X1700.zip   774.78KB   174 downloads
Attached File  Phoenix.zip   201.59KB   105 downloads
Attached File  Property_List_Editor.zip   81.25KB   112 downloads
Attached File  Kext_Helper_b6.zip   1.17MB   90 downloads

#143
Zaiden

Zaiden

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Hey! I'ts been a while since I've successfully configured my FireGL v5250 ( = x1700) on my Thinkpad T60p. 1680x1050 res, QI/CE enabled, but now i'm trying to get the VGA out to work... I think it might be something related to the EDID in the plist ATIInject file, but I have no idea how it works...

Did anybody get this to work?
Any other idea?

Zaiden

#144
torpie13

torpie13

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
I made a mistake, I updated the "Apple Graphic Update" from the update manager on Leopard 10.5.2.
Now I got black menus.

Any one knows hos to resole and recover from this problem please.


Thanx

#145
cwsohn98

cwsohn98

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I updated the "Apple Graphic Update" from the update manager on Leopard 10.5.2 too.
I've modified those updated files(Ver. 1.5.24.9(5280)) and made my Mobility X1700 work perfectly.


Here's what I did after Apple Graphics Update.

1. To Enable QE/CI modify ATIRadeonX1000.kext
- in the Info.plist dont' add 71D5 but just replace 71DE with 71D5
- Hex edit MacOS/ATIRadeonX1000
Replace DE 71 with D5 71(there are 2 occurrence)
Replace 71 DE with 71 D5(there are 3 occurrence)
Replace 74 42 0F 87 A5 00 with EB 42 0F 87 A5 00(there is only one occurrence)

2. Rest of the extensions(ATINDRV.kext, ATIRadeonX1000GLDriver.bundle, ATIRadeonX1000GADriver.bundle, ATIRadeonVADriver.bundle) are ready made, so U don't need to modify them.

3. To get 1680x1050 resolution and dynamic resolution change capability, U can just use old ATIinject with your own proper EDID.

Now I have 1680x1050x32 resolution with QE/CI enabled. And don't see mouse tearing nor black menu any more.

Hope my experience may help you.

Good luck guys!

#146
torpie13

torpie13

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Great thanx for the Tip.
I've reinstalled Leo (Clean Install) and updated to 10.5.2, installed all my drivers. (Wifi and ATIx1700 ones) then I did not update to "Apple Graphic Update". all thing runs fine now.
I 'll use your tip if I've got to face an accidental install of "Apple graphics".

BTW: What the point of installing them ? Is Apple Graphic Update bringings new features or performance gain ?

Thanx

#147
fingerr

fingerr

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts
  • Gender:Male
  • Location:Poland

I updated the "Apple Graphic Update" from the update manager on Leopard 10.5.2 too.
I've modified those updated files(Ver. 1.5.24.9(5280)) and made my Mobility X1700 work perfectly.
Here's what I did after Apple Graphics Update.

1. To Enable QE/CI modify ATIRadeonX1000.kext
- in the Info.plist dont' add 71D5 but just replace 71DE with 71D5
- Hex edit MacOS/ATIRadeonX1000
Replace DE 71 with D5 71(there are 2 occurrence)
Replace 71 DE with 71 D5(there are 3 occurrence)
Replace 74 42 0F 87 A5 00 with EB 42 0F 87 A5 00(there is only one occurrence)

2. Rest of the extensions(ATINDRV.kext, ATIRadeonX1000GLDriver.bundle, ATIRadeonX1000GADriver.bundle, ATIRadeonVADriver.bundle) are ready made, so U don't need to modify them.

3. To get 1680x1050 resolution and dynamic resolution change capability, U can just use old ATIinject with your own proper EDID.

Now I have 1680x1050x32 resolution with QE/CI enabled. And don't see mouse tearing nor black menu any more.

Hope my experience may help you.

Good luck guys!

Hi cwsohn98,

I have x1600 and tried your way but after loginwindow is starting it immediately fades to black and nothing happens.
Did you faced the same issue?

p.s.
I had to use ATINDRV and IONDRVSupport from 10.4.5 ...

#148
eldefay

eldefay

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Hi,

first i would like to thank everyone worked on this x1700 problem. :D

could someone who has the necessary knowledge, be really kind and write us an installer or something similar? :rolleyes:
I guess the hardest thing about that would be the individual EDID for each Display. How have been that solved with the nVidia Cards?
any replies r wellcome.

thx again

#149
cwsohn98

cwsohn98

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Hi cwsohn98,

I have x1600 and tried your way but after loginwindow is starting it immediately fades to black and nothing happens.
Did you faced the same issue?

p.s.
I had to use ATINDRV and IONDRVSupport from 10.4.5 ...


Hi Mariusz,

To get the best result, I found that version of the driver is the most impotant one.

I use driver version 1.5.24.9(5280) in case of ATINDRV.kext, ATIRadeonX1000.kext, ATIRadeonX1000GA.plugin, ATIRadeonX1000GL.bundle, ATIRadeonX1000VADriver.bundle.
Version is not so important in case of ATIinject but EDID is the most important. I use ATIinject 1.0.0d1.

I got mouse tearing problem when I use some versions from tiger, and there's black menu problem with 5250 version.
But with 5280 it works perfect just in my case.

So I recommend you to get updated drivers and modify it.

All the best

#150
cwsohn98

cwsohn98

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Great thanx for the Tip.
I've reinstalled Leo (Clean Install) and updated to 10.5.2, installed all my drivers. (Wifi and ATIx1700 ones) then I did not update to "Apple Graphic Update". all thing runs fine now.
I 'll use your tip if I've got to face an accidental install of "Apple graphics".

BTW: What the point of installing them ? Is Apple Graphic Update bringings new features or performance gain ?

Thanx


Hi

I got black menu problem when I use previous version(5250). But every thing is just perfect with new driver(5280).
That's why I use updated one to fix that.

BTW I heard that some commerical software have same UI problem with ver. 5250 too.
So if you got some problem with UI, modifying upgraded drivers may help you.

Best regards

#151
cwsohn98

cwsohn98

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
How to get my own EDID.

Unzip attachment in M$-Windows.
- Pheonix.exe is EDID extract utility in windows and edid-1.jpg ~ edid-4.jpg is captured screen image
for your reference. You'll use it in step I.
- hexstr2bin and base64 is Mac executable which'll be used in step II.

Step I: Get EDID
To get your own EDID, execute attached Pheonix.exe in M$-Windows.
Extract your EDID and export it as a Raw 128 byte format(Refer to attached screen images).
I assume that you've exported it as 'my_edid.raw'


Step II: Prepare data for Info.plist of ATIinject.kext
1. copy hexstr2bin, base64 and my_edid.raw to some your directory in Mac.

2. open a terminal. change to that directory then sudo -s
bash-3.2# cd some your directory
bash-3.2# sudo -s
bash-3.2# chmod a+x hexstr2bin base64

3. encode my_edid.raw and you'll have 172 bytes long encoded edid(my_edid.txt).
bash-3.2# ./base64 -e my_edid.raw my_edid.txt
./base64: 128 byte(s) read, 172 byte(s) written

4. ATIinject needs device Id and vendor id. So let's prepare it as follows.
In my case, Vendor Id. is 1002(means ATI/AMD) and Device Id. is 71d5(means Mobility Radeon X1700 with ASIC M66-P)
a. Type in just as follows in the terminal to get Vendor plus Device Id.
bash-3.2# echo 71 d5 10 02 | ./hexstr2bin - - | ./base64 -e - dev_ven.txt
./hexstr2bin: 4 byte(s) read, 4 byte(s) written
./base64: 4 byte(s) read, 8 byte(s) written

You'll have 8 bytes long encoded dev_ven.txt

b. Next to get another Device Id.
bash-3.2# echo d5 71 00 00 | ./hexstr2bin - - | ./base64 -e - dev_id.txt
./hexstr2bin: 4 byte(s) read, 4 byte(s) written
./base64: 4 byte(s) read, 8 byte(s) written

You'll have 8 bytes long encoded dev_id.txt

c. Make sure that you've got all three .txt files
bash-3.2# ls -l
total 120
-rw-r--r--@ 1 charliesohn staff 6148 Feb 29 22:57 .DS_Store
-rwxr-xr-x 1 charliesohn staff 17196 Feb 22 07:57 base64
-rw-r--r-- 1 root staff 8 Feb 29 23:30 dev_id.txt
-rw-r--r-- 1 root staff 8 Feb 29 23:26 dev_ven.txt
-rwxr-xr-x 1 charliesohn staff 12920 Feb 22 07:58 hexstr2bin
-rwxrwxrwx 1 charliesohn staff 128 Feb 29 13:50 my_edid.raw
-rw-r--r-- 1 root staff 172 Feb 29 23:24 my_edid.txt

Step III: Edit Info.plist of ATIinject.kext
1. Open dev_id.txt in editor and copy it(Command-C). It is 8 bytes long characters.
Open Info.plist, find DeviceID entry then replace data with yours

<key>ATY,DeviceID</key>
<data>
1XEAAA== <-- replace this with yours(Command-V)
</data>

2. Open dev_ven.txt in editor and copy it(Command-C). It is 8 bytes long characters too.
Find DeviceID entry then replace data with yours

<key>device-id</key>
<data>
cdUQAg== <-- replace this with yours(Command-V)
</data>

3. Open my_edid.txt in editor and copy it(Command-C). It is 172 bytes long characters too.
Find EDID entry then replace data with yours

<key>LVDS,EDID</key>
<data>
AP///////wBMo0YzAAAAAAAPAQOAIRV4Cof1lFdPjCcn <-- replace these 4 lines with yours
UFQAAAABAQEBAQEBAQEBAQEBAQEBky6QoGAaHkAwICYA
S88QAAAZAAAADwAAAAAAAAAAADzSAmQDAAAA/gBTQU1T
VU5HCiAgICAgAAAA/gBMVE4xNTRQMS1MMDMKAFQ=
</data>

You may enter your EDID just in a line long, two or even more. Just make it looks neat and good as you like.


That's all. Now you can save Info.plist, chmod, chown, remove caches and reboot.
I hope you get it!

TIP:
You may get blank screen if you happen to press 'Detect Display' button in Display config pane.
In case of rebooting does not solve the problem, reboot in safe mode(-x) and reboot nomal mode again.
That'll gonna get your screen back.

All the bests,

Attached Files



#152
fingerr

fingerr

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 260 posts
  • Gender:Male
  • Location:Poland

Hi Mariusz,

To get the best result, I found that version of the driver is the most impotant one.

I use driver version 1.5.24.9(5280) in case of ATINDRV.kext, ATIRadeonX1000.kext, ATIRadeonX1000GA.plugin, ATIRadeonX1000GL.bundle, ATIRadeonX1000VADriver.bundle.
Version is not so important in case of ATIinject but EDID is the most important. I use ATIinject 1.0.0d1.

I got mouse tearing problem when I use some versions from tiger, and there's black menu problem with 5250 version.
But with 5280 it works perfect just in my case.

So I recommend you to get updated drivers and modify it.

All the best

Hi cwsohn98,

so it seems that for x1700, latest ATINDRV and IONDRVSupport works, but not for bloody x1600.

I have lestest (1.5.24.9) ATIRadeonX1000.kext, ATIRadeonX1000GA.plugin, ATIRadeonX1000GL.bundle, ATIRadeonX1000VADriver.bundle kexts (I dont even need to hexedit ATIRadeonx1000.kext to have QE/CI and res change), but have to use older ATINDRV (1.4.20.28 (1.0f159)) otherwise screen fades to black after loginwindow is started.

Thanks for your help and regards,
Mariusz.

#153
The Vietnamese love Mac

The Vietnamese love Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Location:HANOI-VIETNAM
Hello there,

I have to say in advance that I'm 100% newbie to Mac :D , so sorry if I'm gonna have some silly questions.

My laptop is Asus V1jp with ATI RADEON x1700. I installed a flat MAC (iaktos 10.5.1) and couldn't get the right resolution (which is 1680x1050 as in Vista).

I tried The Huan's method but it didn't work for me (not sure if I was wrong somewhere). I later updated to Mac 10.5.2 and followed cwsohn98's (post 146) but it didn't work for me, either (display went black blank after rebooting).

Can anyone please instruct me how to get my ATI x1700 to work at its1680x1050 resolution under Mac Leopard? Please tell me detailed steps (clearly how-to). Please find below my EDID.

Thanks a lot.

Attached Files



#154
kiou

kiou

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Ok I got my Mobility Radeon X1700 working flawlessly on my F3JP! 1680x1050 resolution, Qe/Ci enabled with no mouse tearing or artifacts!
Thanks to everyone who helped!
I followed the instructions above and everything is fine. I skipped step 14 because my EDID already provided me with the resolution

I am including the files i used: ATIinject.kext, ATIRadeonX1000.kext (to enable QE/CI), and ATINDRV.kext
Also included are teh tools that finetuned provided: phoenix editor, kexthelper, and property list editor.

Attached File  X1700.zip   774.78KB   174 downloads
Attached File  Phoenix.zip   201.59KB   105 downloads
Attached File  Property_List_Editor.zip   81.25KB   112 downloads
Attached File  Kext_Helper_b6.zip   1.17MB   90 downloads



Ive tried the method you have given around 6 times taking care to do everything you have said. I have the same laptop as you but it doesnt work. Ive loaded leopard though an iATKOS V1.0i dvd and it simply wont work! So what Im thinking is a. you may have just been lucky b. there is some mistake in the instructions c. the instructions arent clear enough?

I would greatly appreciate any help you can give me cause I hate this crappy resolution!!! im stuck in. Thank.

#155
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

Hello there,

I have to say in advance that I'm 100% newbie to Mac :D , so sorry if I'm gonna have some silly questions.

My laptop is Asus V1jp with ATI RADEON x1700. I installed a flat MAC (iaktos 10.5.1) and couldn't get the right resolution (which is 1680x1050 as in Vista).

I tried The Huan's method but it didn't work for me (not sure if I was wrong somewhere). I later updated to Mac 10.5.2 and followed cwsohn98's (post 146) but it didn't work for me, either (display went black blank after rebooting).

Can anyone please instruct me how to get my ATI x1700 to work at its1680x1050 resolution under Mac Leopard? Please tell me detailed steps (clearly how-to). Please find below my EDID.

Thanks a lot.


Hello there,

This ATiinject should work for you!

Also if you made the Leopard Graphics Update then you should use
Should work for all the family of ATi Mobility Radeon x1700 after the Leopard Graphics Update and forget about black menu or black screen, and no more Leopard Graphics Update in the list of updates.
Do not forget to chown / chmod and diskutil repairpermissions /

Good luck

#156
The Vietnamese love Mac

The Vietnamese love Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Location:HANOI-VIETNAM
Thank you, righteye.

I have re-installed Leopard with the Graphics Update, so now as I understand, will I have to chown / chmod only "ATINDRV.kext" and "ATIRadeonX1000.kext"?

And by the way, what is diskutil repairpermissions /?

I will be very grateful , should you can explain a little more clearly to me.

#157
righteye

righteye

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 346 posts
  • Gender:Male
  • Location:Romania

Thank you, righteye.

I have re-installed Leopard with the Graphics Update, so now as I understand, will I have to chown / chmod only "ATINDRV.kext" and "ATIRadeonX1000.kext"?

And by the way, what is diskutil repairpermissions /?

I will be very grateful , should you can explain a little more clearly to me.


Actually you have to do this in Terminal:

sudo -s
then enter your password
chmod -R 755 /System/Library/Extensions/ATIinject.kext
chown -R root:wheel /System/Library/Extensions/ATIinject.kext
chmod -R 755 /System/Library/Extensions/ATIRadeonX1000.kext
chown -R root:wheel /System/Library/Extensions/ATIRadeonX1000.kext
chmod -R 755 /System/Library/Extensions/ATINDRV.kext

chown -R root:wheel /System/Library/Extensions/ATINDRV.kext - makes the kext extensions to be recognized by the system as loadable
sudo rm -rf /System/Library/Extensions.mkext - removes the cache of extensions created previous
diskutil repairpermissions / - repairs the permissions on your hard disk so that you will not get some errors ...

That's it ... what i understand ... but might not be the right explanations.
For sure are working if are the correct kexts

Cheers

#158
The Vietnamese love Mac

The Vietnamese love Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Location:HANOI-VIETNAM
Hi righteye,

I'm trying it right now following what you instruct. Previously, I applied the ways suggested by some members in this thread but used your files. Consequently, the black screen re-appeared, and I had no other way but re-installed MAC (I didn't do any backup of kext files).

I already have Vista on my system but I don't have big problems with dual-booting the two system (just a little fix for boot parttion...), so possibly, I don't have to use diskutil repairpermissions /

Currently, I have 2 problem with MAC: screen resolution and Internet connection. Well, let sort the resolution out first.

I'll inform you of the result over my system.

Thank you very much.

#159
The Vietnamese love Mac

The Vietnamese love Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Location:HANOI-VIETNAM

Actually you have to do this in Terminal:

sudo -s
then enter your password
chmod -R 755 /System/Library/Extensions/ATIinject.kext
chown -R root:wheel /System/Library/Extensions/ATIinject.kext
chmod -R 755 /System/Library/Extensions/ATIRadeonX1000.kext
chown -R root:wheel /System/Library/Extensions/ATIRadeonX1000.kext
chmod -R 755 /System/Library/Extensions/ATINDRV.kext

chown -R root:wheel /System/Library/Extensions/ATINDRV.kext - makes the kext extensions to be recognized by the system as loadable
sudo rm -rf /System/Library/Extensions.mkext - removes the cache of extensions created previous
diskutil repairpermissions / - repairs the permissions on your hard disk so that you will not get some errors ...

That's it ... what i understand ... but might not be the right explanations.
For sure are working if are the correct kexts

Cheers


Well, righteye.Yourmethoddoesn'tworkformeagain :thumbsdown_anim: .Butjustletyouknow,myMacnowworksfinewiththeresolution
of1680x1050 :( .

Iusedall yourfiles(justhad alittlemodificationtoATIinject.kext, changed "device ID" to 71D51002)andfollowedfinetuned's theinstructionsfromthispost(http://forum.insanel...ndpost&p=498674).

Anyway, thank you very much. I still have dozens of questions, so may bother you soon. :D

#160
P2iM-0

P2iM-0

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Boston MA
@all

So, is there any news on getting X1700's working without black menus and full QE/CI after 10.5.2 & the Graphics Update?

I've been trying to modify the kexts included in the Graphics Update and can't seem to get QE/CI regardless of what I do. One of the biggest differences between before/after the Graphics Update is ATINDRV.kext is completely overhauled in the Graphics Update, there is no information in ATINDRV.kext/Contents/Info.plist -- there is now a plugins directory with different types of plugins.

ATINDRV.kext/Contents/Plugins Contains:
ATY_Alopias.kext
ATY_Caretta.kext
ATY_Hypoprion.kext
ATY_lago.kext
ATY_Lamna.kext
ATY_Sphyrna.kext
ATY_Wormy.kext


I'm not sure if we need new mods for ATINDRV.kext because I'm really not sure what was modified in the old ATINDRV.kext that was working before the Graphics Update (I was using the version posted by Finetuned in the thread in his signature -- ATiv5250_kexts.zip).

So, does anyone even know where to start modifying to try to get this working?

I found it interesting that in Tyrone Shoe's post here -- he says he has everything working 100% including sleep and an external monitor on his Lenovo T60p! I've tried PMing him and posting in that thread and have yet to receive a response. Tried asking around in irc.osx86.hu with no avail...

--P2





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy