Jump to content

Cyrillic subtitles on VLC


  • Please log in to reply
11 replies to this topic

#1
Данчо

Данчо

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Location:Sofia, Bulgaria
I mostly use VLC to play my movies, but now I came across a movie in a weird language and I need subtitles. The .sub file is in cyrillic, so the standard font would not appear. A standard fix for BS Player in Windows was changing the font encoding to cyrillic, but I don't see such options in VLC for Mac. Any ideas how to get this working..? Maybe i need a cyrillic font...?

#2
R2k.

R2k.

    One minute to midnight

  • Members
  • PipPipPipPipPipPipPip
  • 917 posts
  • Gender:Male
  • Location:Serbia
  • Interests:Music production and sound design
bro,i`m using MPlayer OSX successfully with cyrillic encoding ...
because MPlayer have option to chose encoding,fonts (you can choose cyrillic) ...

good player,try it,it`s free ... :)



~R

#3
Данчо

Данчо

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Location:Sofia, Bulgaria
Thanks fot the tip, did what you said, but still no subtitles.... Prolly doing smth wrong...

#4
R2k.

R2k.

    One minute to midnight

  • Members
  • PipPipPipPipPipPipPip
  • 917 posts
  • Gender:Male
  • Location:Serbia
  • Interests:Music production and sound design
i think that you must add some bulgarian cyrillic font to your Font Book,and than choose that font from MPlayer ...
it`s complicated indeed ... :wacko:







~R

#5
Данчо

Данчо

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Location:Sofia, Bulgaria
got it, selected a different encoding: CP2150 instead of just cyrillic!
HOWEVER, fullscreen playback is slow and choppy on this player, i guess the 13" macbook can't handle it. Even worse on the 32" LCD... Have to watch in a window now :wacko:

#6
Wizi

Wizi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 67 posts
  • Gender:Male
  • Location:Sofia, Bulgaria
My MacBook handle full screen without any problems.

#7
R2k.

R2k.

    One minute to midnight

  • Members
  • PipPipPipPipPipPipPip
  • 917 posts
  • Gender:Male
  • Location:Serbia
  • Interests:Music production and sound design
i have 17" screen and everything works nice in fullscreen .... :D

i really don`t know ...


~R

#8
Данчо

Данчо

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Location:Sofia, Bulgaria
The slow playback appears when I select "use second monitor", because otherwise it won't appear on the external display in fullscreen. I think it should work if I use the external LCD as a primary monitor (close the lid and wake up with remote).

#9
drmr

drmr

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

got it, selected a different encoding: CP2150 instead of just cyrillic!
HOWEVER, fullscreen playback is slow and choppy on this player, i guess the 13" macbook can't handle it. Even worse on the 32" LCD... Have to watch in a window now ;)


VLC -> Preferences -> Input/Codecs -> Subtitles -> Subtitles text encoding -> CP1251. This is for bulgarian subtitles. You need to select the proper encoding. The problem is that there are different encodings used among the same language. I think there is no need to install additional fonts in order to display them (or at least I haven't done so).

#10
Dubesor

Dubesor

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
thanks for the VLC tip. this worked for me on another video :(

#11
esculap

esculap

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
  • Gender:Male
  • Location:Bucharest
actually, for the 0.8.6d version i'm using, the encodint options is under:

VLC -> Preferences -> Input/Codecs -> Other Codecs -> Subtitles -> Subtitles text encoding

hope this helps anyone

#12
desichka

desichka

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
This doesn't work for me...or may be I'm doing something wrong... Please advise!

I am trying to play cyrillic (Bulgarian) subtitles on VLC and I did everything you guys have discussed here and nothing seems to help. I have both the movie (.avi) and the subtitles (.idx) in the same folder. I changed the subtitles encoding to 1251 and yet, no subtitles seem to appear. I even tried this on a MPlayer and didn't work also...

Any suggestions?

Thank you in advance!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy