Jump to content

Nvidia : Tv and Lcd Inverted + Screen in Portrait (not landscape)


  • Please log in to reply
8 replies to this topic

#1
benoit311080

benoit311080

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Location:Belgium
Hi,
I ve just tried Natit. It works great on my Geforce 6600T.
The main problem i have is this one:
The main screen in osx is my TV (S-video)
The second screen in osx is my pc lcd screen (DVI).
I don't use the VGA output.

How to invert to make my pc lcd screen the main screen in osx?

Update :
- Problem for swapping main/second display resolved : read here after in the replies.

- Here is my situation :
I use the last version of Natit (version on its website)
In all cases, i don't have mirroring, just desktop extension.
=> Putting monitor on DVI + tv on S VIDEO : the resolutions being backward w/ inverted monitor on the DVI. TV is OK
=> Putting monitor on VGA + tv on S VIDEO : it's ok for monitor and TV. Just I have no mirroring

If you have a full compatibility with nvidia, give me your tips. thanks


#2
Guest: bikedude880_*

Guest: bikedude880_*
  • Guests
Go to System Preferences -> Displays. In there you should see the option called "Rearrange" or something to that effect. Drag the grey bar from the faux display in the preferences to the other display. Everything should just slide on over.

#3
benoit311080

benoit311080

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Location:Belgium
Yeah! Thanks.
Now, my lcd is the main.

I've got a new problem: on my lcd screen, OSX is in portrait (not in landscape) : i have a resolution of 1050X1680 and not 1680X1050.


#4
LedY

LedY

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
I have the exact same problem on my NVidia GeForce 6600 w/ my TV and LCD flat screen monitor...the resolutions being backward w/ inverted monitor screen and the main & secondary displays being swapped. The only difference between my setup and yours is I'm using VGA output from the video card.

#5
Guest: bikedude880_*

Guest: bikedude880_*
  • Guests
I had that problem also. Sadly I don't remember how I fixed it. Try a different version, delete Extensions.kextcache/mkext, and reboot.

#6
LedY

LedY

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts
benoit311080: you can try the version posted here. It works for me. The only problem with this version is Mirror displays doesn't work.

#7
benoit311080

benoit311080

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Location:Belgium
Yeah. It works now with the last version on nati too.

The only main problem : how to activate mirroring with nvidia cards....

#8
LedY

LedY

    InsanelyMac Protégé

  • Members
  • PipPip
  • 65 posts

Yeah. It works now with the last version on nati too.

The only main problem : how to activate mirroring with nvidia cards....


Can you point me to the version of Natit that you used? Did you modify the Info.plist to add your EDID also? If so, what did you use for your EDID from your TV?

#9
gotoh

gotoh

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 470 posts
  • Gender:Male
  • Location:France
I had the "portrait bug" once. Reboot fixed it... Just make sure you remove your kext cache files before you reboot...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy