Jump to content

como instalar Ozmosis Bootloader

Ozmosis firmware bootloader

  • Please log in to reply
22 replies to this topic

#1
capitanbelico

capitanbelico

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 168 posts
  • Gender:Male
  • Location:Santo Domingo
  • Interests:OSX, Mac

Hola , como están todos.

 

escribo para solicitar ayuda con Ozmosis, me he animado a utilizarlo y encuentro ciertos inconvenientes con su instalación.

mi placa es GA-Z87M-D3H y la ozmosis rom es : Z87MD3H-F11-OZM-DSDT-G-1479-M.rom

ademas necesito una guia preferiblemente en español o ingles y que sea al menos un poquito mas explicita que la mayoría que andan por ahi.

 

muchas gracias, agradeceré su ayuda.



#2
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

Disculpa, no me quiero entrometer pero ¿porque te complicas queriendo flashear la BIOS? mi ingles no es bueno y tiro de Google translator, ademas solo ver que hay que flashear ya dejo de leer el resto del post y por lo que veo en el post de Ozmosis se trata de eso en primer lugar, lo que quieres conseguir es un hackintosh no? pues usa Clover y una instalación retail, conseguirás lo mismo sin jugártela y bajo mi punto de vista mas "limpiamente" o como mínimo igual



#3
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
  • Gender:Male

En realidad, hoy por hoy  con la facilidad de uso de los bootloader existentes, mas la gran experiencia adquirida por la comunidad "hackintoshera" instalar la "manzana" es pan comido.

Sin embargo por naturaleza el ser humano se lo puede catalogar en distintas categorías.

Una de ellas es la de "culos inquietos" .

Yo los definiría como toda persona que a pesar de tener solucionado un problema, busca otras alternativas, otros  métodos distintos que conduzcan al mismo resultado pero que faciliten el trabajo a los demas.

Ahí es cuando muchos se cuestionan "¿para que revolver la mierda si ya llegó al pozo?" .

 

Doy gracias a esos personajes inquietos que nos han dado tantas herramientas que nos hacen la convivencia con el hack, tan fácil.

Recuerden lo que era instalar un hack hace unos años atrás y lo que es ahora con Chameleon y/o Clover por ejemplo.

¿Que hubiera pasado si dichas mentes se hubieran conformado con las herramientas de aquel entonces? 

 

Desde los comienzos se busca la compatibilidad mas perfecta para el hack y mayor facilidad para el usuario (recuerdo unas bios modificadas de un genio cuyo nombre no puedo recordar ahora - creo que era algo así como Navcom).

 

Me atrae la idea de Ozmosis pero personalmente no la pongo en práctica porque mis conocimientos son muy limitados y porque no tengo una placa con dual bios. (En cuyo caso, aun con conocimientos deficientes estaría experimentando seguro)

Es mas, he encontrado una bios modificada para mi placa y no quiero probarla hasta comprender mejor que han modificado porque los parámetros a corregir son bastantes y no puedo decir exactamente cuales fueron cambiados.

 

¿Que es peligroso? Si, mucho, pero no estaríamos aquí disfrutando de este S.O. si algunos valientes pioneros no hubieran asumido riegos.

 

Siempre escuché quejas sobre la comunidad hispano-parlante acerca de su compromiso en el hack. Hablo mas bien de desarrolladores y programadores que no vuelcan sus conocimientos al castellano (muchos si lo hacen en los foros ingleses). Ni dudar que hay muchísimos genios aportando en castellano,  (si no, no existiría este foro).

 

Al querer acceder a ese conocimiento o lenguaje (inglés-ruso-aleman) me siento como en la edad media cuando por ejemplo las misas se impartían en latin y el vulgo no entendía nada de nada, y quedaba a cargo de los "iluminados" para que le hiciesen de interprete.

Esta percepción mía, es totalmente personal ya que si tuviese la formación adecuada  no tendía barreras de comunicación.

 

En fin, una vez hecho mi descargo continuaré disfrutando de este domingo.



#4
pmcnano

pmcnano

    Preguntaaame caom!

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,240 posts
  • Gender:Male
  • Location:Merida, Mexico

En verdad que de lo que se pierden :P Es una maravilla en mi opinón el ozmosis! Y dos páginas alemanas tienen bases de datos con las bios ya modificadas.



#5
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,405 posts
  • Gender:Male

si es esta: http://hackintosh-fo...d1315944fc72762

 

me da un poco de cosita, pero bue... mi placa es dual bios, si algo sale mal tengo auto flasheo...

 

esta interesante...



#6
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

Guzman, yo esas cosas las dejo a PomPIs que si no ha cambiado nada no le cuesta comprarse una placa base para experimentar solo por el gusto de decir "lo hice", yo si peto la mía deberé decir adiós a mi maquina y volver a poner en marcha un AMD 7750x2 con una G210 y 2 GB de RAM y al paso que llevo seria una solución para muchooooo tiempo



#7
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
  • Gender:Male

Te entiendo y mucho Eduardo.

 

Mi AsRock Z77 Extreme 4 pasó a mejor vida (estará en el cielo de las plaquitas la bandida) y estoy desesperado por una Gigabyte dual bios (Uefi) para probar.

Desesperado porque no tengo un duro.



#8
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

fíjate lo que hay por ahí, mi placa aunque no se si es la misma revisión, la mía es la 1 y hay la 1.3 aunque solo cambia la velocidad de enlace de los pci's y ya compare una vez las Bios, son idénticas .............. no puedo leer estos posts luego pico y la cago muy fácilmente, ya tengo las dos versiones bajadas, solo cambia por la actualización pero leyendo el foro que tienen no explican nada así que habrá que leer el post de aquí en Insanely

Z68_zpse0e680a7.jpg



#9
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

queria editar pero no me deja escribir debajo de la captura, en fin, leyéndome de cabo a rabo el post de Ozmosis veo que hay algunos problemitas y que con Yosemite te hace ver todas las particiones como Install OsX, me esta mosqueando, anda y aclárame un poco Derty que ya estoy picado y si se me pasa lo dejo correr a ver si es algo que se me esta pasando.

 

EDITO:
Llevo desde ayer muchas horas de lectura, mas de las que quisiera en foros alemanes, rusos y principalmente ingleses, la verdad es que hay poco que ganar y mucho que perder con OZMOSIS, como dicen muchos usuarios ganas una carpeta de menos en la particion EFI (con Clover) y aun así tienes que ir actualizando la BIOS a cada actualización de Apple, tienes que seguir parcheando el AppleHDA o meter vodooHDA en la BIOS, necesitas en un porcentaje de placas muy alto meter FakeSMC y kexts de red, DSDT, etc. después de todas estas vueltas lo dejo correr, mi {censored} también es inquieto y soy de los que se pueden pasar horas probando cosas miente y pensamientos trabajan al 150% no suelo quedarme sin salidas o ideas pero no quiero llegar al extremo de quemar una placa base por una simple actualización que no da ventajas en ningún modo, SI alguna si perocomprando una placa Z77 a los de QUO que aparte del Thunderbolt y los Firewire no tiene nada de diferente con otras Gigabyte digamos "de calle" o serie, eso si, seguiré leyendo y estando al día con este tema de OZMOSIS por si alguien necesita alguna cosa en nuestro foro español, lo que pueda ayudare aunque jamas lo aconsejare, disculpad el tocho 

 

pd. ya hice ayer mi propia ROM y no me da el mismo resultado (bits) que la bajada del foro alemán ya que en ningún sitio dicen que han añadido dentro y algún punto no acabo de comprenderlo bien, solo lo hice por curiosidad y no actualizare (como me repito)

 

dejo unos enlaces para quien quiera comprender o saber algo del tema.

una explicación de quien son cada cual:

http://www.techspot....g-a-hackintosh/

y un foro en el que hay algo mas que explicaciones aun siendo casi los mismos autores que aquí en Insanely y esta mas actualizado, lo que comenta en algunos post The King esta mas que claro

http://www.projectos...&showtopic=3018



#10
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,405 posts
  • Gender:Male

no me salió...  tuve que re-flashear y encima me dio error y no quería recuperar la bios.. original, quite la pila, inicie sin pila el mother, dio todo tipo de errores y pitidos, y al final pude arrancar...

 

estuve dos tardes con esto... ya se que en pruebas no es tiempo para saber nada...

 

pero con chameleon yo tengo todo controlado y funcionando.. solo parcheo el audio y red y con smbios y chameleon boot, pelados y basicos mi hard corre perfectamente osx y windows...

 

lo de las QUO, pienso igual.. hay varios modelos gigabyte perfectamente funcionales.

 

vamos a esperar unos meses, en su momento el parchar dsdt, también fue un dolor de cabeza. 



#11
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

estoy intentando hablar con Magnifico, el tío esta metido en todas partes hasta me lo encuentro en casi todos los foros que leo sobre el tema, estoy intentando hablar con el para ver su experiencia ?¿?¿?¿ pero no se si sacare algo en claro con el, Chris1111 también anda por ahí incluso con videos en Youtube sobre Ozmosis (hackintosh Montreal) bastante didácticos pero con pocas explicaciones sobre resultados, Derty prueba tu a hablar con Chris que creo recordar que tu francés es bastante bueno a ver si se moja y da alguna consejo, si ves alguno de los videos con Ozmosis que hay por ahí son incluso mas lentos en el arranque que mi sistema aunque yo uso una SSD

 

Por cierto te bajaste la Bios para ti ya hecha o la hiciste tu?



#12
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

Te lo dije ,,,, ya esta instalada la Bios con Ozmosis, de momento el único cambio visual (en la BIOS) es que me aparecen 18 opciones de arranque aunque solo tenia 6, arranque EFI, USB, los legacy y otro montón mas incluida la de recovery, bueno me permite arrancar con UEFI la SSD por lo que de momento tengo todo funcional, OsX y Win 8.1, desde EFI no acaba de arrancar o sea que me bajo la ultima Yosemite a pelo y haré una instalación a ver que pasa al puro estilo de Apple, luego comento si va o si ...no y de esa forma vera que me falta por funcionar suponiendo que entre al sistema.

iCloud no para de decirme que meta la contraseña y no la coge ..... algo si ha cambiado pero ya lo solucionare después



#13
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,405 posts
  • Gender:Male

haciendo mi bios destruí todo...jajaja, tal ves por meter el fakesmc, pero no creo. 

 

mi francés solo servira para salir a tomar un cafe con chris.. :help:

 

 

lo saque todo de aqui:

 

http://www.insanelym...291655-ozmosis/

 

fui directamente a "OzmosisDefaults with imac14,2 and boot arguments for OS X 10.10"

 

 

hace tiempo que no dedico tiempo al hackintosh... desgraciadamente...

 

 

en este canal están los videos de muestra

 

https://www.youtube....mamadeus/videos

 

 

 

el video de chris, si alguien quiere seguirlos, en extraño francés....

 

 

la pagina de chris, donde encontrar el osmosis box

 

http://www.hackintosh-montreal.com



#14
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
  • Gender:Male

ejejej

¿este es el Eduardo que no quería trastear?

¡Toma del frasco Carrasco!

 

¡Enhorabuena por tus avances!

 

No hay caso somos unas "putonas", en cuanto sale algo para trastear nos come el gusanillo.

 

También anduve por las páginas alemanas pero me mosquea que no se detallen las modificaciones hechas a la Bios.

 

En caso de llegar a probar algun día, mi intención era agregar FakeSMC, el kext del Lan,el DSDT y el kext "dummy" de Spike para que al actualizar el HDA no "jodiera" el invento.

Pero entiendo que no es para siempre.

Si cambia la version Bios hay que rehacer todo de nuevo, si cambias hard (gráfica, memoria, cpu, etc) mas de lo mismo. Y no digamos si Apple hace algun cambio drástico.

 

Pero, en fin...¿esto no es el leitmotiv del hackintosh?

 

http://www.hackintos.../20657-ozmosis/



#15
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

me esta cabreando, hice un instalador limpio siguiendo los pasos que indican para un Apple y no funciona:

KP del AppleIntelCpuPowermanagement, no da ni tiempo a hacer captura de pantalla ni con la cámara lista, mientras hacia el instalador me he ido a comprar tabaco y al volver estaba el equipo en reposo, vamos apagado del todo pantalla CPU, todo, con solo tocar una tecla ha vuelto a encender con todo funcionando, algo es algo, ahora como tengo también el arranque UEFI desde las opciones pues arranco la SSD en la que tengo Clover y listo, si le digo que arranque EFI ( funciona sin bootloader) me arranca desde la SSD y dice que tengo un MacPro 3,1 pero sin red y sin audio, Ethernet SI pero Wifi NO, la gráfica 6850 bien reconocida y funcionando perfecta habrá que trastear un poco pero mi Bios es de poca capacidad y no se donde llegare si tengo que andar metiendo cosillas en ella, Windows 8.1 funciona muy bien y muy rápido, ahora mismo no se por donde meterle mano pero voy a ello poco a poco.



#16
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
  • Gender:Male

¿Cargaste la dsdt corregida en la bios Ozmosis?



#17
juanerson

juanerson

    InsanelyMac Deity

  • Local Moderators
  • 1,711 posts
  • Gender:Male
  • Location:Tru, Venezuela

Será(n) la(s) SSDT(s) que contiene(n) los P-States? Porque ese KP se muestra cuando las tablas SSDT son incompatibles con la "norma Apple" o hay alguna incoherencia (entradas "External") entre la DSDT y las SSDT relacionadas con los estados del procesador. Que yo recuerde el equipo se reinicia enseguida, casi en el acto... y no da chance de fotografiar nada, se conoce como "instant reboot". Por si acaso quieres salir de dudas probando, el NULLCPUblablabla debe anular ese KP. Además del tema de parchear el AICPUPM.kext (MSR 0xE2) que es casi obligatorio en los Sandy Bridge... etc, este punto en particular se puede resolver parcheando la BIOS (cuando lo permite).

 

Esta OZMOSIS que cocinaste tiene el registro en operaciones MSR parcheado? Pudiera venir por allí tu KP, Eduardo. Saludos.


Edited by juanerson, 22 October 2014 - 06:19 PM.


#18
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

no, la Bios que he cargado es la que baje del foro alemán, de ahí que tenga que buscarme la vida para saber que carajos han metido en esa Bios, no obstante me fio mas del trabajo hecho por ellos que de la Bios que hice yo que no acabo de atreverme, si en la mia hubiera alguna fallo en el DSDT o en las SSDT desconozco lo que puede pasar, tengo que leer mas aun, de momento he conseguido que iCloud acepte mi pass y vuelve a ir todo fino, si alguien quiere echar un vistazo le saco un report DarwinDumper y lo subo a ver que hay o deja de haber si es que allí se puede ver arrancando desde EFI sin bootloader, vamos a pelo



#19
uzmi

uzmi

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
  • Gender:Male

no, la Bios que he cargado es la que baje del foro alemán, de ahí que tenga que buscarme la vida para saber que carajos han metido en esa Bios, no obstante me fio mas del trabajo hecho por ellos que de la Bios que hice yo que no acabo de atreverme, si en la mia hubiera alguna fallo en el DSDT o en las SSDT desconozco lo que puede pasar, tengo que leer mas aun, de momento he conseguido que iCloud acepte mi pass y vuelve a ir todo fino, si alguien quiere echar un vistazo le saco un report DarwinDumper y lo subo a ver que hay o deja de haber si es que allí se puede ver arrancando desde EFI sin bootloader, vamos a pelo

 

¿No usas Clover? ¿Y el equipo funciona bien con los P-States?

 

Extrae tu dsdt modificada por Clover y prueba a abrir la bios alemana y cambiarla por la tuya.

 

Con Clover puedes hacer el dump de las tablas ACPI desde la interfaz del mismo presionando:

F4 para las tablas originales (sin tocar). Se guardarán en la carpeta ACPI/origin.
F5 para las tablas editadas por Clover (incluyen los fixes que hayas habilitado). No estoy seguro pero creo que a estas las guarda en la carpeta ACPI/patched.



#20
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 783 posts

no, si arranco la SSD desde EFI esta clavado a 1.600 no hay cambios en el procesador y el lo da error en los P/C States y ademas cuando ejecuto DarwinDump se queda congelado y no lo acaba me toca dar botonazo, voy a probar a extraer las tablas desde Clover y ver si puedo cambiarlas en la ROM







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy