Jump to content

Ready to give up on Sony Vaio VPCEG16FM

sony vaio

  • Please log in to reply
54 replies to this topic

#41
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

Why did you have those IOBlockStorage errors ? Did you get still waiting for root error before ?



#42
RehabMan

RehabMan

    InsanelyMacaholic

  • Developers
  • 3,264 posts
  • Gender:Male
  • Location:Bellingham, WA
  • Interests:skiing, software, classic cars

I booted as directed and attached is the result.

I don't believe so. You can look at the attached pictures, but I didn't see it. Some of the other boot attempts have much more text that scrolls by and I might not have seen it.


Your mach_kernel is incorrect for the version of OS X you have...

Time to rebuild your USB.

#43
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

Maybe rebuilding the installer will help. Sony Vaio has a reputation of setting sata mode to IDE and hidden from their bios, especially the sandy bridge model and earlier, he could need a help on that



#44
Scott69

Scott69

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Your mach_kernel is incorrect for the version of OS X you have...Time to rebuild your USB.


If you have a specific method of rebuilding my USB I would be happy to follow it. I followed Dr Hurts directions for building the Mavericks version I have with Clover, and I followed Rodrigchunas directions to build the Yosemite version with Chameleon.

I'm sure if you have a method in mind that would mean that you have control over the content when I boot, it would make sense.

Ideas?

#45
Dr. Hurt

Dr. Hurt

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,673 posts
  • Gender:Male
  • Location:Santander, Spain
  • Interests:Politics, Sci/Tech, Medicine.

I have a rather extreme suggestion for you if you're willing to go that far.

 

Take the HDD out of the laptop and use the other machine to install (or restore an existing) OS X to a partition, then put it back into your Vaio.

 

That way we boot using the well supported regular 6-series AHCI SATA protocol instead of USB.



#46
Scott69

Scott69

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

I have a rather extreme suggestion for you if you're willing to go that far.
 
Take the HDD out of the laptop and use the other machine to install (or restore an existing) OS X to a partition, then put it back into your Vaio.
 
That way we boot using the well supported regular 6-series AHCI SATA protocol instead of USB.


I assume I should install a bootloader to this HDD after I install?

#47
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

Yup that's the point, or you could try rebuilding another USB following this guide



#48
Dr. Hurt

Dr. Hurt

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,673 posts
  • Gender:Male
  • Location:Santander, Spain
  • Interests:Politics, Sci/Tech, Medicine.

I assume I should install a bootloader to this HDD after I install?

 

Not necessarily. Clover will start from the USB, and detect OS X you restored to the drive.



#49
Scott69

Scott69

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

Not necessarily. Clover will start from the USB, and detect OS X you restored to the drive.


Dr hurt,

I made an install of iAtkos ML2 to a new SATA drive. I installed it with the specific screen size option as well as the Intel HD3000 option selected.

Attached is the result.

Attached Files



#50
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

Look like Still waiting for root device error



#51
Scott69

Scott69

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
I guess there are no new ideas? I did as advised and installed to a separate SATA drive and it didn't work.

#52
vusun123

vusun123

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,095 posts
  • Gender:Male

What error did you get ?



#53
Scott69

Scott69

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

What error did you get ?


The screen shot above shows all that I can tell you. I don't see an error anywhere. Unless someone can tell me how to capture the text of the whole boot sequence, I don't see any errors.

#54
Mad Marcsen

Mad Marcsen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 70 posts

Hey,

 

maybe i can help you with my experiences on installing Mavericks on an VPCEB4C5E.

 

First i made a bootable stick with this guide:

http://www.insanelym...-for-mavericks/

 

I only installed Clover and FakeSMC. NullPower is not needed on my machine.

 

Then i obtained the config.plist for Clover from this guide because on this machine you have to inject EDID, else you get a blackscreen when loading the GUI:

http://www.insanelym...vaio-vpceb4c5e/

 

I booted the stick with "-v -UseKernelCache=No -f USBBusFix=Yes"

 

I hadn't had any luck for a few times because i missed to install PS/2 drivers for the keyboard  :blush:

 

However, boot time until the installer was loaded was about 20 or 30 minutes. In this time the notebook dir _nothing_. Maybe you just should gave to wait. Last message on my Vaio was the line with Bluetooth.

 

Edit: Please also try to plug in an external USB keyboard.



#55
midi_senpai.pkg™

midi_senpai.pkg™

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 883 posts
  • Gender:Male
  • Location:Earth
Wewewewew, is that UEFI capable?
If yes look at my sig ;)





Also tagged with one or more of these keywords: sony, vaio


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy