Jump to content

[Ajuda] Qual OSx instalar?

- - - - - osx novo intel

  • Please log in to reply
47 replies to this topic

#21
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá PimentelX86

 

Para instalar, como disse, usei uma BIOS (pois não havia nenhuma mais recente oficial). A bios que tenho suporta AHCI, mas, por defeito, não dava para alterar de IDE para AHCI, então tive que flashar uma alterada e aí depois, utilizando o Chmeleon (tecla 1, como disseram).

 

Vou então tentar instalar o bootloader.

 

Mas, segundo esta notícia, supostamente a minha placa já vem com suporte por defeito no OSx, certo? http://appleinsider....re_mac_hardware

 

Cumprimentos.



#22
PimentelX86

PimentelX86

    InsanelyMacaholic

  • Local Moderators
  • 2,940 posts
  • Gender:Male
  • Location:Area 51

Olá

 

Suporte por defeito? Não entendi isso...

 

O que posso te dizer é que a tua gráfica já tem suporte, mas é preciso ativa-la de certa forma, por isso te dei o guia... para que saiba ativar a tua gráfica.

 

Sobre a mobo... posso te dizer que tu irá ter efeitos colaterais por modifica-la, mas isso é só vendo no futuro próximo.

 

Te concentra em configurar as coisas... instala o Chameleon via pkg o processo é automático e evita muita dor de cabeça.



#23
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá,

Sim, pensava de ser suporte por defeito no âmbito de já estar activado, ser ter que fazer nada, mas pelo que percebi, não é bem assim.

 

Já li e reli cerca de 5 vezes o tópico sobre as kext da placa gráfica mas continuo sem entender o que é realmente preciso fazer para activar a gráfica.

 

Pelo que percebo, é preciso 3 kext e, no meu caso, tendo uma ATI Radeon HD 5670, preciso dos ATI5000Controller, ATISupport e ATIRadeonX5000, certo? Já sei qual é a minha Vendor ID e Dev ID (0x100268D8).

 

Sei que depois tenho que adicionar o vendor id e dev id na linha IOPCIMatch. Mas não sei de qual dos kext tenho que fazer isso.

 

Por fim, sei que tenho que instalar esses 3 kext. Isto foi o que eu percebi.. Mas, para mim, o tópico é muito complicado pois está a usar uma linguagem avançada demais para mim. E também tentei procurar na internet esses 3 kext e não consegui encontrá-los. Talvez esteja a procurar no local ou com os nomes errados.



#24
PimentelX86

PimentelX86

    InsanelyMacaholic

  • Local Moderators
  • 2,940 posts
  • Gender:Male
  • Location:Area 51

Olá

 

Olha, eu nunca tive gráfica ATI e por isso nem sei como ativa ao certo... pelo que percebi é necessário adicionar o DevID e o VenID nas 3 kexts que alias já estão no OSX e não precisa baixar nada...

 

Veja qual é a kext que controla a tua gráfica e tente entender... até sinto por não poder te dar maiores informações.

 

Boa sorte!



#25
Allaп

Allaп

    InsanelyMaestro

  • Moderators
  • 4,364 posts
  • Gender:Male
  • Location:Brazil

Opa, voltei.

 

@Benny, leia aqui por favor:

http://www.insanelym...ti-radeon-5670/

 

esse aqui é mais detalhado

http://www.insanelym...king-with-qeci/



#26
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá! Já consegui instalar então instalar o OSx 10.9.

 

Consegui colocar o som, internet e placa gráfica a funcionar (o som fica o pouco com distorção, é normal?)

Agora, instalei o bootloader, mas, quando inicio o computador, não me aparece o menu para escolher qual o sistema que quero arrancar... apenas me aparece o menu que segue na imagem em anexo.

 

Outra coisa, tenho vários discos, com músicas e filmes, e estão formatados em NTFS. Mas o OSx nao me autoriza a escrever neles. Como posso fazer para os utilizar a 100%? Obrigado  desde já por toda a vossa ajudar!



#27
PimentelX86

PimentelX86

    InsanelyMacaholic

  • Local Moderators
  • 2,940 posts
  • Gender:Male
  • Location:Area 51

Olá

Qual kext de áudio instalou? Tenta essa VoodooHDA 2.8.4: http://sourceforge.n...84.zip/download
Remove AppleHDA

Cadê a imagem? De qualquer forma, já sei do que se trata... O Chameleon utiliza por padrão essa tela preta(igual a um prompt) e você terá que escolher qual disco bootar através disso.

Sobre NTFS, procura no google por algum programa que faça isso... eu sabia de um, mas infelizmente me esqueci do nome do mesmo.
 



#28
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá!

 

O kext que usei foi Voodoo, mas não me recordo a versão.

 

Onde se encontra AppleHDA para eu remover antes de instalar essa versão?

 

A imagem não é da boot do charmeleon, é uma típica de dualboot do windows.

 

Segue em anexo desta vez.

Attached Files



#29
PimentelX86

PimentelX86

    InsanelyMacaholic

  • Local Moderators
  • 2,940 posts
  • Gender:Male
  • Location:Area 51

Olá

 

Instalou VoodooHDA e esqueceu de remover a AppleHDA? Sempre quando se tem duas kext com a mesma finalidade, se remove a que não quer usar... Todas as kexts ficam na pasta S/L/E... remove jogando no lixo... Tenta essa versão.

 

Sobre o bootmanager... Tem que ver isso. Mas tem pelo menos como dar boot para entrar no OSX?



#30
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá!

 

Sim, consigo dar boot, mas para isso tenho sempre que usar a usb drive..



#31
PimentelX86

PimentelX86

    InsanelyMacaholic

  • Local Moderators
  • 2,940 posts
  • Gender:Male
  • Location:Area 51

Olá

Então o problema não esta no computador, mas sim no modo que configurou as coisas...

Já tem Chameleon instalado? Já criou os 2 arquivos org.chameleon... SMbios?

Já instalou a kext FAkeSMC e já ativou P e C States no org.chameleon.plist???
 



#32
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá!

 

Sim, já instalei o Chameleon e o kext FAkeSMC.

Agora, a activação dos States e a criação desses dois arquivos não sei onde nem como fazer.



#33
PimentelX86

PimentelX86

    InsanelyMacaholic

  • Local Moderators
  • 2,940 posts
  • Gender:Male
  • Location:Area 51

Olá

Esses 2 arquivos são os principais...

Eles podem ser feitos com o chameleon Wizard... E salvado na pasta Extra... aqui eu já te disse como: http://www.insanelym...r/#entry1986183
Faltou dar uma lida no que eu já te ensinei, está tudo lá.

O SMbios tem que possuir um hardware parecido com o teu. Existem vários modelos que você pode escolher pelo próprio CW... Lá ele lista em baixo do modelo o hardware que compõe o modelo... procura por um que contenha o IC2Q... não esqueça de marcar o local de onde está a tua SMbios na aba org.chameleon...
 



#34
Allaп

Allaп

    InsanelyMaestro

  • Moderators
  • 4,364 posts
  • Gender:Male
  • Location:Brazil

Olá! Já consegui instalar então instalar o OSx 10.9.

 

Consegui colocar o som, internet e placa gráfica a funcionar (o som fica o pouco com distorção, é normal?)

Agora, instalei o bootloader, mas, quando inicio o computador, não me aparece o menu para escolher qual o sistema que quero arrancar... apenas me aparece o menu que segue na imagem em anexo.

 

Outra coisa, tenho vários discos, com músicas e filmes, e estão formatados em NTFS. Mas o OSx nao me autoriza a escrever neles. Como posso fazer para os utilizar a 100%? Obrigado  desde já por toda a vossa ajudar!

 

Sobre o App que pode te ajudar a ler/escrever em partições NTFS, use o Paragon (pago). 

Ele é um dos melhores que tem.  ;)


Em meu antigo Hack, eu usava um Core 2 Quad, o SMBIOS correto para ele é de MacPro 3,1.

Pode ir tranquilo... B)



#35
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Boas! Já instalei o paragon em trial e funciona perfeitamente.

 

Agora, fiz o seguinte, conforme podem ver na print. Já havia escolhido o MacPro 3,1 , devido possuir info de socket 775, que é o caso do meu pc... mas, continua a aparecer o bootloader do windows... não entendo o que estou a fazer de mal.

Attached Files



#36
PimentelX86

PimentelX86

    InsanelyMacaholic

  • Local Moderators
  • 2,940 posts
  • Gender:Male
  • Location:Area 51

Olá

 

Qual é exatamente teu problema? Não consegue dar boot pelo HDD é isso?

 

bootloader do windows? O que é isso?

 

Já instalou e configurou as coisas do jeito que eu pedi?

 

Seja mais claro nas suas duvidas, por favor.....



#37
Allaп

Allaп

    InsanelyMaestro

  • Moderators
  • 4,364 posts
  • Gender:Male
  • Location:Brazil

Boas! Já instalei o paragon em trial e funciona perfeitamente.

 

Agora, fiz o seguinte, conforme podem ver na print. Já havia escolhido o MacPro 3,1 , devido possuir info de socket 775, que é o caso do meu pc... mas, continua a aparecer o bootloader do windows... não entendo o que estou a fazer de mal.

 

Quando o PC liga, aparece como se fosse uma tela preta com as opções de partição?

 

Isso pode ser por que você não escolheu o tema, veja se o tema está na pasta Extra, e que o mesmo esteja endereçado no boot.plist.



#38
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá

 

Qual é exatamente teu problema? Não consegue dar boot pelo HDD é isso?

 

bootloader do windows? O que é isso?

 

Já instalou e configurou as coisas do jeito que eu pedi?

 

Seja mais claro nas suas duvidas, por favor.....

 

Olá! Só consigo arranjar para o OSx usando uma usb flash drive com o chameleon.

Já configurei como disse, e pode ver na imagem que coloquei no post anterior http://www.insanelym...-2#entry1986461

 

Mas continua a arranjar automáticamente para o windows 7 se eu não tiver a usb flash drive ligada.

 

Quando o PC liga, aparece como se fosse uma tela preta com as opções de partição?

 

Isso pode ser por que você não escolheu o tema, veja se o tema está na pasta Extra, e que o mesmo esteja endereçado no boot.plist.

 

Olá. Sim, antes aparecia, conforme pode ver na imagem que coloque aqui: http://www.insanelym...alar/?p=1986428

 

Agora já não aparece, arranca automaticamente para o windows, se eu não tiver a flash drive ligada com o chameleon.



#39
Allaп

Allaп

    InsanelyMaestro

  • Moderators
  • 4,364 posts
  • Gender:Male
  • Location:Brazil

tenta reinstalar o Chameleon no OS X.

sobe com o Pen, e instala o Chameleon, depois repare as permissões da pasta Extra com o KextWizard.

 

só lembrando, isso aconteceu quando você plugou o HD que tem o Windows, depois que fez a instalação do OS X no outro HD certo?



#40
Benny-Danny

Benny-Danny

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
  • Location:Portugal
  • Interests:Photography

Olá!

Já consegui, e não foi por instalar o Chameleon novamente..

O que fiz foi no Chameleon Wizard foi:

 

No módulo "Install" escolhi a opção Boot0md, e, depois, quando me pediu qual o disco para instalar o bootloader, escolhi a partição "System Reserverd" (partição criada automaticamente pelo windows quando foi instalado).

 

Depois, no módulo org.chameleon.Boot , 1ª coluna lado esquerdo, alterei o timeout para 5 e activei "default partition", onde escrevi "hd (0,1)" para ele arrancar por defeito na partição do windows (não a partição onde ele está fisicamente instalado, mas sim a "System Reserved" pois é onde tem o bootmgr do windows). Iniciou perfeitamente. Depois, experimente iniciar o OSx e também iniciou sem problemas! :D








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy