Jump to content

[Guide] SurfacePro 1 & 2 Osx-Android-Windows multiboot


  • Please log in to reply
2566 replies to this topic

#2561
JahStories

JahStories

    InsanelyMac Legend

  • Local Moderators
  • 1,496 posts
  • Gender:Male
  • Location:Sicily, Italy.
  • Interests:Everything that got a screen on it, skateboarding, reggae music, PowerPcs, Amigas and retrogamin...

no need to download the grub.cfg, just edit yours as proposed in the guide:

 

navigate to boot/grub and edit thee grub.cfg adding this lines:

Quote

 

 

submenu "Android" {
menuentry "Android" --class android --class linux --class os {
linux /android/kernel root=/dev/ram0 androidboot.hardware=android_x86 quiet video=1920x1080 dpi=145 i915downclock=1 i915.powersave=1 usbcore.autosuspend=2 SRC=/android/
initrd /android/initrd.img
}
menuentry "Android text output" --class android --class linux --class os {

linux /android/kernel root=/dev/ram0 androidboot.hardware=android_x86 video=1920x1080 dpi=145 i915downclock=1 i915.powersave=1 usbcore.autosuspend=2 SRC=/android/
initrd /android/initrd.img
}
menuentry "Android debug mode" --class android --class linux --class os {
linux /android/kernel root=/dev/ram0 androidboot.hardware=android_x86 video=1920x1080 dpi=145 i915downclock=1 i915.powersave=1 usbcore.autosuspend=2 SRC=/android/ INSTALL=1 DEBUG=1
initrd /android/initrd.img
}
}

save and exit.

 

Have Fun!



#2562
Quattro74

Quattro74

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
First post here in this thread,

Thanks to all on making this ultimate hack a reality. I have most things working cept WiFi of course and the other issue is sleep.
On my surface pro 2 4300u I get the wakeup after 10 seconds. Dmesg says that the SAM is the cause, I understand this is the pen system.
Does a fix for this exist? Do others have this on my same hardware? Should I upgrade the FW on the windows side?

My install went well, strait forward shrunk HD, then an elaborate clover configure to get boot working properly. Using standard kexts included
In sp2 4 pack.

Also, backlight slider only works after sleep attempt. Any way to fix this yet?

Thanks,

Q

#2563
makumaku

makumaku

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
I could install mac osx. Now i dual boot mac or windows. Thank you
i am trying to upgrade windows from 8.1 to 10, but upgrade is failure
Can anyone upgrade in enviroment dual boot ?
Windows upgrader is fail not to find partition containing bootlooder of windows…?
Sorry my poor english

#2564
JahStories

JahStories

    InsanelyMac Legend

  • Local Moderators
  • 1,496 posts
  • Gender:Male
  • Location:Sicily, Italy.
  • Interests:Everything that got a screen on it, skateboarding, reggae music, PowerPcs, Amigas and retrogamin...

please update your signature to follow the thread rules and if you really need help.

 

btw

 

Windows 10 update is SAFE for those who correctly followed the dual boot guide, just click and update.

 

SurfacePro users should use (or automatically recive) the Get Windows X App (GWX) to get the update officially. search the web for more info

 

Dunno what's your issue!



#2565
Quattro74

Quattro74

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Surface2Pro. 4300U

In my case the Applebacklightdisplay wasn't automatically recognized in system info when I first looked. I was able to define
It correctly using switchresx, now it shows up with that name under system info under switchresx definition bit under PCI, it is called display
Is this the way it should be showing up? Is this why I can only sleep for 15 sec? What files should I be looking a in order to troublehoot this?

How was this ultimately fixed in SP1 cause the SP2 4200u didn't have any issues, right?

#2566
linenoise

linenoise

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

So, I just realized that clover is not touch sensitive. I have to have a keyboard connected to choose the os. Clover says that it can do an auto boot to a default os after 5 seconds, but I can't figure it out. I tried to change the default volume in theconfig file from SurfaceSSD to Windows, Surface, Microsoft, and System, but none of them seem to work. I also tried to go into osx and tell it to reboot into windows without any luck.  Any ideas?



#2567
Quattro74

Quattro74

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Linenoise,

 

For me it was SYSTEM to get Widows to boot. OS X for my mac install.







2 user(s) are reading this topic

1 members, 1 guests, 0 anonymous users


© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy