Jump to content

Help Intel HD 3000 0X0116 i7

Intel HD 3000 i7 2670QM QE/CI

Best Answer artur-pt, 29 August 2013 - 04:07 PM

hello

 

like i say before u should use the stock kext, present in the OS.

 

only install the original kext .. and try to boot ..

 

have u try to boot with hdmi port ?

 

good hack

Go to the full post


  • Please log in to reply
14 replies to this topic

#1
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hi Guys,

First , sorry for my bad english, i'm french.
I have to explain my problem: 
I've a ASUS N75SF (Intel i7 2670QM Sandy Bridge with Intel HD 3000 mixed with Optimus technology with a NVIDIA GT 555M (Of Course i can't Disable it in the Bios , and i already know that this card isn't compatible with OSX ) with 6Gb of Ram and 1tb Hard Drive) 
My problem is that i've installed Iatkos ML3 (My Bios is compatible with UEFI) and so finally all work (Wifi, Sound, Webcam, USB 3.0) But Intel HD 3000 doesn't work and i've tried so many things, like Inject a DSDT, or many kext wich most of them make my installation Freezing or a Black Screen. Finally i've found AppleIntelSNBFB patched for my device ( With device ID 0X0116) and my computer recognize it, so i can choose my screen resolution etc.. But QE/CI doesn't work at all, and for few days and hour i've tried a lot of solution ( Like change device id 01168086 to 0X01168086 but it doesn't give me QE/CI anyway ) so i don't know what trying at all... And i will be very happy if you can help me, so i hope that you can help me. 
Thanks so much in advance.



#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

have u try dual link patch ?

 

the nvidia works .. no problems.. what is do not work is the switchable graphics .. between intel hd and nvidia..

 

the 2 is the problem..

 

anyway my advice is to use the stock kext .. the ones from the system

 

http://olarila.com/f...136e6bbd2f71dbd

 

good hack



#3
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Re, 
I've the first step of backup in Single Mode 
But Now, i don't see at all , how can i apply the patch to the Dsdt , it makes me confused, how can i Apply it to my DSDT 
When i run DSDT Editor, i can see all the lines of my DSDT but i don't know where can i take the lines from the patch? 
 



#4
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

read all the post..

 

u can use efi string..

 

good hack



#5
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I've tried this, with Efi String And boot.plist, , and i reinstalled  my kext, but that's always the same problem, i've my 1920x1080 resolution but no QE/CI anyway...I Can't play a movie , No OpenGL ... 



#6
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

if u apply all the things in that post..  smbios macboopro8,1

 

dual link patch ..

 

what kext are loaded for the graphics ?

 

if no qe/ci the *.fb.kext sure is not loaded..

 

good hack



#7
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Yeap, the Smbios is set to 8.1 So it is not about this.
I inject the patch as it is say in EFI string and Boot.plist it give me this line :

<string>2</string>

<key>device-properties</key>
<string>5600000001000000010000004a0000000100000002010c00d041030a000000000101060000027fff0400240000004100410050004c00300030002c004400750061006c004c0069006e006b0000000800000001000000</string>
</dict>
</plist> (It is just the end) 
I've just here load two kext :  AppleIntelgraphicFB And AppleintelSNBgraphicsFB 'I've deleted all the other because previously they give me Black Sreen or Freeze before i log into my session.... So is it because of the kext?


#8
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

should be loaded this

 

AppleintelSNBgraphicsFB

 

and

 

appleintelhd3000

 

i think the other fb is for the first generation intel hd

 

good hack



#9
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Ah ok, but i've tried many AppleintelHD3000 wich give me black screen or freeze so, wich one have i to choose... That's the question ...lol 
I'l search and i'l report if this work. ^^



#10
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

Best Answer

hello

 

like i say before u should use the stock kext, present in the OS.

 

only install the original kext .. and try to boot ..

 

have u try to boot with hdmi port ?

 

good hack



#11
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Okay i will try with them.
Okay i'l try but i think that it will not work on this way ^^
No, but i will, and i'l report you if it work. 
Thanks



#12
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Re , 
The problem is that i have delete IntelHD3000 kext which are from OSX.. And i don't found them on Internet , Must i really reinstall Osx for keep them? .. ^^



#13
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Re , Thanks a lot dude , it works , i've reinstalled, patched dualink , with intel stock kext and AppleintelSNBFB and it works , but the screen sparkle a little, is there a way to change that? Exept Fakesmc?  Thanks 



#14
Jenova565

Jenova565

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Thanks a lot guy, finally i've resolved the sparkle, and my computer work like a charm with full QE/CI and without any artefact, thanks a lot :) 



#15
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,427 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

nice to know .. is all alright..

 

sometimes .. when install several modified kext.. the system become a mess..

 

and the solution is simple.. only do new install .. the right way.. and voila all working.. without any problems..

 

to tune up the system.. take a good read here.. i personally don't like distros.. u install several things .. and don't know what for.. many times only install garbage..

 

http://olarila.com/f...php?f=28&t=1716

 

hack mac os x is a process of learning " how to do ".. and if u like the system .. u learned something new every day

 

good hack







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy