Jump to content

Asus Z87 DELUXE DUAL - very close !

Haswell Z87 ASUS DELUXE DUAL

  • Please log in to reply
6 replies to this topic

#1
PM!

PM!

    Dodo v pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 943 posts
  • Gender:Male
  • Location:Brussels

Hi,

 

I'm facing a very big problem with my ASUS Deluxe dual : i can't get to chameleon boot screen...

 

I'm not new to the hackintosh world but i'm not familliar with ASUS nor UEFI BIOS. I'm pretty shure something is wrong with my bios settings.

I have tried a lot of modifications in the boot menu of the bios but none gave me any change. So here i am posting like in the old days, and begging fir help.

 

If anyone has faced this problem, let me know how to solve it.

 

Any idea is welcome.

 

PM!

 

EDIT : Ok thank's to Gus93 and his topic i found out that i needed to format my usb with MBR instead of GUID !

 

EDIT : just a little update, i'm now facing a problem during install process "Internal Error" comes up aboute one or two minutes after Intall boots up.

 

EDIT 3 : After a few reserch and troubleshooting I managed to install 10.9 on thos board. Still I use it for video editing and FX and needed Adobe After Effects.

So I found on netkas website that 10.8.5 has full support for Haswell CPU. I got it from uploaded.to links and indeed it's running just fine. Even better than 10.9.

 

No bugs to report. Still looking for a ML version of the intel network controller, but haven't searched that much and I know from an other thread that Intel published sources for their new driver that supports the this chip.

 

The only frustration I still have is the missing support for Thunderbolt DSL4510. It my be supported as soon as the new macbook air comes out... maybe...

Attached Files



#2
Gus93

Gus93

    InsanelyMac Protégé

  • Members
  • PipPip
  • 61 posts
  • Gender:Male
  • Location:St. Louis

Just wondering, before you began the install did you flash a patched version of your BIOS?



#3
PM!

PM!

    Dodo v pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 943 posts
  • Gender:Male
  • Location:Brussels

No I have not managed to patch the BIOS. 

The USB Flash Back function doesn't takes the moded bios. The light goes still after a while and nothing happens.

 

I think it needs a little more tweeking from CodeRush but I can't help him debugging the problem as there is no log of the operation.

He told me to try with different USB drives which I did without success so far. 

 

EDIT : my mistake I wasn't renaming the CAP file correctly, a tool called ASUS BRenamer can help rename the bios file correctly fot UFB flashing.



#4
enraginangel

enraginangel

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Can you post how you did it? I've been trying to get Mavericks on my haswell board for days. I'd settle for mountain lion or anything at this point...



#5
PM!

PM!

    Dodo v pa dir i dor !

  • Members
  • PipPipPipPipPipPipPip
  • 943 posts
  • Gender:Male
  • Location:Brussels

First thing was to install using MBR and not GUID.

Then I cloned my ML 10.8.4 OS and updated it to 10.8.5.

Then installed chameleon r1152

Then i flashed my BIOS using PMPatch (needed to be renames correctly) and flashed with Asus USB Flash Back

Edited a DSDT for sleep (as the flashed BIOS wasn't enough and I needed to edit DSDT anyway for my FireWire800 TI card).

 

And that's it.



#6
jsl

jsl

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 246 posts

First thing was to install using MBR and not GUID.

Then I cloned my ML 10.8.4 OS and updated it to 10.8.5.

Then installed chameleon r1152

Then i flashed my BIOS using PMPatch (needed to be renames correctly) and flashed with Asus USB Flash Back

Edited a DSDT for sleep (as the flashed BIOS wasn't enough and I needed to edit DSDT anyway for my FireWire800 TI card).

 

And that's it.

Hi, I am using the same Asus Z87 Deluxe Dual MB as yours.

In Mavericks 10.9 DP2 or DP 3.1 no lucky for Intel HD 4600 Graphics and Thunderbolt DSL4510 function.

But I can not install it in ML 10.8.4 or 10.8.5 because of kernel panic during booting error of AppleACPIPlatform.kext.

Can you post your Mach_Kernel and AppleACPIPlatform.kext in 10.8.5 for our reference ?

Is it due to my Chameleon bootloader (v.2252) to new for it ?

Thanks for help.



#7
mrnick

mrnick

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hi,
So pleased to have found this thread. At least i now know it's possible!

I've just built my first system using 10.8.5 with a z87 deluxe dual and 4770k. Upgraded as I desperately need thunderbolt for swapping edits between systems. It's loading fine (via USB), but i haven't changed anything from default settings in the bios or added any kexts, DSDT or anything else for that matter.

Can anyone help me? Perhaps direct me to a noob walkthrough for this set up? I know I need to start with BIOS, but not really sure what to do with PMpatch.

PM! I really hope you can help, you must have everything I need if you're up and running. I can't tell you how much I'd appreciate it!

System overview:

OSX 10.8.5
z87 Dual Deluxe Thunderbolt Motherboard
Haswell 4770k CPU
2 DVD drives (not working)
Asus onboard sound (not working)
2x PowerColor HD6870 1GB GDDR5 (GTX640, currently installed, and remove these cards to get through install, so need to get this fixed)

Haven't dared install any of my other hardware yet!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy