Jump to content

[Guide] Intel HD2500 Full Resolution and QE/CI (10.8.3+)


  • Please log in to reply
72 replies to this topic

#61
freemannnn

freemannnn

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

here is my dsdt and ioreg

https://www.dropbox....qa9/Archive.zip

 

Type: GPU

  Bus: Built-In

  VRAM (Total): 64 MB of Shared System Memory

  Vendor: Intel (0x8086)

  Device ID: 0x0152

  Revision ID: 0x0009

  Kernel Extension Info: No Kext Loaded

  Displays:

Display:

  Resolution: 1920 x 1080

  Pixel Depth: 32-Bit Color (ARGB8888)

  Main Display: Yes

  Mirror: Off

  Online: Yes



#62
Lacedaemon

Lacedaemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Location:United States
  • Interests:Hackintosh, Android, Linux, Servers, Jailbreaking

can someone patch my dsdt if i uploaded it here?i have an i5 3470 with an asus P8B75-M LE mobo and i cant get hd2500 to worki tried every option with efi injection boot switches, vram size

If you ever get it to work, let me know, because I have the same CPU, and as you can see earlier in the thread, I was unsuccessful...

#63
freemannnn

freemannnn

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

i had tries so many hours trying with different parameters in chameleon to make my hd2500 work.

i want to inject platform id in dsdt but i dont know how to do it. i am reading manuals now and will try



#64
Dr. Hurt

Dr. Hurt

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,509 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

here is my dsdt and ioreg

https://www.dropbox....qa9/Archive.zip

 

Type: GPU

  Bus: Built-In

  VRAM (Total): 64 MB of Shared System Memory

  Vendor: Intel (0x8086)

  Device ID: 0x0152

  Revision ID: 0x0009

  Kernel Extension Info: No Kext Loaded

  Displays:

Display:

  Resolution: 1920 x 1080

  Pixel Depth: 32-Bit Color (ARGB8888)

  Main Display: Yes

  Mirror: Off

  Online: Yes

 

Give this a try. I can't promise it'll work though.. Sorry!!

Attached Files



#65
freemannnn

freemannnn

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

so i put your file you sent me in extra folder and tick "drop ssdt" in chameleon. right?



#66
Dr. Hurt

Dr. Hurt

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,509 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

so i put your file you sent me in extra folder and tick "drop ssdt" in chameleon. right?

 

Yes!

 

And remove any efi strings you're using.



#67
freemannnn

freemannnn

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

nothing changed guys. same board chess in top left screen or scrambled screen upon logon.

tried 32-64-96 memory

graphicsenabler=no

drop dsdt=ticked

 

now i am logged on with -x -F 

 

in about this mac i am gettings this...

Intel HD Graphics 4000 1024 MB graphics

 

Chipset Model: Intel HD Graphics 4000

  Type: GPU

  Bus: Built-In

  VRAM (Total): 1024 MB

  Vendor: Intel (0x8086)

  Device ID: 0x0152

  Revision ID: 0x0009

  Displays:

W2486:

  Resolution: 1920 x 1080 @ 59 Hz

  Pixel Depth: 32-Bit Color (ARGB8888)

  Main Display: Yes

  Mirror: Off

  Online: Yes

  Rotation: Supported



#68
Lacedaemon

Lacedaemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Location:United States
  • Interests:Hackintosh, Android, Linux, Servers, Jailbreaking

Yeah, it's really weird, when I boot with Clover in normal mode with no ig-platform injection (or any injection whatsoever), it will boot and login, but no QE/CI...



#69
freemannnn

freemannnn

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Yeah, it's really weird, when I boot with Clover in normal mode with no ig-platform injection (or any injection whatsoever), it will boot and login, but no QE/CI...

 

the same also for me. when no injection boots normally but no QE/CI



#70
Lacedaemon

Lacedaemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 72 posts
  • Gender:Male
  • Location:United States
  • Interests:Hackintosh, Android, Linux, Servers, Jailbreaking

the same also for me. when no injection boots normally but no QE/CI

What are you using? DVI or HDMI?

If DVI, maybe dual link is the problem for both of us?

#71
freemannnn

freemannnn

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Dvi. But tried also with hdmi

#72
cvt123

cvt123

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi.
Is this thread still live. I have a ga h77n wifi with a i3 3220. I would like to get qe/ci working as I have broken the PCI slot for my graphics card (don't ask)

Could anyone patch my dsdt?

#73
LEENO

LEENO

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

hello

i installed Niresh 10.9 with default settings on acer aspire v5 131.

On the first boot i hear sound but screen is black. Hdmi tv show screen half black and half white.

Video memory is 128mb, it is not editable in bios.

 

 

here are my peripherials:

VIDEO Intel HD Graphics 2500
LED LCD 11,6'
CPU Intel Celeron 1017U 1.60GHz Mobile DualCore (16 x 100)
Samsung 8 GB DDR3-1600 DDR3 SDRAM(11-11-11-28 @ 800 MHz) (10-10-10-27 @ 761 MHz)
Audio Realtek ALC269Intel® 7 Series Chipset Family SATA AHCI Controller
Samsung SSD 840 EVO 250Gb
Intel Panther Point PCH - USB 2.0 EHCI Controller #1 [C-1]







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy