Jump to content

GenericUSBXHCI USB 3.0 driver for OS X with source

xHC USB 3.0

  • Please log in to reply
814 replies to this topic

#801
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 8,186 posts
  • Gender:Male
  • Location:Brazil

This: https://github.com/R...s-multiplex.txt



#802
marmotta

marmotta

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

This: https://github.com/R...s-multiplex.txt


My chipset is z68 and usb is asm1042, this patch is useful?

#803
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 8,186 posts
  • Gender:Male
  • Location:Brazil

We need try. 

Keep in mind that any change we make is forever. If it goes wrong, we try something else.

 

Extract your DSDT, and made 2 copies, 1 for tests and another with the patches that worked.



#804
marmotta

marmotta

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

I give up! I updated the firmware with 131025 , i tryed all clover options.... no work! Usb controller is always present but the my usb3 dock is invisible at osx (with windows work) now not go anyway, usb port swap no longer work.... i tired....



#805
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,084 posts
  • Gender:Male
  • Location:The Streets

ASM1042 worked fine here on both of my Asus boards. When I had Yosemite on my Z68 I had it working with a DSDT edit and the Oyen Digital kext. The downside to using this is it is only good for USB storage. Also ASM1042 is unusable with El Capitan right now.

 

On my X79 I'm using GenericUSBXHCI for the front ports on my case. I've never been able to use the rear ports as they're hub-attached and cause all sorts of hangs and console spam when enabled (regardless of the kext used).



#806
marmotta

marmotta

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

ASM1042 worked fine here on both of my Asus boards. When I had Yosemite on my Z68 I had it working with a DSDT edit and the Oyen Digital kext. The downside to using this is it is only good for USB storage. Also ASM1042 is unusable with El Capitan right now.

 

On my X79 I'm using GenericUSBXHCI for the front ports on my case. I've never been able to use the rear ports as they're hub-attached and cause all sorts of hangs and console spam when enabled (regardless of the kext used).

 

I installed Oyen drivers but not find my asm1042 (normal is needed dsdt edit).... i have edited my dsdt with new "method" in rp02 and rp05 section but when i press return in clover screen the system go in kernel panic.... (acpi not found driver ecc....)



#807
Riley Freeman

Riley Freeman

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,084 posts
  • Gender:Male
  • Location:The Streets

If the DSDT edit isn't working for you, another option is to edit the Info.plist inside mXHCD.kext and remove both instances of IOPCIMatch. This will allow it to load for the ASM1042 without injecting a fake ID via DSDT.



#808
marmotta

marmotta

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

If the DSDT edit isn't working for you, another option is to edit the Info.plist inside mXHCD.kext and remove both instances of IOPCIMatch. This will allow it to load for the ASM1042 without injecting a fake ID via DSDT.

 

YES! Work! mXHCD work very good, no bootflag needed, no sleep problems and my usb dock is always see by osx! Thanks!



#809
tomatenaufdenaugen

tomatenaufdenaugen

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Anywhere else to get this kext?  SourceForge seems to be dead at the moment...



#810
Allan

Allan

    V.I.P. Member

  • Supervisors
  • 8,186 posts
  • Gender:Male
  • Location:Brazil

Anywhere else to get this kext?  SourceForge seems to be dead at the moment...

 

In Clover's (SourceForge) works great, but in HWMonitor and GenericUSBXHCI not...

See the report:

Attached File  Screen Shot 2015-07-17 at 3.48.02 PM.png   37.97KB   17 downloads



#811
tomatenaufdenaugen

tomatenaufdenaugen

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

SourceForge is back up, kext works great on my Shuttle, just by dropping it onto Kext Utility.  Thanks much!



#812
FusselFux

FusselFux

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts

Hardware: MacBookPro6.1

Sonnet USB3 ExpressCard|34

Software El Captain Public Beta 1

 

my PCI express-card was working with Yosemite.

 

Tested with El Captain. not working. at Systeminformation it was shown, but Driver Installed: No. At USB it was not shown.

 

Original Sonnet driver was at Yosemite only 480 Mbit at USB3 Drive. The GenericUSBXHCI_1.2.7_for_Yosemite_14A329r was at 5 Gbit

 

 

 

Typ: USB eXtensible-Host-Controller

  Treiber installiert: Nein

  MSI: Nein

  Bus: PCI

  Steckplatz: ExpressCard

  Hersteller-ID: 0x1033

  Geräte-ID: 0x0194

  Subsystem-Hersteller-ID: 0x16b8

  Subsystem-ID: 0x5701

  Versions-ID: 0x0003

  Link-Breite: x1

  Link-Geschwindigkeit: 2.5 GT/s

 

 

 

 

GenericUSBXHCI:

 

  Version: 1.2.7

  Zuletzt geändert: 26.07.15, 12:03

  Paket-ID: net.osx86.kexts.GenericUSBXHCI

  Geladen: Nein

  Erhalten von: Nicht signiert

  Art: Intel

  Architekturen: x86_64

  64-Bit (Intel): Ja

  Ort: /System/Library/Extensions/GenericUSBXHCI.kext

  Kext-Version: 1.2.7

  Ladbar: Nein

  Fehler bei der Unterschriftenvalidierung: Nicht signiert

  Abhängigkeiten: Erfüllt

  Signiert von: Nicht signiert


Edited by FusselFux, 26 July 2015 - 12:44 PM.


#813
ndx2014

ndx2014

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
  • Gender:Male

managed it to get everything working, but after installing dp4 (i got error: "could not be installed"..) it seems to boot but the usb ports dont work so i cant use my keyboard+mouse to login to the 10.11 partition..



#814
TheRacerMaster

TheRacerMaster

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 307 posts
  • Gender:Male

UD5H has native USB3, why are you using GenericUSBXHCI with that board? In El Capitan you don't even need the muxing DSDT patches anymore.



#815
EnzoFX

EnzoFX

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 285 posts

Z77X-UD3H here,

 

Just got clover going with this  new board. I noticed that after sleep, while kb/mouse does wake the computer, it doesn't wake the display. I have to press power button for it to turn on. Also, kb/mouse (maybe other devices as well) aren't responsive for about a good minute until after it wakes. 

 

Can someone point me in the right direction. I'm also new to Clover and it's expansive feature set. Always used Chameleon before with a  no fuss board (With appropriate dsdt edits) that got me from like SL to Mavericks.

 

Edit: Ok so after disabling CPU PLL overvoltage in BIOS, the display wakes as it should with a kb/mouse press when waking from sleep. (BTW is Clover the reason it takes like 10+ extra seconds for the computer to shutdown after the display goes blank? that's on top of what I think is already another 10 seconds from log-out to display sleep, grr)







Also tagged with one or more of these keywords: xHC, USB 3.0


2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy