Jump to content

Asus A55VD - Se para en el arranque tras la instalacion

- - - - -

  • Please log in to reply
107 replies to this topic

#41
speculumrotae

speculumrotae

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Yo le puse esa también, el bluetooth no va.
Por qué me obligó en la ssd a crear guid, en el disco duro normal me dejó utilizar mbr para instalar osx?

SI le dejo mbr me dice que en la partición no se puede instalar aunque sea hfs+

#42
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Hola de nuevo.
Os cuento. Ayer despues de tenerlo todo casi ok, Arrancaba desde HD , reconocía la HD4000, etc, y me dió por hacer algo que creo que fué borrar otra particion para pasarla a tipo MAC desde la utilidad de discos, y al arrancar me decía can´t find /macth_kernel.

Probé a activar la particion de OS X pero nada. Al final opte por borrar todo y volver a empezar.

Todo desde cero (creo que van ya unas 30 veces), y al final consigo hoy de nuevo un sistema estable.

Hoy lo estoy personalizando, y pienso que debería hacer una copia del sistema con Time Miachine, le digo que use una de las particiones libres que tengo, y me dice que la tengo que borrar. No lo relacioné con lo de ayer, pero me confirmó que no se puede borrar otras particiones, ya que al arrancar me ha vuelto a dar el mismo mensaje y no hay manera de que encuentre el kernel correcto.

Alguna idea para no tener que empezar de nuevo?

Gracias

Añado: Arrancando desde USB , ha arrancado el OS X del HD, he ejecutado el chameleon wizard y he instalado la ultima version (la r2152).

Reinicio y sale el menu textual del chameleon 2152 (no grafico) y al elegir la particion OS X me dice lo mismo : can´t find /macth_kernel.

PD2 : el el directorio raiz de la particion de OS X , hay un archivo oculto que se llama mach_kernel de 8,2 mb

#43
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
mach_kernel / o kernel=mach_kernel

#44
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
can´t find /mach_kernel

y ahi se queda.

Lo dice justo al principio unas 4 lineas debajo de las versiones de Darwin y Chameleon

#45
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
tienes la carpeta Extra com org.chameleon.boot.plis and SMBIOS en la raiz de tu disco?? esta configurado tu boot.plist? has probado las dos flags que te he passado?

#46
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
tienes la carpeta Extra com org.chameleon.boot.plis and SMBIOS en la raiz de tu disco?? SI

esta configurado tu boot.plist? si te refieres a com.chameleon.boot.list , SI, ha estado funcionando hasta que borré la cuarta particion como MAC. si no es ese archivo no se donde está.

has probado las dos flags que te he passado? en el com.chameleon.boot.list hay una entrada de kernel=mach_kernel, creada por chameleon wizard , ¿te refieres a eso?

#47
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

si tienes esto

com.chameleon.boot.list pues esta mal, el boot.plist tienes que estar

así org.chameleon.boot.plist o no te funciona, intenta dar el boot com el USBInstaller si no va mandame tu Extra folder



#48
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
No, es org.chameleon.boot.plist , es que lo escribí de memoria porque lo tenia apagado.

te mando la carpeta

Attached Files



#49
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
en ML todos los kexts deven estar S/L/E y no in E/Extensions, copia todo para S/L/E y borra de E/E , copia el kernel y pones en Extra, mira tu bios si sata esta en AHCI Mode, HPET EN 64 bits, boot com -f -v

#50
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Solucionado: era problema de reinstalar el chameleon. Lo que ocurre es que el chameleon no me lo instala bien desde el wizard, dice "instalado" pero no lo deja bien (al menos a mi), he instalado de nuevo el r2140 desde el paquete, y ya ha vuelto a arrancar.

Parece ser que en mi disco duro que es 4K (el que da problemas boot0=error) si se borra una particion hay que volver reinstalar chameleon, supongo para actuvar la particion correcta de nuevo .

Gracias.


SIGUIENTE RETO: ARRANQUE DUAL CON WINDOWS

#51
firol

firol

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Paciencia que poco a poco lo vas consiguiendo. Yo estoy de viaje y tengo mono de seguir experimentando y perfeccionar el hackintosh, pero no me traje el portatil, cuando vuelva supongo que me habrá llegado la tarjeta wifi y con la ayuda del foro podre afinar lo que me falta, sobre todo el tema del reposo y el arranque dual.

Yo tengo kext en Extra/Extensions y en principio no tengo problemas, aunque probare a moverlos a s/l/e para ver si el tema del reposo se arregla.

@ifire sabes cual puede ser la solucion a lo del reposo? Cuando entra en reposo y quiero salir, el portatil no reacciona y la pantalla sigue en negro teniendo que reiniciar. Probe a meter en extra y s/l/e (alternativamente y juntos) el kext de sleeenabler que speculum me paso, pero nada. Tiene que ser algun problema de powermanagement, pero no tengo ni idea, como estoy de viaje no puedo subir mis carpetas ni hacer capturas de pantalla.

#52
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

sleep:Proper combination for sleep is:


1) patched HPET, TIMR, RTC, PIC sections

2) patched EHCI/UHCI sections

3) patched AppleLPC kext to match chipset id

4) removed NullCPUPowerManagement,

5) patched AppleRTC kext to solve CMOS reset after sleep


#53
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
CONSEGUIDO. Sorprendentemente ha funcionado a la primera el arranque dual.(digo sorprendentemente porque a mi nada me sale a la primera)

He instalado windows (una version antigua porque las nuevasdicen que no se pueden instalar en mbr en sistemas uefi), y después he booteado desde usb y he elegido arranque OS x . Una vez en mac he reinstalado de nuevo el chameleon y voliá.

Arranque dual funcionando.


PRÓXIMO RETO : AFINAR OS X

Preguntas :

1 -Sabéis como puedo verificar que este funcionando bien cosas internas como ,la gestion de velocidad del procesador, gestion de temperatura / ventiladores, y demás que no son visibles a simple vista?

2 - Hay algún método para hacer una imagen del OS X, restaurable en caso de desastre, que no ocupe el espacio total de la particion , sino solo el espacio utilizado?

#54
firol

firol

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
Me alegro mucho que hayas resuelto ya casi todo, tienes un Macbook Pro a todos los efectos y a 1/3 de su precio.

Sobre comprobar rendimiento y tal, si le das al icono de la manzana arriba a la izquierda, acerca del equipo, informacion del sistema, veras bastantes cosas. En la carpeta extra que te paso speculum, dentro de extensions, hay una aplicacion que creo recordar se llama CPUMonitor (icono de un termometro), si la ejecutas ahi tienes temperaturas y rpm de los ventiladores.

Sobre la copia de seguridad, yo probaria a hacerla con time machine en un hd externo, a ver si no te da errores raros. Otra opcion es usar Carbon copy cloner, aunque no se si te obliga a copiar toda la particion.

@ifire gracias por lo del reposo. Entiendo que debo ir probando en el orden que pusiste hasta dar con la solucion.

#55
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Acabo de ampliar la memoria del portatil a 8 Gb.

El primer arranque me dió un Kenel Panic. Arranqué con -x -f y arrancó bien. Despues con arranque normal me ha arrancado bien.

En informacion del sistema reconoce los 8 Gb, y es mas automaticamente la ha puesto a la tarjeta de video 512 Mb dedicados.

El tema está en que en arranque gráfico de chameleon en la esquina superior izquierda, me sale como memoria 3130 mb aprox.

Y en el monitor de actividad de Mac tambien me sale 3.13 Gb.

No sé si el sistema lo está usando realmente.

Hay que modificar algo ?

#56
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Varios temas

1 - Ninguna idea sobre el tema de la memoria que puse anteriormente?

2 - Aparte, en el arranque da algunos fallos que no me da tiempo a leer/recordar ni escribir, no son fallos criticos pues arranca bien, pero me gustaría revisarlos, ¿hay algon log del arranque con los errores donde mirarlo?

3 - Cuando llevo tiempo usandolo se vuelve muy lento, tarda muuucho en abrir las aplicaciones, sabeis de que puede ser?

4 - @ifire gracias por lo del reposo. Entiendo que debo ir probando en el orden que pusiste hasta dar con la solucion

Firol, respecto a eso, has avanzado algo?

5 - HAs conseguido arrancar desde HD? Un consejo de Novato: ten en cuenta que si arrancas dede USB, aunque despues le digas que arranque del HD, carga los Kext de la carpeta SLE del USB, no del HD, al menos a mí. Fijate en modo -v cuando carga todos los kext como pone algo así como "read HFS flle disk(1,1)....bla,bla, ... nombre del kext"

Si te das cuenta el disco 1,1 es el USB, cuando consigues arrancar desde HD dice lo mismo pero poniendo disk(0,1)
Eso me dió muchos quebraderos de cabeza, hasta que me di cuenta que lo que modificaba en el SLE del HD no servía ya que leía los de USB.

Que me corrija iFire si me equivoco.

#57
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,433 posts
  • Gender:Male
  • Location:Tru, Venezuela
Ampliación o disminución de memoria ram implica OBLIGATORIAMENTE volver a extraer la DSDT y SSDT(s) y aplicar los cambios en:

1) Principalmente en los famosos accesos a memoria de los dispositivos, normalmente de este estilo: OperationRegion (BIOS, SystemMemory, 0xBLABLABLA, 0xBLA)

2) Con respecto a la(s) SSDT(s) aplicar los cambios en la tabla de PowerManagement (CpuPm), que es la encargada de los accesos a memoria del procesador. Saludos.

#58
mahumi

mahumi

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
Vamos que me resulta mas facil reinstalar el sistema de nuevo... porque de lo que me comentas, ni idea.

Gracias de todas formas Juanerson.

Por otra parte y siguendo en mi afan por afinar el OS X, he encontrado "System Info" en este foro y me gustaría saber si es fiable, ya que me salen algunos kext que yo no tengo instalados en S L E.

Os pongo unas capturas de pantalla


No tengo instalados estos kext :

AppleUSBComposite.kext
AppleUSBHub.kext
AppleUSBEHCI.kext


Me recomendais instalarlos ?

Attached Files



#59
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
estos kexts ya los tienes en el Sistema, son pluguins de IOUSBFamily.kext

#60
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,433 posts
  • Gender:Male
  • Location:Tru, Venezuela

Vamos que me resulta mas facil reinstalar el sistema de nuevo... porque de lo que me comentas, ni idea.

Pero de qué hablas? Lo de la nueva DSDT con memoria ampliada NO tiene nada que ver con reinstalar el sistema, en lo absoluto. Entiende que es OBLIGATORIO.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy