Jump to content

gtx 570 on SL 10.6


  • Please log in to reply
19 replies to this topic

#1
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
can it be done? or is the gtx 460 the best that can be used on the nvidia side.

#2
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
Yes, but it is not worth the headache. Do you really need to be on SL? Do you still use Power PC Apps?

#3
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
Heck yeah man i gotta have StarCraft 1 and other early blizzard titles and fallout 1 & 2. :P How bad of headache is it? does it require code/text editing? There was/isap ossiblity for me to get a used GTX 570 for really cheap and that made me curious.

#4
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,901 posts
  • Gender:Male
I'm interested in knowing this too: i have a HTPC that is limited to Snow Leopard, since it's powered by an AMD CPU, and i want to get the best possible graphics for gaming purposes. Until yesterday, i thought that the ceiling was the GTX 285, then i came across this topic and others and realized there was also same success with Fermi cards.

#5
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
To start you need to install the Retail Nvidia Drivers for 10.6.8. It has been a while since I looked into this but I know a handful of people were able to get it to work.

#6
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
Any one else know how hard or what is envolved with gettign a 570 towork on SL, an already installed SL?

#7
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male
Did you install the retail drivers?

#8
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
I don't own the card. i was thinking of purchasing one if i could get it for cheap. I assume you download sais drivers from Nvidia's web site? Also would i have to edit my "plist" first? before installing the 570? or would that matter? or am even making any sense?

I i have read cases where upgrading wasn't straight forward and things didnt' work right when the hardware was added/installed.

Edited by cdoublejj, 08 March 2013 - 01:32 AM.


#9
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,991 posts
  • Gender:Male

I don't own the card. i was thinking of purchasing one if i could get it for cheap. I assume you download sais drivers from Nvidia's web site? Also would i have to edit my "plist" first? before installing the 570? or would that matter? or am even making any sense?

I i have read cases where upgrading wasn't straight forward and things didnt' work right when the hardware was added/installed.


Why not just get a AMD 6870? Works OOB in 10.6.8 and will be great for gaming in SL.

#10
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
Well i just got the 570 in a trade. my main reason for gettign it is becasue the osx machine also runs linux and Nvidia drivers are superior on linux.

#11
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
well. I'm abotu to get all my parts with in the next week.... I think. since I no longer have the GTS250 i was using, I guess i'll just pop the card in and see what happens when i try to boot SL.

#12
rominator

rominator

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 141 posts
There are no drivers whatsoever in SL.

Even using the 10.6.8 Quadro 4000 drivers the device id is not present.

It might be possible to find the GTX470 id and replace it with 570 but I honestly don't know of anyone who has done this and had it work

It would be in the NVDAGF100Hal.kext in the info plist if it is anywhere

good luck

#13
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
Interesting becasue if one googles gtx 570 and snow leopard, this kind of information just doesn't come up. it wouldbe nice if this kind of infomration would show up. that said i'm getitng kernel panics at boot right when it's doing the nv enabler rom dector stuff. I also have some other REALYL REALLY weird stuff going on that i think i need to sort out first but, for the most part this is frustrating becasue i REALLY like having the power PC capability for older apps and games and this was the only decent GPU i could get witho ut spending money.

I am curious if an HD6850 with work with snow leopard?

EDIT: I also if some could give me a run down on WINE for mac. I know most of the time people use wine wrappers instead on an instaleld program like on linux. I understand every one runs the windows version of things with instead of the power PC versions.

#14
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,901 posts
  • Gender:Male
Well, try to add the device ID! Let's see what happens: you could be the very first to enable it for Snow Leopard. Don't you like the prospect of being a pioneer?

All the best!

#15
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
I do i just don't how to add the device ID or where to ad it to, let laone with out being to boot into the os. How ever i suspect that i would use the OS instilation disc to edit in the device ID?

#16
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,901 posts
  • Gender:Male
Yeah!

Boot with -s

Then mount -uw /

Then type:

nano /Volumes/*insert here the name of your HD*/System/Library/Extensions/NVDAGF100Hal.kext/Contents/Info.plist (EDIT: no, i'm not sure it's there anymore, see below)

Add the device ID to the correct place (which i don't know what it is) and exit.

All the best!

P.S.: After taking a look at NVDAGF100Hal.kext, i'm not sure anymore it's where you'll add the deviceID of your card, because i didn't find the IOPCIMatch key there: you'll really have to research it better. But the method (boot -s etc) stays valid. Good luck.

#17
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
Maybe i should mention this is an Iatkos install that was setup for a GTS250. I then traded my GTS250 (and then some) for a GTX570 (who would pass that up?). I assume when you say -s this is with the install CD? I'm fairly sure there is good chance i might kenerl panic before hand due to possible bug.glitch/HW failure i ahvne't yet nailed down (could be a false positive)

#18
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
Well it's kernel panicing like mad. even with "-s" the furthest I iv'e ever gotten with maxmem and cpu= is to the video rom detection.

I'm gonan try and clean install and if that doens't get me any where i'll either give up or install Lion. (the wine will proably suck ass compared to running stuff on rossetta).

#19
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
how do i reacherch where to put the hardware ID? google where the IOPCIMatch key is?

EDIT: lookign at this stuff,

http://legacy.tonyma...=52086&p=327782

http://www.osx86.net...or-message.html

http://sourceforge.n...s/cuda-z/files/

http://www.nvidia.co....45-driver.html

http://www.insanelym...rce-500-series/

http://www.osx86.net...l-10-6-8-a.html

EDIT: even the SL install disc that worked fine before kernel panics, even with -s. I wish some famous OS X hacker would address the issue of gtx 500 series in SL. looks like i'm upgrading and going ot have to use play on mac :( so sad.

#20
cdoublejj

cdoublejj

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
  • Gender:Male
  • Location:USA, MO
is the device ID all ways in plist for all kexts? I was looking/trying to add the device ID to the quadro 400 drivers. I do not see a IOPCIMATCH key. Also i can't find a folder called "extra" does it go in root? i i ask i may have deleted it but, it only had 3 ATI kexts in it. KEXTs i do not need. i'm betting if it was the "extra" folder i wouldn't even be able to boot.

EDIT: from what i can guess the NVenabler is causing it not boot because it can't handle the device and vendor ID. I installed a different NVenabler, i can tell it recognizes the ID differently but, it still freaks out and locks up.

EDIT: I'm getting a GTX 480.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy