Jump to content

[Guide] Lenovo B570 with Mountain Lion

- - - - - b570 10.8 mountain lion

  • Please log in to reply
31 replies to this topic

#21
dmarkey

dmarkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
I'm getting bad artefacts with my HD3000 :(

#22
Dayson

Dayson

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

I have successfully followed this guide step by step and I've got Mountain Lion installed on my B570e, BUT the following still does NOT work:

 

  1. Wireless Network Card not detected (maybe I don't have a Realtek Wireless Card?)
  2. Trackpad not working (solved using kexts from - http://www.osx86.net...2_trackpad.html but no multi-touch support). For multi-touch support, the Elan Touchpad drivers from here work well - http://forum.osxlati...river-mac-os-x/

I even tried the steps as suggested by nicololo, but no luck. (I have a Lenovo b570e and maybe the trackpad is slightly different - it has the ELAN PS/2 Port Smart-Pad)

 

Could someone with experience on this issue provide me the necessary kexts + any additional steps to get this working? I've tried searching the entire internet, but no luck on this.



#23
RichP

RichP

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Hi - Let me add my thanks for producing such a comprehensive and clearly – written guide.

Sadly, I've learned that my B570 won't run ML because it has the Pentium B940 CPU.  I can get it to boot to safe mode (but no audio).  

 

UPDATE: Swapped the CPU for the one in the OP and it's all working.



#24
data14

data14

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

I just updated through software update from 10.8.3 to 10.8.4. I had to replace AppleHDA. Everything works.



#25
bajabronco

bajabronco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts

I did the 10.8.4 update and found that my sound and wifi didn't work, I just used the backed up 10.8.3 HD audio kext and sound worked again, but installing the previos i080211family would show networks but would not allow me to connect.  to get wifi working again I needed to use a new atheros 9285 kext to get it working - I used the following two kexts from here to fix the problem airport atheros 40 & ioath3kfirmware.

 

http://www.osx86.net...for_10.8.4.html

 



#26
inter8alia

inter8alia

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Dear experts! Please, who can explain the nature of artefacts on the screen that appear from time to time despite everything. And what can be the reason for hanging/freezing the system randomly (once/twice a day/ in two days/etc). Overheating? But thermal paste on CPU and VIDEOCARD was replaced and the CPU temp ranges 45-69 degrees (depending on workload). OSX was re-installed for several times, all updates were applied (including chamelion and fake smc updates, etc), yet the problem with system hanging remained. 

With Ububtu the same laptop works perfectly - neither artefacts nor hangs/freeze.

Thank you!

 

P.S. Hanging of the system is the major problem for me and I hope sombody hint me the reason for it.

Lenovo b570/HD 3000/8 RAM/ OSX 10.8.3. 



#27
amynvirani

amynvirani

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hello everyone.

I am trying to install MAC OS Mountain Lion on my Lenovo B570e. The specs are:

Core i5 2450m

4gb ram

Intel HD Graphics 3000

 

I am using iAtkos ML2 and for installing I am able to reach the installer screen by using -x command.

Can anyone please tell which options to select in  the custom options? I have tried a few but after installation when i boot into MAC with -x -v it just freezes at some point.

 

UPDATE:

I installed mac os 10.8.2 using iAtkosML2 and then updated to 10.8.4 successfully. the only problem i am facing is that wireless is not working. if i keep the wireless turned on in bios, mac doesnt boot. when i turn it off it does boot properly. Another problem i am facing is that the trackpad is working but there is no scroll no multi touch.
wireless card: Qualcomm Atheros AR9285 Wireless Network Adapter
trackpad: elan Lenovo pointing device
 
also if anyone could tell me how to test if the power management is working properly or not.
 
Thank you.


#28
data14

data14

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

I do not know if you have found answer to your problems but:

wireless: you have to add your vendor and device id to the IO80211 kext plist

for touchpad try this: http://forum.osxlati...river-mac-os-x/



#29
kordon

kordon

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

Successfully installed ML2 on my Lenovo too(i3 CPU)

But I have still some problems.

For example the touchpad. It doesn't support Multitouch for some reason. I had Lion before, so I know that Multitouch has to work normally.

The same goes to the audio.

 

I read that here that I should easily just take the kexts which were given in iAtkos L2 (which I had installed) but surprisely I cannot open the the content of the image.

When I'm mounting the .dmg file I can see iAtkos L2 on my desktop and normally I right click on that and show the package content.

But there is no option. There is also another weird thing, when I double click on L2, I see just an empty window with the iAtkos L2 background, but nothing else to click.

 

How can I extract the kext from there, or could somebody upload them for me?

I would like the AppleHDA, VoodoHDA and everything what is connected to the mouse and keyboard :D

 

edit: Audio works now with the latest Voodoo-driver. Tried also the ps2-Kexts from iAtkos L2 but still no MultiTouch-Support. OS X doesn't find ApplesSynapticsTrackpad, so it says ^^



#30
hypocris

hypocris

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

thank you! your AppleHDA helps to make my internal mic working! just view layout id in your DSDT and change mine to yours. 



#31
yoyo58

yoyo58

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

deleted


Edited by yoyo58, 01 February 2014 - 11:45 PM.


#32
yoyo58

yoyo58

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

deleted


Edited by yoyo58, 01 February 2014 - 11:44 PM.






Also tagged with one or more of these keywords: b570, 10.8, mountain lion


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy