Jump to content

PCI 8139 Nic


  • Please log in to reply
12 replies to this topic

#1
mediamac

mediamac

    Mediarays

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
  • Location:INDIA
  • Interests:Hackintoshing
Hi,
I have tried many kexts like PcgenRTL8139 and also other 8139 kexts.My NIc is Dlink 538 TX and it has Realtek 8139 chipset.It loses the connection after few hours.I tried all solution none works.
Let me know how you fixed this issue.
Thanks

#2
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Bangladesh
Try my one if it works...

Attached Files



#3
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,203 posts
  • Gender:Male
add also:


<key>EthernetBuiltIn</key>
<string>Yes</string>

in org.chameleon.Boot.plist

#4
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
I have same NIC and the official Realtek driver works great. I use 2.0.6 which is made for 10.7+, but am sure they have a SL version too.

#5
mediamac

mediamac

    Mediarays

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
  • Location:INDIA
  • Interests:Hackintoshing

Try my one if it works...

When i used your Kext the card is not recognised.

add also:


<key>EthernetBuiltIn</key>
<string>Yes</string>

in org.chameleon.Boot.plist

I have already added this part.

I have same NIC and the official Realtek driver works great. I use 2.0.6 which is made for 10.7+, but am sure they have a SL version too.

Can you post the links please to the official drivers ?
Many thanks for your replies.

#6
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Bangladesh
Sorry i haven't note, you need for osx 10.6.x. This one for SnowLeopard.

Attached File  Realtec_8111D_3264.zip   1.03MB   2 downloads

Hope it will work.

#7
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Sry, I actually have different NIC, my mistake. @plsh2me version may work, if not try here http://www.osx86.net...ek_rtl8139.html

#8
mediamac

mediamac

    Mediarays

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
  • Location:INDIA
  • Interests:Hackintoshing

Sorry i haven't note, you need for osx 10.6.x. This one for SnowLeopard.

Attached File  Realtec_8111D_3264.zip   1.03MB   2 downloads

Hope it will work.

Hi,
Thanks for your effort.I am typing with your kext installed.Its slow and also losing connections frequently.

Sry, I actually have different NIC, my mistake. @plsh2me version may work, if not try here http://www.osx86.net...ek_rtl8139.html

Tried this same disconnection problem :(

#9
plsh2me

plsh2me

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Bangladesh
If you yet not tried official release then try it - http://www.realtek.c...3&GetDown=false .

And if not work you should go for manual config. -

Systemconfiguration -> Network -> Ethernet -> more options -> Hardware:


Configuration: manual


Speed: 10baseT/UTP


Duplex: Fullduplex


MTU: Standard (1500)



#10
mediamac

mediamac

    Mediarays

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
  • Location:INDIA
  • Interests:Hackintoshing
Actually you have specified download link for PCI Express whereas my network card is PCI.Will there be any difference ? Also the download links for mac is not working.All the links under "MacOS 10.6 on Intel-based Mac computer".If you got a copy please attach it
Thank you

#11
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Their links never work. They do work, but are so slow that computer thinks access is denied. Which boggles the mind since they make NIC's and have the worst servers in the world. Keep trying a million times and eventually the download will work. Only native kexts are for very only OSX though and probably not 64bit

#12
mediamac

mediamac

    Mediarays

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
  • Location:INDIA
  • Interests:Hackintoshing

Their links never work. They do work, but are so slow that computer thinks access is denied. Which boggles the mind since they make NIC's and have the worst servers in the world. Keep trying a million times and eventually the download will work. Only native kexts are for very only OSX though and probably not 64bit

Yes i experienced a lot of time and frustrated.Anyway i will try to download and post the results.
Thanks

#13
mediamac

mediamac

    Mediarays

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
  • Location:INDIA
  • Interests:Hackintoshing
This Realtek 8139 card seems it cannot find a fully working kext (atleast for me) so i ordered a Netgear GA311 as suggested by verdant.
Thanks all





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy