Jump to content

open safari at startup (starts minimised)[Resolved]


  • Please log in to reply
5 replies to this topic

#1
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts
I have this problem on my netbook running Snow Leopard and my pc running Lion and Mountain lion.
Is this normal? something that only affects hacks? or does this happens on real macs too?
I know it's not a major issue and I've lived with it for years now but I was just wondering if there's a fix.
Mike

#2
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
It's handy feature designed to save you embarrassment if other people are around and Safari opening to the porn you were on last time you were online. :) JK. Mine doesn't do that, check ~/Library/Preferences in safari's plist, or the reopen all windows when opening app in system preferences/general or the reopen windows when logging in option (not sure if you meant at OSX start up or just Safari start)

#3
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
Go to System Preferences > users > select your account > Login items, if Safari is there, then select it and press the "minus" bottom at the bottom of the list.

#4
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts
Well safaris plist didn't give me any clues, re-opening windows when logging on worked but re-opens the last tabs I had open not my home tabs, I could not find the option referred to in

system preferences/general.


Going to

System Preferences > users > select [font=inherit !important][font=inherit !important]your [/font][font=inherit !important]account[/font][/font] > Login items[font=Verdana, Geneva, sans-serif]

, if Safari is there, then select it and press the "minus" bottom at the bottom of the list just stopped it loading all together as I expected.

[/font]

[font=Verdana, Geneva, sans-serif]

I'm not worried Chrome works fine.

[/font]

[font=Verdana, Geneva, sans-serif]

Mike

[/font]


#5
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Wait, Safari was in your login items, on purpose? So you want Safari to launch on login, but in a window and not minimized? I've never had any desire to have safari as a login item, but do have a Safari launch app/script I wrote a maybe a year ago that would work perfectly if that is what your trying to do I'd just got to dig it up real quick.

If you want Safari to launch in window, you can use this in start folder. It is just an apple script wrapped as an .app that will always launch Safari in a new window, even if safari's already open , bypassing normal tabbed behavior. Enable access for assistive devices in accessibility prefpane.

Attached Files



#6
Crabhunter

Crabhunter

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 257 posts
Thanks for your help.
Works like a charm on my Snow Leopard netbook, I'll try it on my Mountain Lion pc tonight.
I see no reason why it won't work on that as well.
Mike

Working on my ML pc as well :)

Edited by Crabhunter, 31 August 2012 - 05:37 PM.






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy