Jump to content

need help booting mountain lion installation on my laptoplaptop


  • Please log in to reply
81 replies to this topic

#1
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
hello there
thank you for giving me the oppertunity for writing this thread
anyway I have this modern laptop from samsung model is 300e4a-s0esa
core i5-2450m with 6gb of ram and nvidia optimus (intel 3000 + 520mx)
so far I was not able to boot my freaking system via the usb flash disk and I tried at least three ways so far but only one seems to work but I don't want to use it cause I need to find the problem with my method
I tried the method for the vanilla mac os x mountain lion and I did all the neccessory steps but it seems that my system does not see the bootable usb stick (I tried guid partition type but no luck strange even though my system is uefi compilant and I did set the ahci to manually enabled but I think I don't have legacy usb support)
I am now trying to make it mbr and redo the hole thing
I am doing this on a vmware image of lion 10.7.4 with a purchaced copy of the mac os x mountain lion app
any way I hope I can really boot to the installation this way
note : I selected smbios of the 9.1 mac book pro once and the other time I selected 8.3 mac book pro
I ma goin to keep this post alive until I completely reach the desktop of lion

ps: I really don't need to say this but the only working way for me was a tonymac with a cold boot  but I ma not happy with it and it catches my systems as a mac book pro 8.1 but I am discarding this way of use

if any one have an idea about laptop support files to boot my installation please tell me !!!

sorry for my newbishness and thanks in advance

#2
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,062 posts
  • Gender:Male
Specs:

Samsung 300E4A-S0ESA

i5-2450m

6 GB of Ram

Intel 3000

Nvidia 520MX


Guide:


Use the following boot flag and report back with a

picture of what is no the screen:

-v

Also what do you mean that your computer does not see the flash drive? Are you saying that in the laptop BIOS Boot menu it does not appear?

#3
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
i don't have a bios menu to check for boot sequence
i only did put the usb-hdd option at the top then cd then sata hdd
and i do mean that bios skips the usb flash (guid partitioned) and boots directly from sata hdd

i am planing on installing the ML on a 32gb usb san disk cruz blade

thanks for your help i will report back soon i hope

#4
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
sorry for my bad expression
what I meant was that I did change the boot sequence from the bios itself not from the boot menu because I don't have one
any way I managed to boot up my usb flash drive
the problem was that no one told me that it has to be mbr partitioned okay
but I had a panic but I don't know what it is
I took a picture of it and I will attach

Attached Files



#5
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,062 posts
  • Gender:Male
Ok, now I understand.

#6
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
thank you for understanding
do you have ann idea about that panic code in pictures
its getting late already here at my country so I will countinue in. at 12gmt

#7
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
any one knows how to get out of that panic code !!

#8
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
any body help me if you can please !!!

#9
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
try this boot flag: -f -v -x GraphicsEnabler=No busratio=25 npci=0x2000 and if no boot post your Extra.

#10
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
ok I will try to do that


#11
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,753 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

try to use appleacpiplatform.kext from lion.

in the photos, is in the error

or try also use this one

http://netkas.org/?p=1072

good hack

#12
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
thanks every one for your feedback
thanks ifire for pointing out the extra folder
but anyway i was experimenting with the installation methods soo deep that i put alot of kexts in my installation folder
now i only did put the macbook pro 8.3 smbios.plist (only modified the cpu max speed to 3100 and the memory to ddr3 1333mhz) file in my extra folder and the themes folder created by the chameleon wizard
and vioalla i booted into the installation and i saw the new apple (ooh yeah finally) but i got stuck on the welcome screen because there is no KEYBOARD OR MOUSE support for my laptop (mouse is ps2 elan tech and the keyboard is a generic arabic enabled with functions keyboard)
what should i do now (is there any keyboard or mouse kext or something) ??

artur-pc : thanks for the heads up but i need to know what does this appleacpiplatform.kext do ?? should i put it even if i had a successful boot ??

appreciate all the possible help guys

#13
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
nevermind everyone about the mouse keyboard problem cause I used apple ps2 kexts
and I booted into the installation successfully but before the apple logo I had two lines says that there was some problems during boot and there is a pause for 5 seconds then apple logo and the system boots
when I changed to verbose mode at first it says dsdt.aml not found and too much lines afterwards of kexts . is this okay ??
anyway I installed the mac os x mountain lion on my 32gb usb flash disk guid formatted and the installation completed successfully
i rebooted my system and then I got another panic twice !!!
what should I do help me please !!
I will attach the picture of the panic

Attached Files



#14
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
OK , put this kexts in your Extra/Extensions of USBInstaller and boot with -f -v


Attached File  PS2.zip   272.35KB   79 downloads

#15
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
thanks ifire for attaching the file but I already posted about the mouse keyboard problem
however do you have an idea about that second panic I got
do I need to change something or to rick something in the chameleon wizard perhaps
please respond quickly if you can .

#16
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

OK , put this kexts in your Extra/Extensions of USBInstaller and boot with -f -v

:wink2:



#17
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
thanks for replying so soon BUT :
where is the kext man !!! Is it the same as the above one ??
again thanks ifire i will confirm its working when you attach

i am sorry ifire but it seems you have put all the needed kexts in one zip file
I am gratful to you
i will try them now

#18
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

the needed kexts in one zip file, man this is what I post for yours problems ,

DOWNLOAD THE PS2.zip

files an

put this kexts in your Extra/Extensions of USBInstaller and boot with -f -v, this is very

difficult for you understand?????


Attached File  PS2.zip   272.24KB   25 downloads

#19
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
ifire : thank you for your support i did put your files in my extra extention folder (only just them)
i was able to boot with no panics
but now i am stuck at the loading screen
the circle under the apple keeps spinning and spinning for 15 minutes and nothig happens
this is where am i right now in verbose mode
it says waiting for apple smc or something like that
help please !!

Attached Files



#20
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
try this boot flag again:

-f -v -x GraphicsEnabler=No busratio=25 npci=0x2000



post your folder EXTRA!!!!!!!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy