Jump to content

Contacts and Reminders Crash

contacts reminders crash

  • Please log in to reply
9 replies to this topic

#1
hase091

hase091

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Florence
Hi all ^_^
i've an HP DV6990el (dv6000 series) and i've a problem with the apps Contacts and Reminders (the other works perfectly).

When i try to open contacts, it say this error:
---

Crashes Since Last Report: 570
Per-App Crashes Since Last Report: 6
Anonymous UUID: ED0DD9C1-9CB7-4A46-8E1F-C89CDD2C33B5

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Symbol not found: _OBJC_CLASS_$_CLGeocoder
Referenced from: /System/Library/PrivateFrameworks/ShareKit.framework/Versions/A/ShareKit
Expected in: /System/Library/Frameworks/CoreLocation.framework/Versions/A/CoreLocation
in /System/Library/PrivateFrameworks/ShareKit.framework/Versions/A/ShareKit
---

When i try to open reminders, it say this:
---

Process: Reminders [574]
Path: /Applications/Reminders.app/Contents/MacOS/Reminders
Identifier: com.apple.reminders
Version: 1.0 (70)
Build Info: Reminders-70000000000000~14
Code Type: X86-64 (Native)
Parent Process: launchd [148]
User ID: 503

Date/Time: 2012-07-29 09:18:46.256 +0200
OS Version: Mac OS X 10.8 (12A269)
Report Version: 10

Crashes Since Last Report: 583
Per-App Crashes Since Last Report: 4
Anonymous UUID: ED0DD9C1-9CB7-4A46-8E1F-C89CDD2C33B5

Crashed Thread: 0

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
Symbol not found: _OBJC_CLASS_$_CLGeocoder
Referenced from: /Applications/Reminders.app/Contents/MacOS/Reminders
Expected in: /System/Library/Frameworks/CoreLocation.framework/Versions/A/CoreLocation
in /Applications/Reminders.app/Contents/MacOS/Reminders
---

How can i find "_OBJC_CLASS_$_CLGeocoder"?
And where do i put it? :wallbash:

Thanks alot ^^

#2
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Mail, Reminders, Notes, Facetime crash

#3
hase091

hase091

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Florence

Mail, Reminders, Notes, Facetime crash



the log are not the same, i think that was another problem.

however, i'm trying to do that

Thank you very much eep357.

1-Start my clean install of OS X 10.8.
2-Mount image OSx10.8 Installer.
3-I opened the folder "Packages".
4-Run the installer packete "essentials.pkg"
5-Reboot and everything works fine.

Again, thank you very much.

Best regards.


hope it works :-)

#4
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 723 posts
  • Gender:Male
  • Location:Budapest, Hungary
The error message says it's having some problem with the location services framework. Maybe some kind of permission problem?

#5
hase091

hase091

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Florence

The error message says it's having some problem with the location services framework. Maybe some kind of permission problem?


maybe... how to fix the permissions? ^_^

However, reinstall essentials.pkg doesn't work for me. :(

in my "noob mind", reading online i've seen that (how nyolc8 say) is a problem of framework, so i've tryed to install the SDK hoping that it fix the libraries... doesn't work too :'D

#6
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
/System/Library/Frameworks/CoreLocation.framework/Versions/A/CoreLocation is installed as part of the BaseSystemBinaries.pkg. There are parts of that framework included in a few of the different packages, but the file referenced in your error log is in the above pkg. permisions should be -rwxr-xr-x size 1,154,144 bytes checksum 3524175746

reinstallation of the BaseSystemBinaries.pkg will prob be easiest method, if still an issue use Pacifist to verify your current install and it's permissions against the ML installer app.

#7
bajabronco

bajabronco

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
I had the exact same problem, I had to re-install, and then it worked fine.

#8
hase091

hase091

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Florence
I don't know if this can be a problem, but i've followed this guide to install OSX:

http://www.insanelym...howtopic=280756


However, i've used Pacifist to scan all the usb boot of ML done with that guide and that's the log:

https://docs.google....VFhyd19QREhUTDg

(it's in italian language :-/ sorry)

So....
the only way is to format all?
should i'll modify something before the install?
do i need to re-initializing the Hdd or i just need to do a "re-install?
and.. i've another usb hdd with iAtkos Lion L2 (perfectly working) and all my files. should migration assistant create problems like this? (after this installation, at the third boot i've used it to recovery my profile)

#9
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
I can't view your doc, but don't scan your installer as it is not a complete install and still has all the packages in their pkg form and none of the files are extracted, Pacifist will throw a million errors. You would scan the completed installation on your HD. Anyway if you haven't, I would just run the BaseSystemBinaries.pkg again, then reinstall Chameleon as I'm not sure which package it is, but one of the Base packages will overwrite one of the Chameleon boot files and give a Boot 0 error, just run the chameleon installer after the BaseSystemBinaries.pkg, then reboot.

#10
hase091

hase091

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
  • Gender:Male
  • Location:Florence

run the BaseSystemBinaries.pkg again, then reinstall Chameleon, then reboot.


IT WORKS! :D

thanks so much! :-)

Now i need to refix imessage and the appstore (everytime i change account, it stop to work -.-) but i know how to do :-P

Thanks again!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy