Jump to content

Reboot after Kext loading


  • Please log in to reply
7 replies to this topic

#1
Testo

Testo

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hello,

I´m trying to install Mountain Lion GM on my PC but it restards after loading the Kext files.

My PC:
ECS G31T-M7 V1.0
Core2Quad q8200
4GB Ram (2x á 2GB)
ATI Radeon 6950 1GB
2x 500GB Sata HDD (on drive C: is Windows 7 and on drive D: is iAtkos L2 and the Windows Bootloader)

#2
smorf

smorf

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
  • Location:Pacifica, CA
same thing here. i just can´t figure out what the cause is, as it instantly reboots after loading the kexts. is there a way to log the output during boot? any other ideas?
hardware config details in my signature.

#3
fffeee

fffeee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
I had this problem, updating to a newer build of Chameleon let me boot into the Window Server but now I'm just at a white screen with a pointer and no Installer.

#4
Jimsen2020

Jimsen2020

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Same problem.

#5
fffeee

fffeee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
My situation is sorted out now, I updated my SVN repository for Chameleon and installed from the dev trunk, and then removed the ATI6000Controller from the installer USB flash drive I was using.

Booting with GraphicsEnabler=No after that worked enough to get me into the installer, and then installation went smoothly.

The newfangled ATI/AMD kexts have some changes -- the kexts on the ML install image will not work if you have a non-reference 6870 or probably any other card in that family. I had to create a custom personality for my Sapphire 6870 in Lion, and I will likely have to do that in ML as well. In the mean time I am using the ATISupport and ATI6000Controller and ATIFramebuffer kexts I used in Lion and it's working great with full acceleration now.

Obviously this isn't ideal, but until I get around to creating a new personality in the ML kexts that's what I need to do. (The methods for creating those needs to be changed a bit too since the binary inside the bundle is not called ATI* anymore, but AMD*, so the ati-personality.pl script needs to be updated)

#6
Testo

Testo

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Thanks I will try it out now. I hope it works :)

#7
Testo

Testo

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Same problem anyway :help: I have a XFX 6950 can to tell me how i can get full acceleration on my Lion Hackintosh?

#8
fffeee

fffeee

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
This thread: http://www.insanelym...ic=273937&st=60 will discuss creating a custom personality and the more recent posts will direct you to updated tools to find the right offsets in the Mountain Lion kexts.

Have fun!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy