Jump to content

OS X Mountain Lion no carga la instalación (Solucionado)

- - - - -

  • Please log in to reply
15 replies to this topic

#1
Argentum_90

Argentum_90

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Hola, estoy intentando instalar Mountain Lion en mi Hackintosh pero no hay manera, el instalador no carga y me da kernel panic.

He usado una imagen retail de 10.8.0 y me he creado una unidad USB arrancable con MyHack, que te lo deja todo preparado. Mi placa no soporta HPET, o al menos yo no se dónde se activa. El error me lo da con o sin los C Estates del procesador activados desde la BIOS. Esta es la imagen del kernel panic:

Posted Image

Gracias

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
Parece que no lee la carpeta Extensions del instalador, prueba copiar la carpeta Extensions de S/L/E para Extra/Extensions e boot com -f -v

#3
Wolf-Mac

Wolf-Mac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Location:Spain
A mi me ha pasado que, usando Kakewalk, me funciona el USB Boot con la ML 10.8 Golden Master y sin embargo no me funciona con ML 10.8 Retail. Acabo de comprobarlo

Ahí lo dejo como dato por si quieres probar con la GM

Con MyHack no me iba con la Golden Master, me falta probar la Retail desde MyHack a ver que pasa

EDITO: Ya me he dado cuenta, torpe de mi, se apagaba la pantalla pero el PC seguida andando

A veces al crear el USB Boot la opción GraphicsEnabler del org.chameleon.Boot.plist del USB se quedaba en NO, se entra al USB a Extra y se edita el archivo dejandolo en Yes y después del booteo ya se puede visualizar el instalador para empezar la instalación

Espero le sirva a alguien

#4
Argentum_90

Argentum_90

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
El Finder no me deja, me dice que ya existen esos archivos en la carpeta cuando no es cierto. No se por qué.

EDITO:

Sí que he podido pasar los Kext, pero me ha dado el kernel panic igualmente. Incluso he pasado el Fix de MyHack, donde dice claramente que está combinando los kext, y sigue dando kernel panic. Estos son los kext que me instala MyHack:

AppleACPIPS2Nub.kext, ApplePS2Controller, FakeSMC, Ispcidrv, NullCPUPowerManagement y Patched_10.7_Apple RTC.

Yo no ni teclado ni ratón PS2, no sé para qué me los pone. Mi org.chameleon.Boot.plist:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1024x768x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Timeout</key>
<string>5</string>
</dict>
</plist>


#5
Wolf-Mac

Wolf-Mac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Location:Spain
Mira en este hilo como tengo yo el org.chameleon.Boot.plist

http://www.insanelym...howtopic=281011

#6
Argentum_90

Argentum_90

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Me he bajado el Golden Master y probado a instalar con MyHack, pero sigue sin arrancarme la instalación. He probado por casualidad con un 10.7.3 retail que tenía por ahí, y MyHack me lo monta y puedo instalar. Pero el Mountain no :S

Alguna idea más por ahí?

#7
surfcaster

surfcaster

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 471 posts
lo mejor es olvidarse de Myhack y cosas por el estilo, hay una version de la GM dando vueltas por la red y subida desde Olarila en torrent, esta perfecta y esta tanto para montarla en un USB como para grabarla en DVD, software como Kakewalk, MyHack, Uni...., etc. hacen un trabajo "generalizado" y que es imposible funcione correctamente en todas las variaciones de hardware que llegamos a tener, no por ello dejan de ser interesantes, siempre hay quien no tiene la mas minima idea y tira de ello, yo mismo he probado las 3, decir que la unica que NO me ha funcionado es la ultima en el orden que las he nombrado pero dejemoslo asi ya que no son mas que un par de scripts que hacen lo que todos sabemos hacer ya, Wolf_Mac ya lo sabes de sobras restaurar BaseSystem, borrar acceso a packages, copiar en su lugar la carpeta packages que esta en la raiz, copiar esa media docena de archivos de sistema que estan en la raiz (boot, kernel, etc.) e instalar Chamaleon, una vez hecho usa tu carpeta Extra con el añadido en ella de FakeSMC y kext para AHCI si fuese necesario, ¿tan complicado es?, no lo creo, ademas hay por ahi una utilidad IMPRESIONANTE como es Kext Utility, creas una carpeta Extensions, metes en Extensions todos los kexts que necesites o creas necesitar, la arrastras a Kext Utility y te creara un archivo llamado Extensions.mkext y tan solo con ese archivo en Extra + el ocbp+smbios es suficiente para arrancar la instalacion en cualquier maquina.

#8
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,450 posts
  • Gender:Male
  • Location:Tru, Venezuela
Así es la cosa.

smbios.plist bien hecho + o.c.B.p con "UseKernelCache=No" + dsdt (& ssdt) + Extensiones + la caché híbrida.

Todo en "/Extra" ... y como requisito final instalamos Chameleon 2.1 en esa partición (GUID - Mac OS Plus) ... a correr!

Una recomendación post-instalación. Lo más sano es instalar todos los .kexts en /S/L/E y establecer "UseKernelCache=Yes".

#9
Argentum_90

Argentum_90

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Vale, me he olvidado de programas automáticos y me he cocinado mi USB de instalación a mano.

He seguido tu screencast al pie de la letra juanerson, y sigo teniendo Kernel Panic. El mismo de siempre: Can't perform kext scan: no kext summary.

Ahora me tarda un poquito más en el arranque por lo de la caché híbrida, así que eso está bien hecho. Tengo estos kext en el Extra/Extensions: FakeSMC.kext y NullCPUPowerManagement.kext

De lo que sí me he dado cuenta antes es que me decía algo de que no encontraba el DSDT.aml.

Os paso mi org.chameleon.Boot.plist y SMBIOS.plist para ver si están correctas:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1024x768x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<key>Timeout</key>
<string>5</string>
<key>UseKernelCache</key>
<string>No</string>
</dict>
</plist>


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosdate</key>
<string>29/02/08</string>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MP31.88Z.006C.B05.0829021410</string>
<key>SMboardmanufacturer</key>
<string>Apple Inc.</string>
<key>SMboardproduct</key>
<string>Mac-F42C88C8</string>
<key>SMfamily</key>
<string>Mac Pro</string>
<key>SMmanufacturer</key>
<string>Apple Inc.</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMserial</key>
<string>QT8212N5XYK</string>
<key>SMsystemversion</key>
<string>1.0</string>
</dict>
</plist>

Este es el DSDT.aml que he extraido con el DSDT SE, a ver si hay algo que se pueda arreglar o sería cuestión de ponerlo a pelo en la carpeta Extra:

http://cl.ly/2Z2n2X0C0m3l

#10
ctroncosor

ctroncosor

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 109 posts
- Del error se deduce que el problema es que no esta creada la cache que usa UseKernelCache así que como señalo correctamente juanerson hay que iniciar con No en esa opción

- Si el equipo no tiene HPET usar el flag ForceHPET=yes.

- Recordar agregar el flag arch=x86_64, así como npci=0x2000 o 3000 (de no funcionar como es un socket 775 usar los kexts de 10.6.7), es ML GM !!!

- Si aún así no parte claramente es un problema de como se construyo del instalador y es absolutamente valido lo señalado por juanerson, de hecho en olarila lanzaron hasta un HackBookt de ML, con 3 versiones, así que para que seguir usando myhack.

- Así que en resumen mejor arma el pendrive siguiendo el metodo retail.

Saludos

#11
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,200 posts
  • Gender:Male
a ver les dejo los hackboot para mountain lion retail.

el hackboot tiene graphicenabler yes
el hackboot-1 tiene graphicenabler no

Archivo comprimido.zip

#12
Argentum_90

Argentum_90

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
El lunes lo pruebo y os digo algo. Gracias!

#13
Wolf-Mac

Wolf-Mac

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 158 posts
  • Location:Spain

lo mejor es olvidarse de Myhack y cosas por el estilo, hay una version de la GM dando vueltas por la red y subida desde Olarila en torrent, esta perfecta y esta tanto para montarla en un USB como para grabarla en DVD, software como Kakewalk, MyHack, Uni...., etc. hacen un trabajo "generalizado" y que es imposible funcione correctamente en todas las variaciones de hardware que llegamos a tener, no por ello dejan de ser interesantes, siempre hay quien no tiene la mas minima idea y tira de ello, yo mismo he probado las 3, decir que la unica que NO me ha funcionado es la ultima en el orden que las he nombrado pero dejemoslo asi ya que no son mas que un par de scripts que hacen lo que todos sabemos hacer ya, Wolf_Mac ya lo sabes de sobras restaurar BaseSystem, borrar acceso a packages, copiar en su lugar la carpeta packages que esta en la raiz, copiar esa media docena de archivos de sistema que estan en la raiz (boot, kernel, etc.) e instalar Chamaleon, una vez hecho usa tu carpeta Extra con el añadido en ella de FakeSMC y kext para AHCI si fuese necesario, ¿tan complicado es?, no lo creo, ademas hay por ahi una utilidad IMPRESIONANTE como es Kext Utility, creas una carpeta Extensions, metes en Extensions todos los kexts que necesites o creas necesitar, la arrastras a Kext Utility y te creara un archivo llamado Extensions.mkext y tan solo con ese archivo en Extra + el ocbp+smbios es suficiente para arrancar la instalacion en cualquier maquina.



Pues gracias por tu explicación, ahora que llevo unos días seguidos en Hackintosh ya voy retomando de nuevo algo de práctica. Normalmente estoy en Linux y tenía todo este tema olvidado.

El caso es que yo me hice el USB Boot a mano como unas tres veces pero me saltaba algún paso de los finales y por eso siempre fracasaba

Estos hilos me estan sirviendo de nuevo para recordar, aprender y apuntar..

Saludos

#14
Argentum_90

Argentum_90

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Nada, no hay manera de conseguir arrancar el instalador. Sigo teniendo Kernel Panic. Os cuento qué hay en mi carpeta Extra a ver si entre todos llegamos a la solución:

DSDT.aml
Extensiones: FakeSMC y NullCPUPowerManagement (he probado con y sin ella). Están siempre el Extensions.mkext refrescado con el Kext Utility
Extensions.mkext

org.Chameleon.Boot.plist (he probado con el npci en 0x2000 y 0x3000)

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Graphics Mode</key>
<string>1024x768x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=X86_64 npci=0x3000 ForceHPET=Yes -v</string>
<key>Timeout</key>
<string>5</string>
<key>UseKernelCache</key>
<string>No</string>
</dict>
</plist>

SMBIOS.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosdate</key>
<string>29/02/08</string>
<key>SMbiosvendor</key>
<string>Apple Inc.</string>
<key>SMbiosversion</key>
<string>MP31.88Z.006C.B05.0829021410</string>
<key>SMboardmanufacturer</key>
<string>Apple Inc.</string>
<key>SMboardproduct</key>
<string>Mac-F42C88C8</string>
<key>SMfamily</key>
<string>Mac Pro</string>
<key>SMmanufacturer</key>
<string>Apple Inc.</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMserial</key>
<string>QT8212N5XYK</string>
<key>SMsystemversion</key>
<string>1.0</string>
</dict>
</plist>

Aquí os paso mi carpeta Extra en un .zip a ver si está todo en orden: http://cl.ly/0A3z0O0n3N2W

- Del error se deduce que el problema es que no esta creada la cache que usa UseKernelCache así que como señalo correctamente juanerson hay que iniciar con No en esa opción

- Si el equipo no tiene HPET usar el flag ForceHPET=yes.

- Recordar agregar el flag arch=x86_64, así como npci=0x2000 o 3000 (de no funcionar como es un socket 775 usar los kexts de 10.6.7), es ML GM !!!

- Si aún así no parte claramente es un problema de como se construyo del instalador y es absolutamente valido lo señalado por juanerson, de hecho en olarila lanzaron hasta un HackBookt de ML, con 3 versiones, así que para que seguir usando myhack.

- Así que en resumen mejor arma el pendrive siguiendo el metodo retail.

Saludos


No se a qué te refieres con la extensión de 10.6.7. Qué extension?

#15
Argentum_90

Argentum_90

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
Después de mucho tiempo dándole vueltas y vueltas, el problema no estaba en mi carpeta Extra ni en nada que hiciera mal creando el USB booteable. El error estaba en un ajuste de la BIOS. Por lo visto las ASUS P5Q están dando bastante follón, pero se soluciona con poner en Disabled el Max CPUID Value Limit.

Así el sistema arranca a pelo, sin complicarse mucho, con cualquier carpeta Extra genérica.

Igualmente, muchas gracias por la ayuda a Surfcaster y Juanerson

#16
davicon

davicon

    davicon59

  • Members
  • PipPipPipPipPip
  • 323 posts
  • Gender:Male
  • Location:Caracas - Venezuela
  • Interests:Diseo Grafico - Computacion - Tennis

Me he bajado el Golden Master y probado a instalar con MyHack, pero sigue sin arrancarme la instalación. He probado por casualidad con un 10.7.3 retail que tenía por ahí, y MyHack me lo monta y puedo instalar. Pero el Mountain no :S

Alguna idea más por ahí?

Veo que tienes como yo una GForce 8400 GS y al parecer el Moutain no la soporta, a mi no me deja pasar y al leer un grupo de kext, se reinicia, es cuando en verbose cambia la resolucion, nbo he podido solventarlo







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy