Jump to content

[Solved] F12 to Open/Close tray? (see page 4)

F12 Eject Tray Optical Drive

  • Please log in to reply
75 replies to this topic

#61
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
If you want to use ESB2 as mistudio did above, find SATA section in your DSDT and edit it adding device ID:
					   Device (SATA)
						{
								Name (_ADR, 0x001F0002)
								Method (_DSM, 4, NotSerialized)
								{
										Store (Package (0x02)
												{
														"device-id",
														Buffer (0x04)
														{
																0x81, 0x26, 0x00, 0x00
														}
												}, Local0)
										DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
										Return (Local0)
								}
DVD player and keyboard to eject will work and no orange icons on sata drives. Although there is more to it than just an "orange icon fix", that is what you will find it is often referred to as in DSDT patch/editors. Verify your own device address for SATA before adding, mine is at 0x001F0002 or 00:1f.2 in lspci

#62
JBX

JBX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
@eep357, I appreciate your help

I have installed and ran Ispci and for SATA I get:

00:1f.2 SATA controller [0106]: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller [8086:2922] (rev 02)

I noticed when I open my DSDT and look under SATA (for 0x001F0002) I see "device-id" already listed at line #4448. Is this correct or do I add/change the entry? sorry I'm newbie at this, I tried to edit it but got errors every time. If you get chance can you please take a look at it. I've attached the file.

Attached Files



#63
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Try this.

Attached Files



#64
JBX

JBX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
@eep357. replaced and re-booted but still not working.

#65
hugeschnauzer

hugeschnauzer

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 237 posts
I can't burn dvd anymore since M Lion...

#66
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

@eep357. replaced and re-booted but still not working.

check system profile/sata and see what is listed as the controller. ICHx, generic or ESB2?

#67
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Also latest version of Fabio's Enoch branch of Chameleon includes a module to address this issue referred to as "yellow icon fix". In the installer, choose customize to install it.

#68
hugeschnauzer

hugeschnauzer

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 237 posts
It shows ESB2.

Its very annoying because i need to burn some Idvd edits..

Any hint?

Tks a lot again eep357

#69
JBX

JBX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
update chameleon using latest Enoch branch and yellow icon fix, however DVD Player was not fixed when I restarted. After another restart...

I have a different problem now. Somethings a mess with Chameleon and I can no longer boot my ML HD. I have Chameleon on it's own partition. Will try and fix (I'm in Win 7 HD atm).

#70
hugeschnauzer

hugeschnauzer

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 237 posts
Burned sucessfully with Toast.

tks

#71
JBX

JBX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
Fixed my boot and back in ML. I think the newer boot loader installers mess my system up. Anyway is there a way to get the fix for DVD Player and Eject without using those installers?

#72
zeisaac

zeisaac

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
Hello, i need a help...

before i instaled the ML my eject button works fine but now at ML it wont work.

i have Apple Keyboard Wireless.

Please some one help me.

Attached Files



#73
janel_f

janel_f

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
success!
i've just install this kext and open/close tray it's working again, just like in Lion.
same with the DVD Player app.

Attached Files



#74
JBX

JBX

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 174 posts
  • Gender:Male
@janel_f, Thanks a lot, seems to work perfectly.

#75
max.1974

max.1974

    InsanelyMac Geek

  • Donators
  • 135 posts
  • Gender:Male
  • Location:Brazil - Paraná
THANKS MAN!!! GREAT JOB!!!!

#76
naquaada

naquaada

    Gates crusher

  • Donators
  • 360 posts
  • Gender:Male
  • Location:Germany

Hello, I'm digging out this old thread because I have this problem in Mavericks 10.9.5.

 

As usual, holding F12 ejects the DVD and Ctrl+F12 opens the restart requester. That worked afer a clean install in 10.9.0 (including transferred user account) but after the update it doen't work anymore. In other programs the F-Keys have their functions, in the Finder the keys F1 - F12, and Print/Scroll/Pause do nothing and just bring the error sound. Everything what happens is that in the Finder the last icon is selected. An exception is the F5 key, which also selects the last icon, but doesn't give out an error sound.

 

This error occurs on my Gigabyte GA-Z77-DS3H. I also have Snow Leopard on it installed, there is no error. The error also doesn't appear on my Zotac board and my Dell XPS One A2420. I'm using the menu tool 'Butler' and if I want to assign a hotkey to F1-F15 it shows a message that this key is already assigned. Is there a method to find assigned hotkeys? There's nothing in 'keyboard->shortcuts'. The problem also exists if the Finder is deactivated.

 

EDIT: Weird. It's an older mouse/keyboard combination 'Logitech Cordless Internet Pro', with a bigger RF receiver with one USB and one PS/2 connector. I installed the 'Logitech Control Center' for Mavericks and now I have some more settings for the mouse, but not for the keyboard. The error was still there. Then I changed the keyboard to another USB port - The eject and shut down functions are working again!








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy