Jump to content

Can't get Realtek 8111C to work


  • Please log in to reply
6 replies to this topic

#1
Spanky Deluxe

Spanky Deluxe

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 131 posts
I've got my system up and running in DP4, sound, multi-display etc. Everything works absolutely fine except for the networking. I can't get anything to work. I've tried AppleRTL8169Ethernet.kext and RealtekRTL81xx.kext to no avail, my built in ethernet just isn't detected.


My board is an Asus Rampage Gene II that other people seem to have got ethernet working before on. Up until now I've been running Lion 10.7.3 and ethernet worked fine.

Any ideas?

#2
giofrida

giofrida

    InsanelyMac Italy

  • Members
  • PipPipPipPipPipPipPip
  • 667 posts
  • Gender:Male
  • Location:Italy
Have you tried to install the driver from Realtek site?
Here's the link:
CLICK HERE!


Scroll down where you see "Others", so download "MacOS 10.7 on Intel-based Mac computer" Package. Then, download it.

Bye,
-giofrida

#3
JamesLittler

JamesLittler

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,022 posts
  • Gender:Male
  • Location:Portsmouth, England
RTL81xx.kext requires a vanilla IONetworkingFamily.kext.

If you have any non-default plugins contained within IONetworkingFamily it will not work!

Add
EthernetBuiltIn=yes to your org.chameleon.boot.plist

#4
Spanky Deluxe

Spanky Deluxe

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 131 posts

Have you tried to install the driver from Realtek site?
Here's the link:
CLICK HERE!


Scroll down where you see "Others", so download "MacOS 10.7 on Intel-based Mac computer" Package. Then, download it.

Bye,
-giofrida

RTL81xx.kext requires a vanilla IONetworkingFamily.kext.

If you have any non-default plugins contained within IONetworkingFamily it will not work!

Add
EthernetBuiltIn=yes to your org.chameleon.boot.plist


I've tried both of those to no avail. Luckily I had an Apple USB->Ethernet adapter kicking about so I'm using that for now but 100 MBps doesn't go too far when you've got a 70 Mbps broadband connection and the computer in question is a Plex server!

#5
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
For mine(same chipset), I had to use IONetworking from DP3, DP4 version with plugin would not work

#6
Spanky Deluxe

Spanky Deluxe

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 131 posts

For mine(same chipset), I had to use IONetworking from DP3, DP4 version with plugin would not work


Is there any chance you can upload the DP3 IONetworking version?

#7
Derty

Derty

    InsanelyMacaholic

  • Donators
  • 3,165 posts
  • Gender:Male

RTL81xx.kext requires a vanilla IONetworkingFamily.kext.

If you have any non-default plugins contained within IONetworkingFamily it will not work!

Add
EthernetBuiltIn=yes to your org.chameleon.boot.plist


thats is correct, my two 8111c work correctly.



my kext in extra folder, no need nothing more.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy