Jump to content

[How To] Lenovo z370 (i3-2330m HD3000(8086 0116))

- - - - - hd3000 is 2330m z370 80860116 0x80860116 8080 0116

  • Please log in to reply
119 replies to this topic

#101
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
you would have to do it in the terminal (i'm not giving you a tutorial of how to do this, google is your friend).
in theory you shouldn't make it unable to boot if your playing with battery kexts but its not impossible.

i think you'll find a dsdt edit is necessary to make the sensor work without panic but given your a newbie to os x i would imagine this is beyond you. in a few weeks time i will be working on it

#102
pflaume

pflaume

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
your right, i'm a total newbie to os x and it sounds like it's way beyond my knowledge. thought it would justbe like installing the other kexts :/

#103
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
by all means try to install the battery kexts but don't expect it to be stable when running them.

did you mange to replicate the panic you got before?

Other people seems to have a stable rig with the set-up you have so there's no reason you shouldn't have provided you can live without the battery sensor hence if you can get me a print screen of when it panics i should be able to sort it

#104
pflaume

pflaume

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
I installed them via KextUtility and til now everything works fine - I'm confident that those two kexts will do the job ... at least I hope they will do the job :D

#105
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
Just make sure your booting with -v then when it panics you can tell its the battery kexts which are causing it (if yours doesn't panic with them installed you'll be the only person out of everyone I've helped where it doesn't - usually takes a couple of hours for it to happen)

#106
pflaume

pflaume

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
Laptop was running since my last post and I rebooted it 10 min ago (-v activated all the time), but until now there was no kernel panic. Seems to work pretty good.
So keep your fingers crossed ;)

DAMN-GOOD-NEWS-EDIT: I'm using the kexts for almost a day now and they work like a charm :) Had no kernel panics or something else disturbing. May you test them too, so we can be sure that they'll work?

#107
pflaume

pflaume

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
Does your vga- or hdmi-port work?

I tried to connect my tv (tried both ports) yesterday, but nothing happened.

#108
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
I have tested them, so have others. It will cause panic, give it time.

My HDMI works fine but you have a different graphics card / processor to me so unfortunately i can't help you there (although others with the same set-up as you have it working so it must be possible)

#109
pflaume

pflaume

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
Okay, I will wait :) Just read that Apple may put nvidia cards in their MacBooks next year, so may nvidia optimus will work then.

I just took a look inside my systeminformation and I'm a bit confused. It shows me that there's the Intel HD3000 as graphics card and that my screen is on the nvidia card. Is that right or am I getting this wrong?

Posted Image
Posted Image

#110
pflaume

pflaume

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
Hey rockinron, are there any news on working battery kext? Would be great having that :)

Regards

#111
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
Hey pflaume,
As for development I currently I have full s3 sleep working perfectly with the sole exception that on-board audio doesn't work on wake (I know why but not sure if it can be fixed or not yet).
As for the battery sensor: I have yet to find a way to make this work but I haven't spent much time trying. Unfortunately I have tried the usual ways of making battery sensors work on mountain lion with the same results (kernel panic). With the release of mountain lion coming at the end of this month I don't plan on working on a battery sensor until then but at the moment it seems unlikely I will have the spare time to make it work. Rest assured if I do get it working I will update this guide as soon as I am confident it is stable.

#112
pflaume

pflaume

    InsanelyMac Protégé

  • Members
  • Pip
  • 29 posts
Sounds pretty good. On the new MacBook 15" are nVidia cards, do you think it's possible to get our nVidia card working?

#113
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
I don't have the nvidia card on mine so I can't provide you with a guide to make it work. Others have got it working fine though so I don't see why you shouldn't. If you look in the attachment to the original post there will be the smbios for a mac pro 8.3. I suggest you copy this to /extra on your hdd and see if your nvidia card works. Also check its enabled in the bios. After doing this if it doesn't boot type

PCIRootID=0

at the chameleon boot screen.

#114
ijustwanttodownloadstuff

ijustwanttodownloadstuff

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
Well, I am finding myself installing again as I accidentally deleted my partition table :P
This time I am getting kext errors when trying to boot the installed volume. I install it, install the bootloader, install the kexts, copy the "Extra" Folder, repair my permissions, and copy the boot1h file fine. But when I try to boot after the installer freezes at "kext failed to load: com.apple.AppleLPC" I have tried without the dsdt.aml as well which does not seem to change the result.

#115
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
Just to clarify... You make the installer, install OS X, then it doesn't boot?

Have you made it back to the desktop since you tried reinstalling it?

I ask because it sounds like you haven't got to the desktop but you say you have installed my extra folder. As of step 2 of the guide you should have OS X on your laptop only then do you use any of my files...

#116
ijustwanttodownloadstuff

ijustwanttodownloadstuff

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
Yeah, I can boot the desktop from the USB, the problem is when I try to boot directly (using the chameleon bootloader I installed), I cant see why it's acting differently this time though as I did the same steps as last time!

#117
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
If you're still getting this problem boot with -v and post a screenshot of when it stalls, not immediately sure whats causing it.

Alternatively you could try installing ML:
http://www.insanelym...l=&fromsearch=1

#118
ijustwanttodownloadstuff

ijustwanttodownloadstuff

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
I guess I'll try ML as it's newer anyway. Thanks for the link and tutorial.

#119
ijustwanttodownloadstuff

ijustwanttodownloadstuff

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
I have installed ML but when I boot it (from the USB) I get a KP straight away. I have tried various things but can't seem to get round this. Any ideas?

#120
rockinron_1

rockinron_1

    InsanelyMac Sage

  • Retired
  • 396 posts
  • Gender:Male
  • Location:UK
Re-do part 6 of the guide I link to in the mountain lion guide and ensure you don't get any errors. Also please keep ML questions on that guide rather than this one.





Also tagged with one or more of these keywords: hd3000, is, 2330m, z370, 80860116, 0x80860116, 8080 0116


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy