Jump to content

[GUIDE] 10.6.8 on a Dell Optiplex GX620

gx620 Dell Optiplex GX620

  • Please log in to reply
107 replies to this topic

#61
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,508 posts
  • Gender:Male
  • Location:Tampa, Florida

The problem is the on board network card is dead.
So when in Windows I used an Intel ethernet card in the PCI Slot.
The card was found after the 10.6.3 install (natively) using the os x 86 mod CD bootloader to install the OS.
I upgraded to 10.6.8 as instructed and now there's no ethernet card in the PCI Slot... System Profiler reads as if there's no card at all.

I tried all available Kext's but no joy... any suggestions or help?

PCIRoot=1
or the files
AppleACPI from 10.6.7

#62
GR Ant

GR Ant

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi,

Thanks for the response. I used the AppleACPI from 10.6.7 method... no change. The OS can't see my PCI Ethernet Card! Any other suggestions???

Thanks
G

#63
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,508 posts
  • Gender:Male
  • Location:Tampa, Florida

Hi,

Thanks for the response. I used the AppleACPI from 10.6.7 method... no change. The OS can't see my PCI Ethernet Card! Any other suggestions???

Thanks
G

what smbios.plist model u using. is it done properly (chameleon wizard or champlist)
in dsdt
Device (PCI0) under it it shows_UID, 0x00 or ??

#64
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

The problem is the on board network card is dead.
So when in Windows I used an Intel ethernet card in the PCI Slot.
The card was found after the 10.6.3 install (natively) using the os x 86 mod CD bootloader to install the OS.
I upgraded to 10.6.8 as instructed and now there's no ethernet card in the PCI Slot... System Profiler reads as if there's no card at all.

I tried all available Kext's but no joy... any suggestions or help?


I would get the IONetworkingFamily.kext from 10.6.3 right click on it and show package contents. Then open the Plugins folder. Move your IONetworkingFamily.kext from 10.6.8 on to your desktop and do the same thing to open its Plugins folder. Compare the two Plugins folders, move anything that is missing in 10.6.8 over from 10.6.3. Re-install the 10.6.8 IONetworkingFamily.kext.

#65
GR Ant

GR Ant

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
It's working!!!

I have onboard graphics, sound and now PCI Card ethernet.

I took Cerastez's advice and copied the IONetworkingFamily.kext from 10.6.3. - specifically the kext inside the plugins folder (AppleIntel8255x.kext).

I updated to 10.6.8 as instructed and rebooted.

I ran kext wizard and installed AppleIntel8255x.kext into the Extra Folder on Root drive. Rebooted and everything works!

I do have a couple more questions - I have an ati X600 - I downloaded every kext and have one for the x600, should I install the kext??? And, ram, I have 2x 2gb ram chips installed, but have an extra 2x1GB ram chips to fill up the empty slots - would this work???

A big thanks to everyone's help here, I'm up and running. :-)

#66
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Hello. No. only onboard video card Intel® 82945G Express.
And this is ultra smal factor version. But the same specs as yours. Bios A11.

Now I'm trying to follow your guide with the 10.6.3 retail disk.
OK same there I've just instaled 10.6.3 then myhack 1.1 then DSDT edits. I've skip the combo 10.6.8 restarted and the same grey screan appears. I'll use M@ultiBeast with ##### mode because I'm not super user :) and will see what happened.

Posted Image
No luck with easyDSDT computer restarts about half a second after apple logo :( I don't have any ideas how instal Snow Leopard on this maschine :(

OK I think I've found the problem. I've aplied yours guide to DSDT Editor but skiped patch for video. And after restarts system boots. So I should use different patch for the graphic. Maybye laptop version?

What do you think?


I just spent 3 days trying to install on an Ultra Small Form Factor. I was using a DVI to VGA adapter to connect to my monitor. That was a big mistake. Everything worked smoothly once I extracted my DSDT while connected with a DVI cable. Who knew it was so important to use a DVI cable.

#67
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

I just spent 3 days trying to install on an Ultra Small Form Factor. I was using a DVI to VGA adapter to connect to my monitor. That was a big mistake. Everything worked smoothly once I extracted my DSDT while connected with a DVI cable. Who knew it was so important to use a DVI cable.


Hey Cerastez. Why don't you just applied AppleIntelIntegratedFramebuffer.kext which works for my little Dell?

#68
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Hey Cerastez. Why don't you just applied AppleIntelIntegratedFramebuffer.kext which works for my little Dell?


I did try it, but I never could get it to work. It would start and get to my desktop picture but the menu bar and things on my desktop never appear.
Are you using a VGA adapter to connect to your monitor?
Do you use a DSDT file and the AppleIntelIntegratedFramebuffer.kext? Or just the kext?
Did you use a newer Chameleon? Any special settings?
Did you upgrade to 10.6.8 or did you stay at 10.6.3?

#69
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

I did try it, but I never could get it to work. It would start and get to my desktop picture but the menu bar and things on my desktop never appear.
Are you using a VGA adapter to connect to your monitor?
Do you use a DSDT file and the AppleIntelIntegratedFramebuffer.kext? Or just the kext?
Did you use a newer Chameleon? Any special settings?
Did you upgrade to 10.6.8 or did you stay at 10.6.3?


1. For the first time I've used a VGA adapter so I was't able to use DSDT patch. So I've applied only AppleIntelIntegratedFramebuffer.kext in 10.6.3 without any DSTD patch and after upgrade to 10.6.8 I have to reinstal this kext because system upgrade modified it again. So from that time I was able to use this graphic card with almost any resolution. Now I'm not using any VGA adapter and maybe DSDT patch should work?

So only AppleIntelIntegratedFramebuffer.kext - No special settings.

2. I've upgraded Chamelon with Champlist software to v2.1VS r1817 and everything still works.

3. I have small artifacts when I'm using special programs like Photoshop or Cubase but only with mouse pointer. so sometimes I have to refresh screen with expose or dashboard when I have two pointers on screen.

4. Sometimes I'm losing volume control with dedicated keystrokes or menu bar slider but it only happens when I'm using special audio programs like Cubase or Wavelab. So I think the audio kext isn't perfect for this onboard card.

5. I strongly recommend you to instal Applejack for ability to repair permissions in single user mode. I have had small problems with permissions when I was trying to apply different kext to graphic to solve problems with artifacts. But for for now I stay with first solution because it works best.

Do you have any artifacts with mouse pointer with this DSDT patch?

Kind regards, Pablo

#70
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA
I was able to get the AppleIntelIntegratedFramebuffer.kext to work like it is supposed to in 10.6.3, but once I upgraded to 10.6.8 it didn't work anymore. I did reinstall it and fixed the permissions, but it would only show my desktop picture with no tool bar or dock.

Did you use an efi string?

I am certain that you will be able to use the DSDT if you are connected to your monitor with a DVI cable. I don't get any artifacts with the DSDT.

I would like to connect my GX620 to my TV and use it as a media center, but the TV only has a VGA connector.

#71
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

I was able to get the AppleIntelIntegratedFramebuffer.kext to work like it is supposed to in 10.6.3, but once I upgraded to 10.6.8 it didn't work anymore. I did reinstall it and fixed the permissions, but it would only show my desktop picture with no tool bar or dock.


It's because of incorrect resolution or screen refresh. The same thing happen to me then I have connected it to my 21' 1900x1200 monitor via VGA adapter only desktop picture appears - nothing more. So you have to connect to different monitor maybe?

Now I can use VGA adapter or DVI. I've used this machine for that purpose you want - media center and I've connected it to the TV via DVI to HDMI adapter. Whey are very cheep. It works great even with XBMC for MAC. I have TV with 1360x768 resolution so it worked really smooth.

Try to check artifacts with the Photoshop.

#72
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Hey Cerastez. I've instaled AppleIntelIntegratedFramebuffer.kext from my macbook oryginal 10.6.8 and applied DSDT patch from your first video tutorial but I can't boot to desktop right now.

I've connected monitor via DVI extracted DSDT applied 2 patches, copied dsdt.aml to extra folder... and it didn't boot so I think I should stay with modified kext on my machine?

or mabye if you can send me your dsdt.aml I'll give him another chance.

#73
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Sorry to take so long to respond. I have attached my DSDT file. I did try photoshop and there are no artifacts when I used it. I bought a DVI to HDMI adapter and it works perfectly!!

Attached Files



#74
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Sorry to take so long to respond. I have attached my DSDT file. I did try photoshop and there are no artifacts when I used it. I bought a DVI to HDMI adapter and it works perfectly!!



Hi Cerastez. Thank you for your DSDT file. I've compared them and they look very similar. Both have same number of lines and exact same file size. So I really don't know why I can't even boot this machine with DST patch.

Mabye I shoud use different AppleIntelIntegratedFramebuffer.kext from 10.6.3? Or my computer is different than yours?
I noticed one difference - then draging DSTD.aml to extra folder I don't need to autenticate anymore. Is just copied.

Here is my sceenshot from EFI list

Posted Image
my artifacts are only with the mouse pointer but few things doesn't work as it should so thats why I'm trying to use DSDT patch.

#75
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Hi Cerastez. Thank you for your DSDT file. I've compared them and they look very similar. Both have same number of lines and exact same file size. So I really don't know why I can't even boot this machine with DST patch.

Mabye I shoud use different AppleIntelIntegratedFramebuffer.kext from 10.6.3? Or my computer is different than yours?
I noticed one difference - then draging DSTD.aml to extra folder I don't need to authenticate anymore. Is just copied.

Here is my sceenshot from EFI list

my artifacts are only with the mouse pointer but few things doesn't work as it should so that's why I'm trying to use DSDT patch.


Our computers are the same. My EFI list looks just like yours. I have had trouble with DSDT files that I had extracted when I had already upgraded to 10.6.8. The only DSDT files that I have gotten to work are ones where I extracted the file in 10.6.3 and I had not yet done any hackintosh stuff to the computer, ie no EXTRA folder or special kexts. Please do try my attached DSDT.aml file. I know that it works.

Also I have been using MyFix to set all the permissions correctly.

#76
pabloscotty

pabloscotty

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

Our computers are the same. My EFI list looks just like yours. I have had trouble with DSDT files that I had extracted when I had already upgraded to 10.6.8. The only DSDT files that I have gotten to work are ones where I extracted the file in 10.6.3 and I had not yet done any hackintosh stuff to the computer, ie no EXTRA folder or special kexts. Please do try my attached DSDT.aml file. I know that it works.

Also I have been using MyFix to set all the permissions correctly.


OK. I've tried :( copied AppleIntelIntegratedFramebuffer.kext (from 10.6.8), used myFix for permissions and something, copied yours DSDT file to extra folder. After reboot my screen goes gray:

Posted Image

So I give up :( but anyway thank you very much for your help.

#77
bartmac86

bartmac86

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Hi there all... Thank you @ topicstarter for the nice how-to, I've read it a 100 times, and even printed it! I prepared everithing, and tried to install it on a second disk (disconnect the old 10.5.X-one)

However, I still dont have a working 10.6 dell gx620 after a 10-12 installs.
I had a 10.5.X working (I think Kalyway, but dont remember right), but it went broke (cant boot anymore) while trying to install 10.6 on another disk.

The problem I have:
- when booted the nawcomm (I have a P4HT, not a dual core), and press F5 he can't start reading the DVD (dual layer burned image)
- when using other install methods (iATKOS, Hazzard-distro, ..), some don't finish, other say the dvd is not complete, ...
- when I use the SnowLeo distro (the only one I can finish the install) there is a kernel panic (IATAOSFamily ?)

So, what would i like to know :
- I need to burn the dvd on a windows xp-system. Do I swap the dvd-unit, so the burning an reading is done with the same unit ?
- anybody has burning guidelines to burn that 10.6.3 image to a DL-DVD (what program and settings to use). Do I need disk-at-once or track-at-once? My writing program said it did successfully write the image, but there was a problem closing the session.
- how can I test the abovementionned DVD to check if it is fully readable, bootable (if needed), and closed correctly.
- a howto, what options (kext, kernels, ..) I need to select on that SnowLeo-distro --> this is my alternative to the howto of the topicstarter.
- my dvd is a PATA unit, the harddisk can be SATA or PATA (I have both, so pls say what has the best chances)


Please, It's starting to drive me mad. I started saturday morning te update process :)

System:
Stock GX620 (3Ghz HT cpu), but with added RAM (3gig now, instead of 1gig)

The DVD-drive is pata.

Thank you!

#78
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

Hi there all... Thank you @ topicstarter for the nice how-to, I've read it a 100 times, and even printed it! I prepared everithing, and tried to install it on a second disk (disconnect the old 10.5.X-one)

However, I still dont have a working 10.6 dell gx620 after a 10-12 installs.
I had a 10.5.X working (I think Kalyway, but dont remember right), but it went broke (cant boot anymore) while trying to install 10.6 on another disk.

The problem I have:
- when booted the nawcomm (I have a P4HT, not a dual core), and press F5 he can't start reading the DVD (dual layer burned image)
- when using other install methods (iATKOS, Hazzard-distro, ..), some don't finish, other say the dvd is not complete, ...
- when I use the SnowLeo distro (the only one I can finish the install) there is a kernel panic (IATAOSFamily ?)

So, what would i like to know :
- I need to burn the dvd on a windows xp-system. Do I swap the dvd-unit, so the burning an reading is done with the same unit ?
- anybody has burning guidelines to burn that 10.6.3 image to a DL-DVD (what program and settings to use). Do I need disk-at-once or track-at-once? My writing program said it did successfully write the image, but there was a problem closing the session.
- how can I test the abovementionned DVD to check if it is fully readable, bootable (if needed), and closed correctly.
- a howto, what options (kext, kernels, ..) I need to select on that SnowLeo-distro --> this is my alternative to the howto of the topicstarter.
- my dvd is a PATA unit, the harddisk can be SATA or PATA (I have both, so pls say what has the best chances)


Please, It's starting to drive me mad. I started saturday morning te update process :)

System:
Stock GX620 (3Ghz HT cpu), but with added RAM (3gig now, instead of 1gig)

The DVD-drive is pata.

Thank you!


I was just chatting with someone about who had similar problems to yours and he felt that it was due to having a PATA IDE DVE drive. My only experience with a PATA DVD drive is an install on a GX620 tower. It was awfully hard to get to work and I don't know if that was because of the PATA DVD drive or some quirk with the towers. Anyway I did finally get it to work. I used the latest Nawcom ModCD 0.3.2 The only real difference is when you are installing the system, the Nawcom's will try to install some kexts that you don't want installed. Once you are done formatting the drive and start the installation process, on some screen before you get to the "Install" button, there should be a button that says "Customize." Hit "Customize" and that will take you to a screen where you can un-check the box that says something like"special install." I didn't actually write down what the check box lable says. It is 'special or 'custom.' Anyway after that the instal will continue according to the tutorial.

I don't have any experience burning CDs with a PC so the only advice I can give you is burn at the slowest speed that you can. Use decent quality blank CDs. And if you have acces to a SATA DVD drive, it probably would work better.

#79
bartmac86

bartmac86

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

I was just chatting with someone about who had similar problems to yours and he felt that it was due to having a PATA IDE DVE drive. My only experience with a PATA DVD drive is an install on a GX620 tower. It was awfully hard to get to work and I don't know if that was because of the PATA DVD drive or some quirk with the towers. Anyway I did finally get it to work. I used the latest Nawcom ModCD 0.3.2 The only real difference is when you are installing the system, the Nawcom's will try to install some kexts that you don't want installed. Once you are done formatting the drive and start the installation process, on some screen before you get to the "Install" button, there should be a button that says "Customize." Hit "Customize" and that will take you to a screen where you can un-check the box that says something like"special install." I didn't actually write down what the check box lable says. It is 'special or 'custom.' Anyway after that the instal will continue according to the tutorial.

I don't have any experience burning CDs with a PC so the only advice I can give you is burn at the slowest speed that you can. Use decent quality blank CDs. And if you have acces to a SATA DVD drive, it probably would work better.


hi, thank you. It is a towermodel of the gx620 (and the dvd-reader is the one who came in it). Reading dvd's (like booting osX86 distro's) is no problem. When 10.5 was installed I was able to burn dvd's on that pata-dvd.

Yesterday I tried some other software (in wintendo) to burn the dvd: burn is successfull, but the data verification gives errors. So I need to go and find another way to have a 10.6.3 disk (need to buy a physical disk instead of buying the download :( ).

I guess, I narrowed the problem: or it is the quality of my DL-DVD-media, or my writer is no good at writing DL-DVDs.

#80
Cerastez

Cerastez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 160 posts
  • Gender:Female
  • Location:Bellingham, WA, USA

hi, thank you. It is a towermodel of the gx620 (and the dvd-reader is the one who came in it). Reading dvd's (like booting osX86 distro's) is no problem. When 10.5 was installed I was able to burn dvd's on that pata-dvd.

Yesterday I tried some other software (in wintendo) to burn the dvd: burn is successfull, but the data verification gives errors. So I need to go and find another way to have a 10.6.3 disk (need to buy a physical disk instead of buying the download :( ).

I guess, I narrowed the problem: or it is the quality of my DL-DVD-media, or my writer is no good at writing DL-DVDs.


The other fix would be to put the retail installer on a flash drive and install from that or if you have access to an external USB DVD drive, that would work as well.





Also tagged with one or more of these keywords: gx620, Dell Optiplex GX620

  Topic Stats Last Post Info

2 user(s) are reading this topic

1 members, 1 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy